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Preface

Who should read this guide
The audience for this document includes:
• Oracle Database Administrators who are experienced with Oracle Relational Database 

Management System (RDBMS), can edit and run PL/SQL scripts, and are familiar with their ERP 
system.

• Application Server Administrators who have J2EE technology knowledge.
• Windows Server Administrators who have Microsoft Windows experience and who can install and 

configure Windows applications and hardware.
• Customers who are planning a new installation or a migration from a previous release of any 

MarkView product.

Administrators should be familiar with MarkView system operation.

Related documentation
The documentation set for Kofax MarkView is available online:1

https://docshield.kofax.com/Portal/Products/MarkView/10.5.0-yw2qf8m7r6/MarkView.htm

In addition to this guide, the documentation set includes the following items:

Kofax MarkView Features Guide
Use this guide to learn about the features included and options available with MarkView; to become 
familiar with MarkView products; and to decide which are important to the business challenges 
you face and best suit your site. This guide includes information about how features impact the 
workflow, the interaction between features, the touch points with the ERP system, and how features 
address business problems.

1 You must be connected to the Internet to access the full documentation set online. If the 
security policy for your organization requires offline access (without an Internet connection), see
Offline documentation.
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Kofax MarkView Planning Guide
Use this guide to learn about the prerequisites for implementing MarkView products. This guide 
includes system information, such as the protocols required for communication between servers, 
hardware and software prerequisites, and minimum RAM requirements.
Use this guide in conjunction with the Kofax MarkView Technical Specifications document on the Kofax 
MarkView Product Documentation site to prepare a site for product installation.

Kofax MarkView Installation Worksheet
Use this worksheet to collect and record the information you need to install or upgrade MarkView 
products.

Kofax MarkView Upgrade Guide
Use this guide in conjunction with the Kofax MarkView Installation Worksheet to upgrade and 
configure MarkView products.

Kofax MarkView Integration Guide
Use this guide in conjunction with the Kofax MarkView Technical Specifications document on the Kofax 
MarkView Product Documentation site to learn about the prerequisites for implementing Kofax 
products and preparing a site for product installation.

Kofax MarkView Reintegration Guide for Upgrades to Oracle E-Business Suite R12 or 12.2
Use this guide to reintegrate MarkView after an upgrade to Oracle E-Business Suite R12 or 12.2.

Kofax MarkView Administrator's Guide, Volume 1
Use this guide to administer the MarkView system. This guide describes how to configure and 
maintain the applications, solutions, and users that make up the MarkView Suite. The guide also 
describes how MarkView influences the administration of other servers and software that interface 
with MarkView applications.
The MarkView Administrator should be well-versed in database administration, application server 
setup, tuning and maintenance, or should know where to get such information. The administrator's 
guide does not replicate this information, but conveys MarkView product-specific information.

Kofax MarkView Administrator's Guide, Volume 2
Use this guide to maintain MarkView components that are administered outside of the MarkView 
interface. This guide includes advanced administrative tasks and describes MarkView custom 
packages and join points.

Kofax MarkView Release Notes
Use this document to learn what is new with the latest MarkView release, identify outstanding 
defects and workaround solutions where applicable, and learn which defects the release fixes.

Kofax MarkView Technical Specifications
Use this document to learn about supported operating systems and other system requirements.
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Offline documentation
To make the documentation available for use in offline mode, obtain the documentation files from 
the Kofax MarkView product package that you downloaded from the Kofax Fulfillment Site. The 
product package includes the following documentation files for offline use:

• KofaxMarkViewDocumentation_10.5.0_EN.zip сontains the entire Kofax MarkView documentation 
set in English. This file is required for all users who work in offline mode. The .zip file includes 
both help and print folders. The print folder contains all MarkView guides in PDF format.

• Individual documentation .zip file for each of the following languages: Simplified Chinese, 
Brazilian Portuguese, Polish, Japanese, Italian, French, Spanish, and German. Contain only the 
localized MarkView Viewer help files.

For more information about accessing the MarkView help in offline mode, see Access the MarkView 
help.

Getting help with Kofax products
The Kofax Knowledge Portal repository contains articles that are updated on a regular basis to 
keep you informed about Kofax products. We encourage you to use the Knowledge Portal to obtain 
answers to your product questions.

To access the Kofax Knowledge Portal, go to https://knowledge.kofax.com.

 The Kofax Knowledge Portal is optimized for use with Google Chrome, Mozilla Firefox, or 
Microsoft Edge.

The Kofax Knowledge Portal provides:
• Powerful search capabilities to help you quickly locate the information you need.

Type your search terms or phrase into the Search box, and then click the search icon.
• Product information, configuration details and documentation, including release news.

To locate articles, go to the Knowledge Portal home page and select the applicable Solution 
Family for your product, or click the View All Products button.

From the Knowledge Portal home page, you can:
• Access the Kofax Community (for all customers).

On the Resources menu, click the Community link.
• Access the Kofax Customer Portal (for eligible customers).

Go to the Support Portal Information page and click Log in to the Customer Portal.
• Access the Kofax Partner Portal (for eligible partners).

Go to the Support Portal Information page and click Log in to the Partner Portal.
• Access Kofax support commitments, lifecycle policies, electronic fulfillment details, and self-

service tools.
Go to the Support Details page and select the appropriate article.
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Chapter 1

Introduction

With the Kofax MarkView solution, your employees can capture invoice images from multiple 
sources through Kofax Capture and move those electronic images into MarkView workflows for 
processing. Using electronic images eliminates the time that paperwork spends in paper mailing 
systems.

This guide provides important information about installing MarkView, including:
• System requirements that must be met to successfully install MarkView
• Database management requirements
• Preparations, decisions, precautions, settings, and tips to help you successfully and efficiently 

install MarkView
• Instructions for installing MarkView in silent mode
• Information about integration with other Kofax products used with MarkView
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Chapter 2

MarkView system requirements

The primary source of information about supported operating systems and other MarkView 
requirements is the Kofax MarkView Technical Specifications document which is available on the Kofax 
MarkView Product Documentation site.

Oracle patches
Oracle Accounts Payable processing requires Oracle patch 20725445:R12.AP.

If you plan to use the WebLogic application server with Oracle JDBC drivers version 12.1, apply 
Oracle patches 21043834, 20692348, and 19028811 on WebLogic. If you plan to use WebLogic with 
Oracle JDBC drivers version 11.2, verify that you use Oracle JDBC drivers 11.2.0.3 or higher.

See the Oracle website for more information.

WebLogic JDK for 64-bit WebLogic servers
The 32-bit versions of the WebLogic client come with a bundled JDK. For the 64-bit WebLogic client, 
you need a separate 64-bit JDK.

See the Oracle website for more information.
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Chapter 3

Plan your MarkView installation

If you are installing a Service Pack or a Fix Pack as well as MarkView, procedures may have changed 
since this guide was published. See the Service Pack Release Notes for the latest installation and 
configuration information. Also see the readme.txt file included in the Service Pack or Fix Pack 
software distribution for a list of required installers and scripts.

Install other Kofax products
Before you install MarkView, install and configure these other Kofax products:

• Kofax Capture: See the Kofax Capture Installation Guide.
• If you use Kofax Transformation Modules, also install Kofax Transformation Modules and create 

the Kofax Transformation Modules schema user. See the Kofax Transformation Modules Installation 
Guide and Help for Kofax Transformation Modules.

 MarkView automatically installs the default Kofax Transformation Modules project in C:\KTM
\Markview. When you follow the instructions in this guide to customize the project, you create 
a new runtime version of the project directory that stores the Kofax Transformation Modules 
project fpr file and all the files needed for the project.

Complete the Kofax MarkView installation worksheet
The installation worksheet is a Microsoft Word document that helps you gather and record the 
information to install and configure MarkView. Before you proceed, verify that you have completed 
all the applicable fields in the worksheet. Have the worksheet available as you install.

Installation checklist
Use this checklist to track the installation steps for your system.

14



Kofax MarkView Installation Guide for Oracle E-Business Suite

Task Section Notes Done?

Prerequisites Install other Kofax products Install and configure other 
Kofax products, such as Kofax 
Capture, before you install 
MarkView.
For MarkView for Account 
Payable (AP) with 
Transformation, also install 
Kofax Transformation 
Modules and create the Kofax 
Transformation Modules 
schema user.

MarkView system requirements

Complete the Kofax MarkView 
installation worksheet

Download and decompress 
distribution files

Set locale-sensitive environment 
variables

Create and configure schema user

Designate an Oracle user for 
MarkView Invoice Import for 
Oracle Open Interface (for Kofax 
Transformation Modules only)

Verify and Install Either:
• To use the MarkView silent 

installer, see Silent verification 
and installation.

• To use the MarkView interactive 
mode, see:
• Verify your environment
• Install MarkView

Set up Your Oracle 
Environment

Set up your environment and install 
MarkView Oracle Objects

Configure the 
Oracle Forms

Configure Oracle Forms

(Optional) Install
Capture and 
Output modules 
to control how 
documents enter 
into and are 
output from the 
MarkView system.

Capture and Output modules Capture and Output 
components include:
• MarkView Bar Code Server
• MarkView Mail Gateway
• MarkView Import Server
• MarkView Data Export 

Server (for MarkView with 
Kofax Transformation 
Modules)
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Task Section Notes Done?

(Optional) 
Configure 
MarkView for 
Accounts Payable.

Configure MarkView for Accounts 
Payable

Follow the steps in this section 
if your system includes 
MarkView for Accounts 
Payable.

(Optional) 
Configure the 
integration 
between MarkView 
and Oracle 
Internet Expenses.

Expense Management 
Configuration

To configure MarkView for 
Expense Management, you 
must have Oracle Workflow 
Builder installed and your 
system must include data.

(Optional) 
Configure Self-
Service Invoice.

Configure Self-Service Invoice Follow the instructions in this 
section only if you have Self-
Service Invoice installed.

(Optional) 
Integrate with 
other Kofax 
products.

Integration with other Kofax 
products

Follow the steps in this 
chapter to integrate with 
other Kofax products, such 
as Kofax Capture or Kofax 
Transformation Modules.

(Optional) Migrate 
Data

Migrate environments
Customization migration tools

If you are migrating your 
environment, review 
the information in these 
appendices.

 When installing Kofax MarkView, the existing Oracle personalizations get overwritten. To 
prevent data loss, back up your existing personalizations and after the installation is complete, 
restore the backup manually.

Download and decompress distribution files
Your Kofax representative will give you the location from which to download the compressed 
MarkView system setup files.

1. Log in to the application server host operating system as the application server owner.
2. Create the MarkView installation directory, for example <home_directory>/markview where

<home_directory> is the user home directory. This guide refers to the installation directory 
as <installation_directory>.

3. Create a temporary distribution directory for the compressed MarkView installer and 
verification files. For example, <home_directory>/mvdist where <home_directory> is the 
user home directory.

4. In the distribution directory, create the following subdirectories:
• <distribution_directory>/verify

• <distribution_directory>/installer

Where <distribution_directory> is the name of the directory you just created.
5. Download the following file into the verify directory:
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KofaxMarkView-<version_number>_Oracle_Verify.zip
6. Download the following file into the installer directory:

KofaxMarkView-<version_number>_Oracle.zip
7. Extract the files.

 The built-in ZIP utilities in certain versions of Windows have issues with lengthy directory 
paths. Kofax recommends using a third-party extraction utility to decompress the distribution 
files.

Pre-installation tasks

Set locale-sensitive environment variables
To avoid or resolve SQLExceptions that can occur with the MarkView verify or install program, adjust 
the locale settings on the application server.

The following is an example of an exception that may be logged in the installer log file when the 
verify or install program fails:
java.sql.SQLException: ORA-01403: no data found 
 ORA-06512: at "APPS.FND_DOC_CATEGORIES_PKG", line 345 
 ORA-06512: at line 68 
 ORA-06510: PL/SQL: unhandled user-defined exception

Such exceptions can occur when the language setting in the session on the application server 
where the MarkView verify or install program executes does not match any language in the Oracle 
EBS tables (for example, FND_LOOKUP_VALUES). Ensure that the locale-sensitive environment 
variables in the session on the application server are set to the primary language used in the 
Oracle EBS tables. For example, if the primary language used in the EBS tables is en-GB, set the 
LANG environment variable on the application server to en-GB before you run the install or verify 
program.

Depending on the operating system of the application server, other locale-sensitive environment 
variables may be defined. Ensure that any of these variables that is defined is set to the EBS 
language:
• NLS_LANG
• LC_TYPE
• LC_TIME
• LC_MONETARY
• LC_NUMERIC
• LC_MESSAGES
• LC_COLLATE

Create and configure schema user
The MarkView schema user is the MarkView database administrator.

17



Kofax MarkView Installation Guide for Oracle E-Business Suite

The scripts directory includes automated SQL scripts to help you create and configure the MarkView 
schema user. This directory may also include other scripts that you do not need to run. The steps in 
this section describe how to use each installation script.

The scripts directory is <distribution_directory>/installer/scripts (where
<distribution_directory> is the location where you downloaded and decompressed the 
installation files). The scripts directory includes:
• create_account.sql (for installations): Creates the MarkView schema user.
• create_tablespace.sql (for installation): Creates data and index tablespaces.
• gencomp.sql (for installations and upgrades): Checks for invalid packages, recompiles objects and 

resolves dependencies between objects. You will use this script after you install.
• markview_grant_privileges.sql (for installations and upgrades): Assigns grants and privileges to 

the MarkView schema user.

Create tablespaces
The data tablespace contains the MarkView database objects for the MarkView schema user. The 
index tablespace contains the MarkView database indexes. Use the create_tablespace.sql script to 
create data and index tablespaces for the MarkView schema user before you install.

 This script grants autoextend and maxsize unlimited to the tablespace. If you do not use this 
script to create tablespaces, ensure that autoextend is enabled.

1. Log in to the MarkView database as the SYSDBA.
2. Navigate to <distribution_directory>\installer\scripts, where

<distribution_directory> is the location where you downloaded and decompressed the 
installation files.

3. Create the data tablespace for MarkView. See the Kofax MarkView Planning Guide for 
information about database sizes.

a. Run create_tablespace.sql.

b. At the script prompts, enter the following information and make note of the values you 
enter:
• Tablespace name: The data tablespace name, for example MVD.
• Initial size (MB): The initial tablespace size.
• Max size (MB): Use the default to make the maximum tablespace size unlimited.
• Full pathname of the location of the tablespace: The full path and file name where the 

MarkView schema will reside.
4. Create the index tablespace for MarkView:

a. Rerun create_tablespace.sql.

b. At the script prompts, enter the following information and make note of the values you 
enter:
• Tablespace name: The index tablespace name, for example MVX.
• Initial size (MB): The initial tablespace size.
• Max size (MB): Use the default to make the maximum tablespace size unlimited.
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• Full pathname of the location of the tablespace: The full path and file name where the 
MarkView schema will reside.

Create schema users
Use create_account.sql as a guideline for creating the MarkView schema user. Run it as written or 
modify it to suit your purposes.

1. Log in to the MarkView database as SYSDBA.
2. Navigate to <distribution_directory>\installer\scripts, where

<distribution_directory> is the location where you downloaded and decompressed the 
installation files.

3. Run create_account.sql.
A list of available tablespaces appears.

4. At the script prompts, enter the following information and make note of the values you enter:
• Username: The user name for the MarkView schema user.
• Password: The password for the MarkView schema user.
• Database data tablespace name: The data tablespace for MarkView you created in Create 

tablespaces on page 18.
• Database index tablespace name: The index tablespace for MarkView you created in Create 

tablespaces on page 18.
• Name of the temporary tablespace: The name of the temporary tablespace.

Enable editions (for Oracle EBS 12.2 only)

 Only enable editions if you are integrating MarkView with Oracle E-Business Suite 12.2 or 
higher. Running this script with earlier versions of Oracle E-Business Suite will corrupt MarkView.

Use enable_editions.sql to make the MarkView schema editionable. Do not modify this script.
1. Log in to the MarkView database as SYSDBA.
2. Navigate to <distribution_directory>\installer\scripts, where

<distribution_directory> is the location where you downloaded and decompressed the 
installation files.

3. Run enable_editions.sql.
4. At the system prompt for the user name, enter the MarkView database schema name, for 

example, markview.

Assign grants and privileges to the MarkView schema user
The markview_grant_privileges.sql script assigns grants and privileges to the schema user. Do not 
modify this script.

1. Log in to the MarkView database as SYSDBA.
2. Navigate to <distribution_directory>\installer\scripts, where

<distribution_directory> is the location where you downloaded and decompressed the 
installation files.

3. Run markview_grant_privileges.sql.
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4. At the prompt, enter the MarkView schema user name you created in Create schema users.

Designate an Oracle user for MarkView Invoice Import for Oracle Open 
Interface (for Kofax Transformation Modules only)

The MarkView User must have a corresponding Oracle Security (FND_USER) record. The FND_USER 
should have privileges to create invoices; the MarkView Connector system uses FND_USER to submit 
invoices from the Kofax Transformation Modules process into the Oracle Payables Open Interface 
process. Invoices created from the MarkView Connector process list the FND_USER as the "AP 
Creating User" in Oracle.

Configure database logging directory
The MarkView schema requires a logging directory. There must either be a database utl_file_dir or 
you must have a directory for which the MarkView schema has write privileges. When running the 
installer, you will see a prompt on the MarkView schema window.

To configure the database logging directory:
1. Log in to the database host as the operating system user who owns the database for the 

MarkView schema.
2. Create a directory accessible by the database, for example, /<installation_directory>/

markview/markview_logs where <installation_directory> is the MarkView installation 
directory.

3. Grant write permissions to the directory, for example, chmod 1777 /
<installation_directory>/markview/markview_logs.

4. Log in to the RDBMS as SYSDBA.
5. Run the following SQL commands:

SQL> create directory mv_logs as '/<installation_directory>/markview/
markview_logs';
SQL> grant read, write on directory mv_logs to <markview_schema_name>;

A Grant Succeeded message appears.

Add SSL certificate to Oracle Wallet (for SSL only)
Skip this section if you do not plan to use Secure Sockets Layer (SSL) to provide secure web 
communications for the application server.

1. Log in to the Oracle EBS server as the EBS user.
2. If you do not have an Oracle Wallet, from the command line, run the following command to 

create Oracle Wallet and set the Oracle Wallet location:
orapki wallet create -wallet <WalletFolder> -pwd <WalletPasswd> -auto_login

3. Add the SSL certificate to the Oracle Wallet:
orapki wallet add -wallet <WalletFolder> -trusted_cert -cert "<certificate>" -pwd 
 <WalletPasswd>

Where:
• <WalletFolder> is a directory where Oracle Wallet files are located.
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• <certificate> is a file that contains the self-signed certificate or any other certificate 
received from the certificate authority.
If you have a certificate received from the certificate authority, verify that root and 
intermediate certificates from the certification chain are in the Oracle Wallet and run the 
indicated command to add the missing certificates.

• <WalletPasswd> is a password for the Oracle Wallet.

Add SSL certificate to the RDBMS Java truststore (for SSL only)
Skip this section if you do not plan to use SSL to provide secure web communications for the 
application server.

1. Log in to the RDBMS as SYSDBA.
2. Run the following SQL command to get the <java_home> value:

SELECT  dbms_java.get_ojvm_property(PROPSTRING=>'java.home') FROM dual

3. From the command line, run the following command to add the certificate to the RDBMS Java 
truststore:
keytool -import -alias <alias> -keystore <java_home>/jre/lib/security/cacerts -
file <certificate>

Where:
• <alias> is a keystore entry unique name.
• <java_home> is a Java installation directory.
• <certificate> is a file that contains the self-signed certificate or any other certificate 

received from the certificate authority.
If you have a certificate received from the certificate authority, verify that root and 
intermediate certificates from the certification chain are in the RDBMS Java truststore and 
run the indicated command to add the missing certificates.

The default Java certificate authority keystore is cacerts. The default password for cacerts is
<changeit>.

4. If you use Oracle EBS 19c database with SSL, perform the following procedure.

a. Check if <java_home>/jdk/jdk8/lib/security/ contains the cacerts.alt file. If the 
file exists, add a certificate to the cacerts.alt file as follows:
keytool -importcert -trustcacerts -keystore <java_home>/jdk/jdk8/lib/
security/cacerts.alt -storepass <password> -file <certificate> -alias 
<alias>

Where:
• <alias> is a keystore entry unique name.
• <certificate> is a file that contains the self-signed certificate or any other certificate 

received from the certificate authority.
If you have a certificate received from the certificate authority, verify that root and 
intermediate certificates from the certification chain are in the RDBMS Java truststore.

• <password> is a password. The default password for cacerts is <changeit>.

b. If the file does not exist, copy the cacerts file created on step 3 to <java_home>/jdk/
jdk8/lib/security/ and rename it to cacerts.alt.
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c. Log in to the RDBMS as SYSDBA.

d. If you use a pluggable database, switch to the PDB where the MarkView schema resides.

e. Run the following command to add the cacert.alt file to the RDBMS:
exec dbms_java.loadjava('-schema SYS -grant PUBLIC -dirprefix 
<java_home>/jdk/jdk8 <java_home>/jdk/jdk8/lib/security/cacerts.alt');

Create the certificate keystore (for SSL only)
Skip this section if you are not using SSL.

Run one of the following commands to create the certificate keystore:
• If you have a self-signed certificate for the application server, import the certificate to the JKS 

format keystore:
keytool -import -v -alias selfsigned -file <certificate> -keystore <keystore> -
storepass <keystorepassword>

• If you have any other certificate received from the certificate authority, import the certificate to 
the JKS format keystore:
keytool -importkeystore -srckeystore <certificate> -srcstoretype pkcs12 -
destkeystore <keystore> -deststoretype JKS -storepass <keystorepassword>

Where:
• <certificate> is a file that contains the self-signed certificate or any other certificate received 

from the certificate authority.
• <keystore> is a repository that contains your security certificate or certificates.
• <keystorepassword> is a password of the keystore.

Configure the WebLogic environment
If you plan to use the WildFly or JBoss EAP application servers, skip this section and continue with
Configure WildFly or JBoss EAP environments on page 29.

Before you proceed, verify that your system meets the MarkView system requirements.

Install WebLogic
To install and configure the WebLogic application server, refer to the WebLogic documentation.

Configure environment variables for WebLogic
Configure the environment variables for your WebLogic application server.

Set WL_HOME, MW_HOME, and ORACLE_HOME to your WebLogic installation directory. Set the 
JAVA_HOME variable and point it to the Java SDK installation directory.
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For WebLogic 12.1 only, run the installation configuration script to configure the WebLogic 
installation:

1. Run the installation configuration script.
• Windows: %MW_HOME%\configure.cmd
• UNIX: $MW_HOME/configure.sh

2. When prompted if you want to configure a new domain, enter N and press Enter to complete 
the configuration.

Create a new WebLogic domain and machine
1. Start the configuration wizard:

• Windows: %ORACLE_HOME%\oracle_common\common\bin\config.cmd
• UNIX: $ORACLE_HOME/oracle_common/common/bin/config.sh

2. Select Create a new domain and click Next.
3. Select Create Domain using Product Templates and Basic WebLogic Server Domain, and 

click Next.
4. In the Administrator Account window, specify the administrator's credentials and click Next.
5. In the Domain Mode field, select either the Production or Development environment.
6. Specify the appropriate JDK and click Next.
7. In the Advanced Configuration window, select the following check boxes:

• Administration Server
• Node Manager
• Managed Servers, Clusters, and Coherence (or Topology for WebLogic 12.2)

8. In the Administration Server window, specify Server name and Listen Address and Port.
Select Enable SSL, if required.

9. In the Node Manager window, specify Domain Location and Node Manager credentials.
10. In the Managed Servers window, leave the fields blank and click Next.
11. In the Clusters window, leave the fields blank unless you are deploying to a cluster and click

Next.
12. For WebLogic 12.2 only: In the Server Templates window, leave the fields blank and click Next.
13. In the Machines window, click Add, enter the following information for the machine, and click

Next:
• Name: markview_machine
• Node manager listen address: <HOSTNAME>
• Node manager listen port: <NODE_MANAGER_PORT>

14. For WebLogic 12.2 only: In Assign Servers To Machines:

a. In the column on the right, select Machine.

b. In the column on the left, select Server.

c. Use the arrow button to move the Server under the Machine and assign the server to the 
Machine.

d. Click Next.
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15. For WebLogic 12.2 only:

a. In the Virtual Targets window, leave the fields blank and click Next.

b. In the Partitions window, leave the fields blank and click Next.
16. In the Configuration Summary window, verify that all information is correct and click Create.

When the creation of the domain is complete, click Next.
17. In the End Of Configuration window, check Domain Location and Admin Server URL, and 

click Finish.
For WebLogic 12.2, verify that Start Admin Server is not selected.

18. Start Node Manager:
• Windows: <markview_domain>\bin\startNodeManager.cmd
• UNIX: <markview_domain>/bin/startNodeManager.sh

19. Start the domain:
• Windows: <markview_domain>\bin\startWebLogic.cmd
• UNIX: <markview_domain>/bin/startWebLogic.sh

Verify that WebLogic components are running
Verify that the NodeManager is running on every platform and that the WebLogic user has the 
permissions required for access.

1. Log in to the WebLogic Server Administration Console.
2. Go to Environment > Machines and click markview_machine.
3. On the Monitoring tab, verify that Status is Reachable.

Set up memory properties
For UNIX:

1. In <markview_domain>/bin/startWebLogic.sh, locate the following strings:
# Call setDomainEnv here.
DOMAIN_HOME=

2. Immediately before these strings, add the command to set the USER_MEM_ARGS parameter or 
replace the existing command with the following:
USER_MEM_ARGS="-Xms8g -Xmx8g -XX:CompileThreshold=8000 -XX:MetaspaceSize=1g -
XX:MaxMetaspaceSize=2g -Djava.net.preferIPv4Stack=true" export USER_MEM_ARGS

3. Log in to the WebLogic Server Administration Console.
4. Go to Environment > Servers.
5. On the list of servers, click AdminServer and go to Configuration > Server Start tab.
6. In the Arguments field, remove the following arguments, if any:

-Xms1024m -Xmx1400m -XX:CompileThreshold=8000 -XX:MetaspaceSize=128m -
XX:MaxMetaspaceSize=256m

The values for your environment may differ.

 Do not remove other arguments in order for MarkView to function correctly.

7. Restart WebLogic.
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For Windows:
On Windows, select one of the following procedures to set up the memory properties for the 
WebLogic application:
• Use the command line start script
• Use Windows Service

Use the command line start script
1. In <markview_domain>\bin\startWebLogic.cmd, locate the following strings:

@REM Call setDomainEnv here. 
        set DOMAIN_HOME=

2. Immediately before these strings, add the command to set the USER_MEM_ARGS parameter:
set USER_MEM_ARGS=-Xms8g -Xmx8g -XX:CompileThreshold=8000 -XX:MetaspaceSize=1g -
XX:MaxMetaspaceSize=2g

3. Log in to the WebLogic Server Administration Console.
4. Go to Environment > Servers.
5. On the list of servers, click AdminServer and go to Configuration > Server Start tab.
6. In the Arguments field, remove the following arguments, if any:

-Xms1024m -Xmx1400m -XX:CompileThreshold=8000 -XX:MetaspaceSize=128m -
XX:MaxMetaspaceSize=256m

The values for your environment may differ.

 Do not remove other arguments in order for MarkView to function correctly.

7. Restart WebLogic.

Use Windows Service
1. Log in to the WebLogic Server Administration Console.
2. Go to Environment > Servers.
3. On the list of servers, click AdminServer and go to Configuration > Server Start tab.
4. In the Arguments field, remove the following arguments, if any:

-Xms1024m -Xmx1400m -XX:CompileThreshold=8000 -XX:MetaspaceSize=128m -
XX:MaxMetaspaceSize=256m

The values for your environment may differ.

 Do not remove other arguments in order for MarkView to function correctly.

5. Select one of the following options to set up the memory properties:
• Uninstall your current WebLogic Windows Service and before creating your new WebLogic 

Windows Service, verify that the following parameter is set up correctly in the start script:
set USER_MEM_ARGS=-Xms8g -Xmx8g -XX:CompileThreshold=8000 -XX:MetaspaceSize=1g -
XX:MaxMetaspaceSize=2g

• Back up your current version of the Windows Registry and update the
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\services\<WebLogic_Service_name>
\Parameters\CmdLine key that contains memory options for your service as follows:
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-server -Xms8g -Xmx8g -XX:CompileThreshold=8000 -XX:MetaspaceSize=1g -
XX:MaxMetaspaceSize=2g

Verify the JDK version and Java virtual machine availability for WebLogic
For the Java JDK version supported, see the Kofax MarkView Technical Specifications document on the
Kofax MarkView Product Documentation site.

To check the JDK version, and if necessary, add Java to your path:
1. In the JDK installation directory, open the bin directory.
2. Run java -version to verify the installed JDK version.
3. Set JAVA_HOME to the JDK installation directory.
4. Add JAVA_HOME/bin to your path.

JDBC driver version (for WebLogic 12.1.3)
Before you proceed, to verify that you use the appropriate JDBC driver version compatible with 
your environment, see the Kofax MarkView Technical Specifications document on the Kofax MarkView 
Product Documentation site.

Replace the JDBC driver version 12.1.0.1 with the recommended version.
1. Download the JDBC driver from the Oracle website.
2. Stop the WebLogic servers.
3. Navigate to $MW_HOME/oracle_common/modules/oracle.jdbc_12.1.0 and make a backup 

copy of the existing JDBC driver.
4. Copy the recommended JDBC driver version to:

$MW_HOME/oracle_common/modules/oracle.jdbc_12.1.0

5. Restart the WebLogic servers.

Configure SSL for WebLogic 12c (for SSL only)
Skip this section if you are not using SSL.

1. Log in to the WebLogic Server Administration Console using a non-SSL port.
2. Go to Environment > Servers.
3. On the list of servers, click the administration server to configure and go to Configuration >

Keystores tab.
4. If you are on the production mode, click Lock & Edit.

a. In the Keystores field, click Change and select Custom Identity and Custom Trust.
Click Save.

b. In the Identity section, enter the required identity information such as:
• Custom Identity Keystore: <keystore>
• Custom Identity Keystore Type: JKS
• Custom Identity Keystore Passphrase: <keystorepassword>
• Confirm Custom Identity Keystore Passphrase: <keystorepassword>
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Where:
• <keystore> is a certificate repository that you created or imported in Create the 

certificate keystore (for SSL only).
• <keystorepassword> is a password of the keystore.

c. In the Trust section, enter the required trust information such as:
• Custom Identity Keystore: <truststore>
• Custom Identity Keystore Type: JKS
• Custom Identity Keystore Passphrase: <truststorepassword>
• Confirm Custom Identity Keystore Passphrase: <truststorepassword>

Where:
• <truststore> is a repository that contains a trusted certificate or certificates.
• <truststorepassword> is a password of the truststore.

d. Click Save.
5. Click the SSL tab, enter the required information and save changes:

• Private Key Alias: <alias>
• Private Key Passphrase: <keypassphrase>
• Confirm Private Key Passphrase: <keypassphrase>

Where:
• <alias> is a keystore entry unique name.
• <keypassphrase> is a password of the certificate.

6. Click the General tab, clear Listen Port Enabled and select SSL Listen Port Enabled.
Click Save.

7. If you are on the production mode, click Activate Changes.
8. Restart the Node Manager and the WebLogic application server.

Set up Node Manager (for SSL only)
1. Open <markview_domain>/nodemanager.properties for editing.
2. Enter the following information:

KeyStores=CustomIdentityAndCustomTrust
CustomIdentityKeystoreType=jks
CustomIdentityKeyStoreFileName=<keystore>
CustomIdentityKeyStorePassPhrase=<keystorepassword>
CustomIdentityPrivateKeyPassPhrase=<keypassphrase>
CustomIdentityAlias=<alias>
CustomTrustKeystoreType=jks
CustomTrustKeyStoreFileName=<truststore>
CustomTrustKeyStorePassPhrase=<truststorepassword>

3. Restart the Node Manager and the WebLogic application server.

Enable secure session cookies (for SSL only)
To enable MarkView to securely work over SSL, enable the cookie-secure flag by modifying 
the weblogic.xml file. The weblogic.xml file is located in the \WEB-INF directories on all web 
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applications. You must perform the following procedure for all weblogic.xml files within the 
specified path.

1. In the <installation_directory>\applications\<ear_file>\<war_file>\WEB-INF
directories, locate the weblogic.xml file.
• <installation_directory>: MarkView installation directory.
• <ear_file>: All .ear files located in the MarkView installation directory.
• <war_file>: All .war files located within the .ear file.

2. In weblogic.xml, locate the <session-descriptor> element.
3. Add the <cookie-secure>true</cookie-secure> tag inside the <session-descriptor>

element and save the file.

Disable WebLogic basic authentication
1. Log in to the WebLogic host as the WebLogic owner.
2. Open the domain configuration file, which is located in the directory specified when you 

created the domain, for example:
/<WL_home>/../user_projects/domains/<markview domain>/config/config.xml

3. Add the following XML code immediately before the close tag for the security configuration:
<enforce-valid-basic-auth-credentials>false  
</enforce-valid-basic-auth-credentials>

4. Restart the server.

Exclude conflicting libraries (WebLogic 12.2 only)
1. Locate the file:

<WL_HOME>/modules/com.oracle.weblogic.security.opensaml2.jar

The WL_HOME environment variable points to the directory where you installed the WebLogic 
server.

2. Change the file name, or back up and remove the file.
3. If you need to apply a patch on the WebLogic server after the preceding procedure, perform 

the following steps:

a. Restore the file <WL_HOME>/modules/
com.oracle.weblogic.security.opensaml2.jar.

b. Apply the WebLogic patch.

c. Change the file name, or back up and remove the file.

Set up Java Options for WebLogic on AIX
Skip this section, if you do not use AIX platform.

1. Log in to the WebLogic Server Administration Console.
2. Go to Environment > Servers.
3. On the list of servers, click markview_server and go to Configuration > Server Start tab.
4. In the Arguments field, add the following to the end of the line:

-XX:+PositiveIdentityHash -XX:-IgnoreUnrecognizedVMOptions -XX:
+UnlockExperimentalVMOptions
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5. Restart markview_server.

Configure WildFly or JBoss EAP environments
Kofax MarkView supports the WildFly application server, formerly known as JBoss, and JBoss 
Enterprise Application Platform, known as JBoss EAP.

The MarkView installer has the option to install and configure Wildfly as part of the MarkView 
installation process, so that you do not need to install WildFly before running the MarkView installer. 
Alternatively, you can manually install and configure the WildFly environment.

Kofax MarkView supports MarkView installation on the WildFly application server and JBoss EAP in 
both standalone mode and domain mode.

 The WildFly application server in the silent-mode installation files is referred to as JBoss.

Skip this section, if you plan to use the MarkView installer to install and configure WildFly.

For information about downloading and installing both the WildFly and JBoss EAP application 
servers, see the corresponding documentation on the WildFly website.

Complete the following procedures to configure the JBoss EAP environment or to manually set up 
WildFly.
• Configure environment variables on page 29.
• Set up memory properties (standalone mode only) on page 30.
• Set up memory properties (domain mode only) on page 30.
• Create WildFly or JBoss EAP users on page 31.
• Configure ports and hosts on page 32.
• Start WildFly or JBoss EAP application servers on page 33.
• Configure SSL for WildFly and JBoss EAP (for SSL only) on page 33.
• Create a new WildFly or JBoss EAP server for the MarkView instance (domain mode only) on page

37 .
• Set up Java Options for WildFly or JBoss EAP (standalone mode only) on AIX on page 37.
• Set up Java Options for WildFly or JBoss EAP (domain mode only) on AIX on page 38.

Install WildFly or JBoss EAP
1. Download the WildFly or JBoss EAP server from the WildFly website.
2. Extract the downloaded ZIP file to JBOSS_HOME,

where JBOSS_HOME is the WildFly or JBoss EAP installation directory.

Configure environment variables
Configure the environment variables for your WildFly or JBoss EAP application servers. Set 
JBOSS_HOME to your WildFly or JBoss EAP installation directory and ensure that the JBOSS_HOME 
environment variable persists with the shell profile, such as export JBOSS_HOME=<drive&path>/
wildfly.
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For more information about setting JBOSS_HOME for UNIX or Windows, see the installation guide 
on the WildFly website.

Set up memory properties (standalone mode only)
Skip this section if you configure the WildFly or JBoss EAP application servers in domain mode.

For UNIX:
1. For standalone mode, open JBOSS_HOME/bin/standalone.conf for editing.
2. Locate the string similar to the following:

JBOSS_JAVA_SIZING="-Xms64m -Xmx512m -XX:MetaspaceSize=96M -
XX:MaxMetaspaceSize=256m"

Change the string to:
JBOSS_JAVA_SIZING="-Xms8g -Xmx8g -XX:CompileThreshold=8000 -XX:MetaspaceSize=1g -
XX:MaxMetaspaceSize=2g"

 This command must be run on a single line. If you cut and paste from this guide, remove 
any line breaks.

For Windows:
1. For standalone mode, open JBOSS_HOME\bin\standalone.conf.bat for editing.
2. Locate the following string:

set "JBOSS_JAVA_SIZING=-Xms64M -Xmx512M -XX:MaxMetaspaceSize=256m"

Change the string to:
set "JBOSS_JAVA_SIZING=-Xms8g -Xmx8g -XX:CompileThreshold=8000 -
XX:MetaspaceSize=1g -XX:MaxMetaspaceSize=2g"

 This command must be run on a single line. If you cut and paste from this guide, remove 
any line breaks.

Set up memory properties (domain mode only)
Skip this section if you configure the WildFly or JBoss EAP application servers in standalone mode.

For UNIX:
1. For domain mode, open JBOSS_HOME/bin/domain.conf for editing.
2. Locate the string similar to the following:

JBOSS_JAVA_SIZING="-Xms64m -Xmx512m -XX:MetaspaceSize=96M -
XX:MaxMetaspaceSize=256m"

Change the string to:
JBOSS_JAVA_SIZING="-Xms2g -Xmx2g -XX:CompileThreshold=8000 -XX:MetaspaceSize=1g -
XX:MaxMetaspaceSize=2g"

30

http://wildfly.org/downloads/


Kofax MarkView Installation Guide for Oracle E-Business Suite

 This command must be run on a single line. If you cut and paste from this guide, remove 
any line breaks.

For Windows:
1. For domain mode, open JBOSS_HOME\bin\domain.conf.bat for editing.
2. Locate the following string:

set "JBOSS_JAVA_SIZING=-Xms64M -Xmx512M -XX:MaxMetaspaceSize=256m"

Change the string to:
set "JBOSS_JAVA_SIZING=-Xms2g -Xmx2g -XX:CompileThreshold=8000 -
XX:MetaspaceSize=1g -XX:MaxMetaspaceSize=2g"

 This command must be run on a single line. If you cut and paste from this guide, remove 
any line breaks.

For Unix and Windows:
1. Log in to WildFly or JBoss EAP Administration Console.
2. On the Runtime tab, select Server Groups.
3. On the Server Group menu, select Server Group Name.
4. In the Server Group Name box, click the View button.
5. On the left pane, select JVMs, and add a new JVM configuration.
6. Click Edit, and set the following memory properties for your application server. Suggested 

values are:

a. Heap Size to
8g

b. JVM Options to
-XX:MetaspaceSize=1g

-XX:MaxMetaspaceSize=2g

7. Click Save.

Create WildFly or JBoss EAP users
1. Navigate to JBOSS_HOME\bin.
2. Run either:

• Windows: add-user.bat
• UNIX: add-user.sh

For more information about creating both the WildFly and JBoss EAP users, see the administrator's 
guide on the WildFly website.
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Configure ports and hosts
The configuration process varies depending on the mode you use for running the application 
server.

1. For standalone mode: In JBOSS_HOME\standalone\configuration, do the following:

a. Rename standalone.xml to standalone_old.xml.

b. Rename standalone-full.xml to standalone.xml.

c. Open standalone.xml for editing and do the following to configure the host on the 
server:
• Locate <inet-address 
value="${jboss.bind.address.management:127.0.0.1}"/> and change the 
default value 127.0.0.1 to the appropriate host name.

• Locate <inet-address value="${jboss.bind.address:127.0.0.1}"/> and 
change the default value 127.0.0.1 to the appropriate host name.

d. In stanalone.xml, locate the following string to configure the admin port on the server:
<socket-binding name="management-http" interface="management" 
port="${jboss.management.http.port:9990}"/>

Change the default value 9990 to the appropriate port value.

e. In standalone.xml, locate the following string to configure the HTTP port on the server:
<socket-binding name="http" port="${jboss.http.port:8080}"/>

Change the default value 8080 to the appropriate port value.
2. For domain mode: In JBOSS_HOME\domain\configuration, do the following:

a. Open host.xml for editing and do the following to configure the host on the server:
• Locate <inet-address 
value="${jboss.bind.address.management:127.0.0.1}"/> and change the 
default value 127.0.0.1 to the appropriate host name.

• Locate <inet-address value="${jboss.bind.address:127.0.0.1}"/> and 
change the default value 127.0.0.1 to the appropriate host name.

b. In host.xml, locate the following string to configure the port:
<socket interface="management" 
port="${jboss.management.http.port:9990}"/>

Change the default value 9990 to the appropriate port value.

c. In domain.xml, configure the HTTP port on the server:
• In the <socket-binding-groups> section, locate socket binding group with the 

name of your MarkView profile, such as <socket-binding-group name="full-ha-
sockets" default-interface="public">

• In <socket-binding name="http" port="8080"/>, change the default value 8080
to the appropriate port value.
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Start WildFly or JBoss EAP application servers
Start the WildFly or JBoss EAP application servers in standalone or domain modes. For more 
information about the operating modes, see the WildFly website.

If the JBoss EAP or WildFly application servers fail to start, check the application server log file 
for TimeoutException. For JBoss EAP and WildFly, the timeout parameter default value is 300. To 
increase the timeout parameter, add the blocking.timeout Java option:

1. Open the file for your configuration:
• Standalone mode: bin/standalone.conf.bat or bin/standalone.conf.
• Domain mode: bin/domain.conf.bat or bin/domain.conf.

2. Add the following line:
• For Windows: set "JAVA_OPTS=%JAVA_OPTS% -
Djboss.as.management.blocking.timeout=600"

• For Unix: JAVA_OPTS="$JAVA_OPTS -Djboss.as.management.blocking.timeout=600"

Configure SSL for WildFly and JBoss EAP (for SSL only)
Skip this section if you are not using SSL.

Select one of the following procedures depending on the mode:
• Standalone mode
• Domain mode

Standalone mode
1. Open JBOSS_HOME/standalone/configuration/standalone.xml for editing.
2. Locate the <key-stores> line and add the following strings right after the line:

<key-store name="<keystorename>"> 
   <credential-reference clear-text="<keystorepassword>"/> 
   <file path="<keystore>" relative-to="jboss.server.config.dir"/> 
  </key-store> 
  <key-store name="<truststorename>"> 
   <credential-reference clear-text="<truststorepassword>"/> 
   <file path="<truststore>" relative-to="jboss.server.config.dir"/> 
  </key-store>

Where:
• <keystorename> is a name of the repository that contains your security certificate or 

certificates.
• <keystorepassword> is a password of the keystore.
• <truststorename> is a name of the repository that contains a trusted certificate or 

certificates.
• <truststorepassword> is a password of the truststore.

3. Locate the <key-managers> line and add the following strings right after the line:
<key-manager name="<keymanagername>" key-store="<keystorename>"> 
   <credential-reference clear-text="<keystorepassword>"/> 
  </key-manager>
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Where:
• <keymanagername> is a name of the repository that contains a trusted certificate or 

certificates.
• <keystorename> is a name of the repository that contains your security certificate or 

certificates.
• <keystorepassword> is a password of the keystore.

4. Right after the <key-managers>..</key-managers> tag, add the following strings:
<trust-managers> 
   <trust-manager name="<trustmanagername>" key-store="<truststorename>"/> 
  </trust-managers>

5. Locate the <server-ssl-contexts> line and add the following strings right after the line:
<server-ssl-context name="<managementsslcontextname>" key-
manager="<keymanagername>" trust-manager="<trustmanagername>"/> 
  <server-ssl-context name="<applicationsslcontextname>" key-
manager="<keymanagername>" trust-manager="<trustmanagername>"/>

Where:
• <managementsslcontextname> is a management SSL context name
• <keymanagername> is a key manager name.
• <trustmanagername> is a trust manager name.
• <applicationsslcontextname> is an application SSL context name.

6. Locate the following line:
<http-interface http-authentication-factory="management-http-authentication"> 
   <http-upgrade enabled="true" sasl-authentication-factory="management-sasl-
authentication"/> 
   <socket-binding http="management-http"/> 
  </http-interface>

Change the line to:
<http-interface http-authentication-factory="management-http-authentication" ssl-
context="<managementsslcontextname>"> 
   <http-upgrade enabled="true" sasl-authentication-factory="management-sasl-
authentication"/> 
   <socket-binding https="management-https"/> 
  </http-interface>

7. Locate the following line:
<https-listener name="https" socket-binding="https" ssl-context="applicationSSC" 
 enable-http2="true"/>

Change the line to:
<https-listener name="https" socket-binding="https" ssl-
context="<applicationsslcontextname>" enable-http2="true"/>

8. Locate the following string:
<socket-binding name="management-https" interface="management" 
port="${jboss.management.https.port:9993}"/>

Change the default value 9993 to the appropriate port value.
9. Locate the following string:

<socket-binding name="https" port="${jboss.https.port:8443}"/>

Change the default value 8443 to the appropriate port value.

34



Kofax MarkView Installation Guide for Oracle E-Business Suite

10. Copy the <keystore> and <truststore> JKS files to JBOSS_HOME/standalone/
configuration.

11. Restart the WildFly or JBoss EAP application server.

Domain mode
1. Open JBOSS_HOME/domain/configuration/host.xml for editing.
2. Right after the <sasl>..</sasl> tag, add the following strings:

<tls> 
   <key-stores> 
    <key-store name="<keystorename>"> 
     <credential-reference clear-text="<keystorepassword>"/> 
     <implementation type="JKS"/> 
     <file path="<keystore>" relative-to="jboss.domain.config.dir"/> 
    </key-store> 
    <key-store name="<truststorename>"> 
     <credential-reference clear-text="<truststorepassword>"/> 
     <implementation type="JKS"/> 
     <file path="<truststore>" relative-to="jboss.domain.config.dir"/> 
    </key-store> 
   </key-stores> 
   <key-managers> 
    <key-manager name="<keymanagername>" key-store="<keystorename>"> 
     <credential-reference clear-text="<keystorepassword>"/> 
    </key-manager> 
   </key-managers> 
   <trust-managers> 
    <trust-manager name="<trustmanagername>" key-store="<truststorename>"/> 
   </trust-managers> 
   <server-ssl-contexts> 
    <server-ssl-context name="<managementsslcontextname>" key-
manager="<keymanagername>" trust-manager="<trustmanagername>"/> 
   </server-ssl-contexts> 
  </tls>

Where:
• <keystorename> is a name of the repository that contains your security certificate or 

certificates.
• <keystorepassword> is a password of the keystore.
• <truststorename> is a name of the repository that contains a trusted certificate or 

certificates.
• <truststorepassword> is a password of the truststore.
• <keymanagername> is a key manager name.
• <trustmanagername> is a trust manager name.
• <managementsslcontextname> is a management SSL context name.

3. Locate the following line:
<http-interface http-authentication-factory="management-http-authentication">

Change the line to:
<http-interface http-authentication-factory="management-http-authentication" ssl-
context="<managementsslcontextname>">

4. Locate the following line:
<socket interface="management" port="${jboss.management.http.port:9990}"/>
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Change the line to:
<socket interface="management" secure-port="<securemangementport>"/>

5. Open JBOSS_HOME/domain/configuration/domain.xml for editing and locate <profile 
name="full-ha">

a. Within <profile name="full-ha">, locate the <key-stores> line and add the 
following strings right after the line :
<key-store name="<keystorename>"> 
    <credential-reference clear-text="<keystorepassword>"/> 
    <file path="<keystore>" relative-to="jboss.domain.config.dir"/> 
   </key-store> 
   <key-store name="<truststorename>"> 
    <credential-reference clear-text="<truststorepassword>"/> 
    <file path="<truststore>" relative-to="jboss.domain.config.dir"/> 
   </key-store>

b. Locate the <key-managers> line and add the following strings right after the line:
<key-manager name="<keymanagername>" key-store="<keystorename>"> 
    <credential-reference clear-text="<keystorepassword>"/> 
   </key-manager>

c. Right after the <key-managers>..</key-managers> tag, add the following strings:
<trust-managers> 
    <trust-manager name="<trustmanagername>" key-store="<truststorename>"/> 
   </trust-managers>

d. Locate the <server-ssl-contexts> line and add the following strings right after the 
line:
<server-ssl-context name="<sslcontextname>" key-manager="<keymanagername>" 
 trust-manager="<trustmanagername>"/>

e. Locate the following line:
<https-listener name="https" socket-binding="https" ssl-
context="applicationSSC" enable-http2="true"/>

Change the line to:
<https-listener name="https" socket-binding="https" ssl-
context="<applicationsslcontextname>" enable-http2="true"/>

f. Locate the <servlet-container name="default"> tag and add the following string 
between <jsp-config/> and <websockets/>:
<session-cookie http-only="true" secure="true"/>

6. Locate the <socket-binding-group name="full-ha-sockets" line and then locate the 
following string:
<socket-binding name="https" port="${jboss.https.port:8443}"/>

Change the default value 8443 to the appropriate port value.
7. Copy the <keystore> and <truststore> JKS files to JBOSS_HOME/domain/configuration.
8. Restart the WildFly or JBoss EAP application server.
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Create a new WildFly or JBoss EAP server for the MarkView instance 
(domain mode only)
Create a new domain

1. Log in to the WildFly or JBoss EAP Administration Console.
2. Select the Runtime tab.
3. On the Browser By menu, select Server Groups and click Add Server Group.
4. In the Add Server Group window, enter the following information and click Add:

• Name: <domain_name>
• Profile: full-ha
• Socket Binding Group: full-ha-sockets

Create a new server
1. In the WildFly or JBoss EAP Administration Console, select the Runtime tab.
2. On the Browser By menu, select Server Groups.
3. On the Server Group menu, select the newly created server group and click Add Server.
4. In the Add Server window, enter the following information and click Add:

• Name: <domain_name>_server, where <domain_name> is the server group name.
Add the _server postfix to your server name.

• Host: master
• Auto Start: On
• Group: <domain_name>
• Socket Binding Port Offset: 0

5. On the Runtime tab, select Topology and click Refresh.
Start the created server by clicking its name.

Set up Java Options for WildFly or JBoss EAP (standalone mode only) on 
AIX
Skip this section if you do not use AIX platform or configure the WildFly or JBoss EAP application 
servers in domain mode.

For Windows:
1. Open the %JBOSS_HOME%\bin\standalone.conf.bat file for editing.
2. Go to end file and add string set "JAVA_OPTS=%JAVA_OPTS% -XX:

+PositiveIdentityHash -XX:-IgnoreUnrecognizedVMOptions -XX:
+UnlockExperimentalVMOptions" before  :JAVA_OPTS_SET instruction.

3. Save the file.

For Linux:
1. Open the  $JBOSS_HOME/bin/standalone.conf file for editing.
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2. Go to end file and add string JAVA_OPTS="$JAVA_OPTS -XX:+PositiveIdentityHash -
XX:-IgnoreUnrecognizedVMOptions -XX:+UnlockExperimentalVMOptions".

3. Save the file.

Set up Java Options for WildFly or JBoss EAP (domain mode only) on AIX
Skip this section if you do not use AIX platform or configure the WildFly or JBoss EAP application 
servers in standalone mode.

1. Log in to the WildFly or JBoss EAP Administration Console.
2. On the Runtime tab, select Server Groups.
3. On the Server Group menu, select Server Group Name.
4. In the Server Group Name box, click the View button.
5. On the left pane, select JVMs and add a new JVM configuration.
6. Click Edit and set the following memory properties for your application server. Suggested 

values for JVM Options are:
-XX:+PositiveIdentityHash

-XX:-IgnoreUnrecognizedVMOptions

-XX:+UnlockExperimentalVMOptions

Add SSL certificate to the application server truststore (for SSL only)
Skip this section if you are not using SSL to provide secure web communications for the application 
server.

Skip this section if you plan to use the MarkView installer to install and configure WildFly.

To add the certificate to the application server Java truststore, run the following command:

keytool -import -alias <alias> -keystore 
      <application_server_java_home>/jre/lib/security/cacerts -file 
      <certificate>

Where:
• <alias> is a keystore entry unique name
• <certificate> is a file that contains the self-signed certificate or any other certificate received 

from the certificate authority
If you have a certificate received from the certificate authority, verify that root and intermediate 
certificates from the certification chain are in the application server Java truststore and run the 
indicated command to add the missing certificates.

The default Java certificate authority keystore is cacerts. The default password for cacerts is
<changeit>.

Add truststore to the jboss-cli configuration file (for SSL only)
Skip this section if you are not using SSL to provide secure web communications for the application 
server.
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In JBOSS_HOME/bin, open the jboss-cli.xml file for editing. Right after the <color-
output>..</color-output> tag, add the following strings:

<ssl> 
  <alias>"<alias>"</alias> 
  <trust-store>"<truststore>"</trust-store> 
  <trust-store-password>"<truststorepassword>"</trust-store-password> 
    </ssl>

Where:
• <alias> is a truststore entry unique name.
• <truststore> is a repository that contains a trusted self-signed certificate or certificates.
• <truststorepassword> is a password of the truststore.

What to do next
• To use Silent Installation mode, go to Silent verification and installation on page 40.
• To use Interactive mode, go to Verify your environment on page 54.
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Silent verification and installation

In silent mode, you set installation properties in a script that is used by the installer. The installer 
does not display windows or prompt for input during the installation process. Because you can 
reuse the install_silent script, you can automate identical installations on multiple systems.

You can use silent-mode installation on Windows or UNIX systems and can also use it to install 
Oracle Objects.

This chapter assumes that you:
• Completed the tasks described in Plan your MarkView installation.
• Completed the Kofax MarkView Installation Worksheet and have the worksheet available for 

reference.
• Logged in as the owner of the application server.

Using silent-mode installation requires you to complete the following procedures, which this
chapter describes:

1. Edit the interview files in the MarkView installation directory. See Silent-mode setup.

2. If you choose to run the verify_silent script, copy the interview files to the verify directory and 
run verify. See Run the verify_silent script on page 47.

3. Run the install_silent script. See Run the install_silent script on page 48.

When you finish the silent installation:
• For Accounts Payable post-installation steps, see Configure MarkView for Accounts Payable on 

page 116.
• For Oracle Objects post-installation steps, see Configure Oracle Forms on page 77.

Silent-mode setup

Edit the preliminary_interview.properties file
1. Navigate to <distribution_directory>/installer/conf where

<distribution_directory> is the location where you downloaded and decompressed the 
installation files.

2. Back up the preliminary_interview.properties file.
3. Open the preliminary_interview.properties file and enter the following information.

40



Kofax MarkView Installation Guide for Oracle E-Business Suite

 For installations running on Windows, when modifying manually populated fields, use a 
double backslash (\\) or a forward slash (/) as a path delimiter.

Field Allowed Values

AppServerType.app_server_type • WebLogic
• JBoss (use for WildFly and JBoss EAP)

InstallDirectory.install_directory Installation directory. This is user defined and must exist prior 
to installation. This cannot be the same as the temporary 
distribution directory. See the MarkView Installation Worksheet.

InstallerAction.installer_action install

InstallationType.installation_type • Standard Full Install
• Partial Install (Any value other than Standard Full Install 

performs a partial install)

SelectedProducts.selected_products These must exactly match what appears in the install_script.xml 
file. To verify product names, open install_script.xml and search 
for display = <product name>.
For example:
• MarkView for AP 10.5.0 with Transformation
• MarkView for Expense Management 10.5.0
• MarkView Document Library 10.5.0
• MarkView Self Service Invoice 10.5.0

To list multiple products, separate product names with commas.

ERPType.erp_type (Optional) Oracle, or blank

MarkView DBConn.password Password for MarkView schema user

Run the generateInterviewTemplate file
The generateInterviewTemplate script uses the information in the preliminary_interview.properties 
file to generate the installer_interview.properties file.

1. Navigate to <distribution_directory>\installer\bin, where
<distribution_directory> is the location where you downloaded and decompressed the 
installation files.

2. Run either:
• UNIX: generateInterviewTemplate.sh
• Windows: generateInterviewTemplate.bat

Edit the installer_interview.properties file
1. Navigate to <distribution_directory>\installer\conf where

<distribution_directory> is the location where you downloaded and decompressed the 
installation files.

2. Back up the installer_interview.properties file.
3. Open the installer_interview.properties file.
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4. Enter information for the fields identified with bold type in the following table. These fields 
appear in the same alphabetical order in the installer_interview.properties file. Use this list 
as a reference for all possible fields in the installer_interview.properties file. Your file may not 
contain all of the listed fields. Field names and values cannot contain spaces.

 Modifying automatically populated fields may cause unexpected results during the 
installation.

 For installations running on Windows, when modifying manually populated fields, use a 
double backslash (\\) or a forward slash (/) as a path delimiter.

Field Values Source Product

AppServer Type. app 
_server_type

• WebLogic
• JBoss (use for WildFly and JBoss EAP)

Automatically 
populated. Do 
not change this 
value.

All

AppServerType. type SimpleQuestion Automatically 
populated. Do 
not change this 
value.

All

Folder Location. 
location

Directory for the Document Server. Must 
exist prior to installation.

Enter the data 
from your 
Installation 
Worksheet.

AP

FolderLocation. type FolderLocation Automatically 
populated. Do 
not change this 
value.

AP

InstallDirectory. install 
_directory

From the preliminary _interview. 
properties file

Automatically 
populated. Do 
not change this 
value.

All

InstallDirectory. type SimpleQuestion Automatically 
populated. Do 
not change this 
value.

All

InstallationType. 
installation _type

From the preliminary _interview. 
properties file

Automatically 
populated. Do 
not change this 
value.

All

InstallationType. type SimpleQuestion Automatically 
populated. Do 
not change this 
value.

All

JBossAppServer. 
adminUserName

JBoss administrator name Enter the data 
from your 
Installation 
Worksheet.

All
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Field Values Source Product

JBossAppServer. 
adminPassword

JBoss application server administrator 
password

Enter the data 
from your 
Installation 
Worksheet.

All

JBossAppServer. 
adminPort

The admin HTTP port (for example, 9090) To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All

JBossAppServer.asSSL For SSL with WildFly or JBoss EAP: true
Valid values: true, false

Enter the data 
from your 
Installation 
Worksheet.

All

JBossAppServer.domain For domain mode, enter your domain 
name as follows:
JBossAppServer.domain=<domainName>

For standalone mode, leave the field value 
blank:
JBossAppServer.domain=

For domain 
mode, enter 
the data 
from your 
Installation 
Worksheet.

All

JBossAppServer. host Fully qualified hostname of this machine Enter the data 
from your 
Installation 
Worksheet.

All

JBossAppServer. port The HTTP port where MarkView 
applications listen (for example, 26000)

To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All

JBossAppServer. type JBossAppServer Automatically 
populated. Do 
not change this 
value.

All

JBossAppServer. 
jbossLocation

Defaults to
<distribution_directory>/../
wildfly,
where <distribution_directory> is 
the location where you downloaded and 
extracted the MarkView installation files.
If <distribution_directory>/../
wildfly does not exist prior to
installation, the installer creates the 
directory.

To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All
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Field Values Source Product

JBossAppServer. 
oracleDriver

Defaults to
<distribution_directory>/distr/
ojdbc6-11.2.0.3.jar,
where <distribution_directory> is 
the location where you downloaded and 
extracted the MarkView installation files.

To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet

All

JBossAppServer. 
needsDeploy

Defaults to <empty>
Valid values: no, yes

To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All

MarkView DBConn. 
dbType

oracle Automatically 
populated. Do 
not change this 
value.

All

MarkView DBConn. 
host

Fully qualified hostname where MarkView 
resides

Enter the data 
from your 
Installation 
Worksheet.

All

MarkView DBConn. 
indexspace

Tablespace for MarkView indexes Enter the data 
from your 
Installation 
Worksheet.

All

MarkView DBConn. 
loggingDirectory

Oracle logging directory for MarkView 
processes

Enter the data 
from your 
Installation 
Worksheet.

All

MarkView DBConn. 
password

Password for MarkView schema user Enter the data 
from your 
Installation 
Worksheet.

All

MarkView DBConn. 
port

Port for MarkView schema Enter the data 
from your 
Installation 
Worksheet.

All

MarkView DBConn. sid SID for MarkView schema Enter the data 
from your 
Installation 
Worksheet.

All

MarkView DBConn. 
tablespace

Tablespace for MarkView data Enter the data 
from your 
Installation 
Worksheet.

All

MarkView DBConn. 
type

OracleDatabase Connection Enter the data 
from your 
Installation 
Worksheet.

All
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Field Values Source Product

MarkView DBConn. 
user

User name for the MarkView schema user Enter the data 
from your 
Installation 
Worksheet.

All

OracleEBS. password Oracle APPS user password Enter the data 
from your 
Installation 
Worksheet.

All except Doc 
Lib

OracleEBS.type OracleEBSInstance Automatically 
populated. Do 
not change this 
value.

All except Doc 
Lib

OracleEBS. user Oracle APPS user name Enter the data 
from your 
Installation 
Worksheet.

All except Doc 
Lib

OracleEBSCodes. 
holdCode

170_SYSTEMS _HOLD Automatically 
populated. Do 
not change this 
value.

All except Doc 
Lib

OracleEBSCodes. 
releaseCode

170_SYSTEMS _RELEASE Automatically 
populated. Do 
not change this 
value.

All except Doc 
Lib

OracleEBSCodes. type OracleEBS Codes Automatically 
populated. Do 
not change this 
value.

All except Doc 
Lib

OracleText. password Oracle Text user password Enter the data 
from your 
Installation 
Worksheet.

Doc Lib

OracleText.type OracleText Automatically 
populated. Do 
not change this 
value.

Doc Lib

OracleText.user CTXSYS Enter the data 
from your 
Installation 
Worksheet.

Doc Lib

SelectedProducts. 
selected_ products

Products selected in the preliminary 
_interview. properties file

Automatically 
populated. Do 
not change this 
value.

All
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Field Values Source Product

Selected Products. type MultipleAnswer Question Automatically 
populated. Do 
not change this 
value.

All

SMTPInfo. password SMTP password, if necessary Enter the data 
from your 
Installation 
Worksheet.

All

SMTPInfo. serverName Fully qualified SMTP server address Enter the data 
from your 
Installation 
Worksheet.

All

SMTPInfo. type Custom Resource Automatically 
populated. Do 
not change this 
value.

All

SMTPInfo. username SMTP user name if necessary Enter the data 
from your 
Installation 
Worksheet.

All

WebLogic AppServer. 
adminPassword

WebLogic application server password Enter the data 
from your 
Installation 
Worksheet.

All

WebLogic AppServer. 
adminPort

The admin HTTP port (default 7001) Enter the data 
from your 
Installation 
Worksheet.

All

WebLogic AppServer. 
adminUserName

WebLogic administrator name Enter the data 
from your 
Installation 
Worksheet.

All

WebLogicAppServer. 
asSSL

For SSL with WebLogic: true
Valid values: true, false

Enter the data 
from your 
Installation 
Worksheet.

All

WebLogic AppServer. 
domainLocation

Defaults to ${WL_HOME}/../markview) To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All

WebLogic AppServer. 
domainName

Defaults to MarkView To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All
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Field Values Source Product

WebLogic AppServer. 
host

Fully qualified hostname of this machine Enter the data 
from your 
Installation 
Worksheet.

All

WebLogic AppServer. 
jarLocation

Defaults to ${WL_HOME}/server/lib/
weblogic.jar

To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All

WebLogic AppServer. 
javaHomeDir

Defaults to %WL_HOME/../jrockit_* To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All

WebLogic AppServer. 
nodeManagerPort

Defaults to 5556 To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All

WebLogic 
AppServer.port

The HTTP port where MarkView 
applications listen (default 8001)

To change the 
default value, 
enter the data 
from your 
Installation 
Worksheet.

All

WebLogic 
AppServer.type

WebLogicAppServer Automatically 
populated. Do 
not change this 
value.

All

Run the verify_silent script
To ensure that your environment is configured properly for successful installation, run the verify 
script, which is a smaller version of the installation script.

1. Copy the installer_interview.properties file that you generated in Run the 
generateInterviewTemplate file and edited in Edit the installer_interview.properties file from
<distribution_directory>/installer/conf to <distribution_directory>/verify/
conf, (where <distribution_directory> is the location where you downloaded and 
decompressed the installation files).

2. Ensure that all the paths entered in the install_interview.properties file exist.
3. Skip this step if you do not use SSL for the application server. If you plan to use SSL, navigate 

to <distribution_directory>/verify/bin, (where <distribution_directory> is the 
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location where you downloaded and decompressed the installation files), open for editing 
verify_silent.sh or verify_silent.bat and change the following string:
• For UNIX:

java -Xmx1024m -cp ${CLASSPATH} 
      -Doracle_home=${ORACLE_HOME} com.markview.installer.Installer "$@"

to:
java -Xmx1024m -cp ${CLASSPATH} 
      -Doracle_home=${ORACLE_HOME} -Dmarkview.ssl.alias=<alias> 
      -Djavax.net.ssl.keyStore=<keystore> 
      -Djavax.net.ssl.keyStorePassword=<keystorepassword> 
      -Djavax.net.ssl.trustStore=<truststore> 
      -Djavax.net.ssl.trustStorePassword=<truststorepassword> 
      com.markview.installer.Installer "$@"

• For Windows:
java -Xmx1024m -cp "%CLASSPATH%" 
      -Doracle_home=%ORACLE_HOME% com.markview.installer.Installer %*

to:
java -Xmx1024m -cp "%CLASSPATH%" 
      -Doracle_home=%ORACLE_HOME% -Dmarkview.ssl.alias=<alias> 
      -Djavax.net.ssl.keyStore=<keystore> 
      -Djavax.net.ssl.keyStorePassword=<keystorepassword> 
      -Djavax.net.ssl.trustStore=<truststore> 
      -Djavax.net.ssl.trustStorePassword=<truststorepassword> 
      com.markview.installer.Installer %*

4. In <distribution_directory>/verify/bin, run either:
• UNIX: verify_silent.sh
• Windows: verify_silent.bat

If no errors occur, verify_silent returns to a command prompt with no further messages.

If Verify encounters an error
1. Review the verify logs located in the distribution directory in the reports folder.
2. Resolve the issue.
3. Rerun the verify script.

If no errors occur, the script returns to a command prompt with no further messages.

Run the install_silent script
1. Skip this step if you do not use SSL for the application server. If you plan to use SSL, navigate 

to <distribution_directory>/installer/bin, (where <distribution_directory> is 
the location where you downloaded and decompressed the installation files), open for editing 
install_silent.sh or install_silent.bat and change the following string:
• For UNIX:

java -Xmx1024m -cp ${CLASSPATH} 
      -Doracle_home=${ORACLE_HOME} com.markview.installer.Installer "$@"

to:
java -Xmx1024m -cp ${CLASSPATH} 
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      -Doracle_home=${ORACLE_HOME} -Dmarkview.ssl.alias=<alias> 
      -Djavax.net.ssl.keyStore=<keystore> 
      -Djavax.net.ssl.keyStorePassword=<keystorepassword> 
      -Djavax.net.ssl.trustStore=<truststore> 
      -Djavax.net.ssl.trustStorePassword=<truststorepassword> 
      com.markview.installer.Installer "$@"

• For Windows:
java -Xmx1024m -cp "%CLASSPATH%" 
      -Doracle_home=%ORACLE_HOME% com.markview.installer.Installer %*

to:
java -Xmx1024m -cp "%CLASSPATH%" 
      -Doracle_home=%ORACLE_HOME% -Dmarkview.ssl.alias=<alias> 
      -Djavax.net.ssl.keyStore=<keystore> 
      -Djavax.net.ssl.keyStorePassword=<keystorepassword> 
      -Djavax.net.ssl.trustStore=<truststore> 
      -Djavax.net.ssl.trustStorePassword=<truststorepassword> 
      com.markview.installer.Installer %*

2. In <distribution_directory>\installer\bin, run either:
• UNIX: install_silent.sh
• Windows: install_silent.bat

 If the installer encounters an error, the installation stops. Review the log files located 
in the log folder in the MarkView installation directory. Resolve the issue, then rerun the 
install_silent script.

Upon successful completion, the install_silent script returns to the command prompt with no 
further messages.

Install Oracle Objects
Make sure that your environment is configured correctly for installing Oracle Objects. See
Set up your environment and install MarkView Oracle Objects on page 70. Copy the 
target_registry_service.properties file from the MarkView installation directory to the Oracle Objects 
installation directory.

Silent-mode setup for Oracle Objects

Edit the preliminary_interview.properties file for Oracle Objects
1. Log in to the Oracle EBS server as the EBS user.
2. Navigate to <distribution_directory>/installer/conf (where

<distribution_directory> is the location where you downloaded and decompressed the 
installation files).

3. Back up the preliminary_interview.properties file.
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4. Open the preliminary_interview.properties file and enter the following information.

Field Allowed Values

AppServerType.app_server_type • WebLogic
• JBoss (use for WildFly and JBoss EAP)

InstallDirectory.install_directory Installation directory. This is user defined and must 
exist prior to installation. See the Kofax MarkView 
Installation Worksheet.

InstallerAction.installer_action install

InstallationType.installation_type Standard Full Install
Partial Install (Any value other than Standard Full 
Install will perform a partial install)

SelectedProducts.selected_products Must be an exact match to contents of the 
install_script.xml file. To verify product names, 
open install_script.xml and search for display 
= <product name>. To list multiple products, 
separate product names with commas.

ERPType.erp_type Oracle or blank - optional field

Run the generateInterviewTemplate file for Oracle Objects
1. Log in to the Oracle EBS server as the EBS user.
2. Navigate to <distribution_directory>\installer\bin where

<distribution_directory> is the location where you downloaded and decompressed the 
installation files.

3. Run either:
• UNIX: generateInterviewTemplate.sh
• Windows: generateInterviewTemplate.bat

Edit the Oracle Objects installer_interview.properties file
1. Log in to the Oracle EBS server as the EBS user.
2. Navigate to the conf folder in the MarkView installation directory.
3. Back up the installer_interview.properties file.
4. Open the Oracle Objects installer_interview.properties file.
5. Enter information for the fields marked with bold type. There are no spaces in field names.

 Modifying fields populated by the preliminary_interview.properties file may cause 
unexpected results during installation.

Field Values Source Product

InstallDirectory. 
install_directory

MarkView installation 
directory from the 
preliminary_ interview. 
properties file

preliminary_ interview. 
properties

All
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Field Values Source Product

InstallDirectory. type Simple Question preliminary_ interview. 
properties

All

InstallationType. 
installation_type

Install type seeded from 
preliminary_ interview . 
properties

preliminary_ interview. 
properties

All

InstallationType . type SimpleQuestion preliminary_ interview. 
properties

All

MarkView DBConn. 
dbType

Enter oracle. preliminary_ interview. 
properties

All

MarkView DBConn. 
host

Fully qualified hostname 
where MarkView resides

Installation Worksheet All

MarkView DBConn. 
indexspace

Tablespace where 
MarkView indexes will 
reside

Installation Worksheet All

MarkView DBConn. 
logging Directory

Oracle logging directory 
for MarkView processes

Installation Worksheet All

MarkView DBConn. 
password

Password for MarkView 
schema user

Installation Worksheet All

MarkView DBConn. 
port

Port for MarkView 
schema

Installation Worksheet All

MarkView DBConn. sid SID for MarkView 
schema

Installation Worksheet All

MarkView DBConn. 
tablespace

Tablespace where 
MarkView data will 
reside

Installation Worksheet All

MarkView DBConn. 
type

Oracle Database 
Connection

Installation Worksheet All

MarkView DBConn. 
user

User name for MarkView 
schema user

Installation Worksheet All

OAForms EnvInfo. 
appl_top

install_silent.sh Forms

OAForms EnvInfo. 
au_top

install_silent.sh Forms

OAForms EnvInfo. 
c_markview_ top

install_silent.sh Forms

OAForms EnvInfo. 
fnd_top

install_silent.sh Forms

OAForms EnvInfo. type install_silent.sh Forms

OAFrameworks EnvInfo. 
appl_top

install_silent.sh OA Frameworks, OA 
Expense

OAFrameworks EnvInfo. 
common_top

install_silent.sh OA Frameworks, OA 
Expense
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Field Values Source Product

OAFrameworks EnvInfo. 
java_top

install_silent.sh OA Frameworks, OA 
Expense

OAFrameworks EnvInfo. 
type

OAFramework EnvInfo 
Resource

install_silent.sh OA Frameworks, OA 
Expense

OracleEBS password Oracle APPS user 
password

Installation Worksheet All except Doc Lib

OracleEBS .type Oracle EBSInstance preliminary_ interview. 
properties

All except Doc Lib

OracleEBS. user Oracle APPS user name Installation Worksheet All except Doc Lib

Selected Products. 
selected_products

Products selected from 
preliminary_ interview. 
properties

preliminary_ interview. 
properties

All

Selected Products. type Multiple Answer 
Question

preliminary_ interview. 
properties

All

Run the verify_silent script for Oracle Objects
1. Log in to the Oracle EBS server as the EBS user.
2. Copy the installer_interview.properties file from <distribution_directory>/installer/

conf to <distribution_directory>/verify/conf (where <distribution_directory> is 
the location where you downloaded and decompressed the installation files).

3. Ensure that all the paths entered in the install_interview.properties file exist.
4. In <distribution_directory>/verify/bin, run either:

• UNIX: verify_silent_oracle_objects.sh
• Windows: verify_silent_oracle_objects.bat

If no errors exist, verify_silent_oracle_objects returns to a command prompt with no further 
messages.

If Verify Oracle Objects encounters an error
1. Review the verify logs located in the reports folder in the distribution directory.
2. Resolve the issue.
3. Rerun the verify script.

If no errors exist, the script returns to a command prompt with no further messages.

Run the install_silent script for Oracle Objects
1. Log in to the Oracle EBS server as the EBS user.
2. If the Target Registry Service is already deployed, copy the existing 

target_registry_service.properties file to the MarkView installation directory for Oracle Objects.
3. In <distribution_directory>/installer/bin, (where <distribution_directory> is 

the location where you downloaded and decompressed the installation files), run either:
• UNIX: install_silent.sh
• Windows: install_silent.bat
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 If the installer encounters an error, the installation stops automatically. Review the log 
files located in the log folder in the target installation directory. Resolve the issue, then rerun 
the install_silent script.

4. Continue at Post-installation steps.

If no errors exist, the install_silent file returns to the command prompt with no further messages.
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Verify your environment

The Verify tool is a smaller version of the installation application. Verify checks many of the system 
configuration settings and generates log files to help you identify and correct any issues before you
install MarkView.

Before running Verify:
• Ensure that your system is in compliance with the Kofax MarkView Technical Specifications

document on the Kofax MarkView Product Documentation site.
• Complete the Kofax MarkView Installation Worksheet.
• Complete the tasks described in Plan your MarkView installation.

Run Verify
The MarkView verification process requires information about your environment. Complete the 
sections of the installation worksheet that apply to your environment before you begin to verify 
MarkView.

Run verify on all systems where MarkView products are installed or being upgraded:
• Application server hosts
• Oracle E-Business Suite hosts

Verify hosts
Verify checks the following:
• Version information for

• Operating System
• Database
• Database Server
• Application Server
• Forms Server

• MarkView Oracle RDBMS user privileges
• Oracle XML DB
• Oracle Text DB library (for the Document Library installation only)
• Oracle Advanced Queuing
• MarkView schema user setup
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Verify generates logs that contain information about issues that can cause the MarkView installation 
to fail. The values that you enter when you run Verify pre-populate fields in the installer prompts.

Run Verify on the MarkView application server host
Use the information that you entered on the Kofax MarkView Installation Worksheet to respond to the 
Verify prompts. Run Verify before installing MarkView.

1. Log in to the application server host operating system as the application server owner.
2. Ensure that the MarkView application server is running.
3. Ensure that the environment variables are correct.

For more information, see:
• Set locale-sensitive environment variables
• Configure environment variables for WebLogic or Configure environment variables

4. Skip this step if you do not use SSL for the application server. If you plan to use SSL, navigate 
to <distribution_directory>/verify/bin, (where <distribution_directory> is the 
location where you downloaded and decompressed the installation files), open for editing 
verify.sh or verify.bat and change the following string:
• For UNIX:

java -Xmx1024m -cp ${CLASSPATH} 
      -Doracle_home=${ORACLE_HOME} com.markview.installer.InstallerVerify "$@"

to:
java -Xmx1024m -cp ${CLASSPATH} 
      -Doracle_home=${ORACLE_HOME} -Dmarkview.ssl.alias=<alias> 
      -Djavax.net.ssl.keyStore=<keystore> 
      -Djavax.net.ssl.keyStorePassword=<keystorepassword> 
      -Djavax.net.ssl.trustStore=<truststore> 
      -Djavax.net.ssl.trustStorePassword=<truststorepassword> 
      com.markview.installer.InstallerVerify "$@"

• For Windows:
java -Xmx1024m -cp "%CLASSPATH%" 
      -Doracle_home=%ORACLE_HOME% com.markview.installer.InstallerVerify %*

to:
java -Xmx1024m -cp "%CLASSPATH%" 
      -Doracle_home=%ORACLE_HOME% -Dmarkview.ssl.alias=<alias> 
      -Djavax.net.ssl.keyStore=<keystore> 
      -Djavax.net.ssl.keyStorePassword=<keystorepassword> 
      -Djavax.net.ssl.trustStore=<truststore> 
      -Djavax.net.ssl.trustStorePassword=<truststorepassword> 
      com.markview.installer.InstallerVerify %*

5. Navigate to <distribution_directory>/verify/bin, (where
<distribution_directory> is the location where you downloaded and decompressed the 
installation files), and run the command for your operating system:
• UNIX: verify.sh
• Windows: verify.bat

6. On the Which products do you want to verify for this environment? page, select only the 
products that you plan to install.

7. Follow the on-screen prompts and click Verify.
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 On the Installation Progress window, click Show Details to display the progress.

8. Review the generated reports located in the MarkView installation directory you selected 
during the verification. Save these logs in another directory to avoid overwriting them.
The log file reports/EnvironmentReport.txt describes issues with your environment that 
will prevent successful installation.

9. Make changes as indicated in the failure reports. You are now ready to  install.

To run Verify for the Oracle Objects installer on the Oracle EBS host before running the application 
server and database components installer, copy the target_registry.properties file from the 
MarkView installation directory on the application server host to the installation directory on the 
OEBS host. See Download the Oracle Objects installer and Verify files on page 73.
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Install MarkView

Follow the steps in this chapter to run the MarkView installer. If you used the silent-mode 
installation, skip this section.

Before you run the installer:
• Complete the installation worksheet.
• Complete the tasks described in Plan your MarkView installation on page 14.
• Run Verify. See Verify your environment on page 54.

Add SSL certificate to the MarkView installer Java truststore 
(for SSL only)

Skip this section if you are not using SSL to provide secure web communications for the application 
server.

To add the certificate to the MarkView installer Java truststore, run the following command:

 keytool -import -alias <alias> -keystore 
      <installer_java_home>/jre/lib/security/cacerts -file 
      <certificate>

Where:
• <alias> is a keystore entry unique name.
• <certificate> is a file that contains the self-signed certificate or any other certificate received 

from the certificate authority.
If you have a certificate received from the certificate authority, verify that root and intermediate 
certificates from the certification chain are in the MarkView installer Java truststore and run the 
indicated command to add the missing certificates.

The default Java certificate authority keystore is cacerts. The default password for cacerts is
<changeit>.
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Modify installation scripts (for SSL only)
Skip this section if you are not using SSL to provide secure web communications for the application 
server.

1. Navigate to <distribution_directory>/installer/bin where
<distribution_directory> is the location where you downloaded and extracted the 
installation files, and open for editing:
• UNIX: install.sh
• Windows: install.bat

2. Locate and change the string as follows:
• For UNIX:

java -Xmx1024m -cp ${CLASSPATH} 
      -Doracle_home=${ORACLE_HOME} com.markview.installer.Installer "$@"

to:
java -Xmx1024m -cp ${CLASSPATH} 
      -Doracle_home=${ORACLE_HOME} -Dmarkview.ssl.alias=<alias> 
      -Djavax.net.ssl.keyStore=<keystore> 
      -Djavax.net.ssl.keyStorePassword=<keystorepassword> 
      -Djavax.net.ssl.trustStore=<truststore> 
      -Djavax.net.ssl.trustStorePassword=<truststorepassword> 
      com.markview.installer.Installer "$@"

• For Windows:
java -Xmx1024m -cp "%CLASSPATH%" 
      -Doracle_home=%ORACLE_HOME% com.markview.installer.Installer %*

to:
java -Xmx1024m -cp "%CLASSPATH%" 
      -Doracle_home=%ORACLE_HOME% -Dmarkview.ssl.alias=<alias> 
      -Djavax.net.ssl.keyStore=<keystore> 
      -Djavax.net.ssl.keyStorePassword=<keystorepassword> 
      -Djavax.net.ssl.trustStore=<truststore> 
      -Djavax.net.ssl.trustStorePassword=<truststorepassword> 
      com.markview.installer.Installer %*

Where:
• <alias> is a keystore attribute that defines the string alias used to store and retrieve the 

server private key.
• <keystore> is a repository that contains private keys and the certificates with the 

corresponding public keys.
• <keystorepassword> is a password of <keystore>.
• <truststore> is a repository that contains trusted certificates from other parties that it 

expects to communicate with, or from Certificate Authorities that it trusts to identify other 
parties.

• <truststorepassword> is a password of <truststore>.
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Run the MarkView installer

WebLogic
Have your completed installation worksheet available when you start the installer.

1. Log in to the application server host operating system as the application server owner.
2. Verify that the application server is running.
3. Ensure that the environment variables are correct.

For more information, see:
• Set locale-sensitive environment variables
• Configure environment variables for WebLogic

4. Navigate to <distribution_directory>\installer\bin where
<distribution_directory> is the location where you downloaded and extracted the 
installation files, and run the command for your operating system:
• UNIX: install.sh.
• Windows: install.bat.

5. On the Which products do you want to install? window, select the products to install.
6. Click Next.
7. Select Standard Full Install and click Next.
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8. Select WebLogic and click Next.

9. Use the installation worksheet to complete the windows as prompted by the installer.
The windows and prompts that appear vary based on your selections.

10. When prompted, click Install.
The process can take half an hour or more for a new installation. To track the progress, click
Show Details.

11. Click Exit to complete the installation.
The installer finishes with a message indicating whether the installation is successful.

12. The installer creates a log file in the MarkView installation directory. Save the installation log 
files in a safe place in case you need this information for Technical Support.

WildFly or JBoss EAP
Have your completed installation worksheet available when you start the installer.

1. Log in to the application server host operating system as the application server owner.
2. If you use manually installed WildFly or JBoss EAP, verify that the application server is running.
3. If you use manually installed WildFly or JBoss EAP, ensure that the environment variables are 

correct.
For more information, see:
• Set locale-sensitive environment variables
• Configure environment variables
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4. Navigate to <distribution_directory>\installer\bin where
<distribution_directory> is the location where you downloaded and extracted the 
installation files, and run the command for your operating system:
• UNIX: install.sh.
• Windows: install.bat.

5. On the Which products do you want to install? window, select the products to install.
6. Click Next.
7. Select Standard Full Install and click Next.

8. On the Which type of J2EE application server will MarkView use? window, select WildFly/
JBoss and click Next.

9. Use the installation worksheet to complete the windows as prompted by the installer.
The windows and prompts that appear vary based on your selections.
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• Admin Username
• Admin User Password
• Domain

For the domain mode, enter your domain name in the Domain field.
For the standalone mode, leave the Domain field blank.

• App Server Directory
For manually configured WildFly or JBoss EAP, specify <JBOSS_HOME>.
If you are using the MarkView installer to install and configure WildFly, specify the location to 
store your WildFly installation files.

• Host Name
Specify your application server host name.

• Admin Port
The admin ports for manually configured WildFly and JBoss EAP may differ. See Configure 
ports and hosts.

• SSL
Select the check box if you are installing MarkView on SSL.

• HTTP Port
See Configure ports and hosts.

• Install WildFly
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Select Install WildFly, to use the MarkView installer to install and configure the WildFly 
application server.
Clear Install WildFly, to use the manually installed WildFly.

10. On the installer screen, check the summary of your selections.

 In the Application server field, the value JBoss is set.

11. When prompted, click Install.
The process can take half an hour or more for a new installation. To track the progress, click
Show Details.

 In Show Details > Output, Installing or verifying JBoss server... line indicates the 
WildFly installation and verification process.

12. Click Exit to complete the installation.
The installer finishes with a message indicating whether the installation is successful.

13. The installer creates a log file in the MarkView installation directory. Save the installation log 
files in a safe location in case you need them later for Technical Support.
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Post-installation steps

Add SSL certificate for WildFly (for SSL only)
Only follow the instructions in this section if you used the MarkView installer to install and configure 
WildFly and if you use SSL to provide secure web communications for the WildFly application server.

To add the certificate to the application server Java truststore, run the following command:

keytool -import -alias <alias> -keystore 
      <application_server_java_home>/jre/lib/security/cacerts -file 
      <certificate>

Where:
• <alias> is a keystore entry unique name.
• <certificate> is a file that contains the self-signed certificate or any other certificate received 

from the certificate authority.

The default Java certificate authority keystore is cacerts. The default password for cacerts is
<changeit>

Set up memory properties (for WebLogic only)
1. Log in to the WebLogic Server Administration Console.
2. Go to Environment > Servers.
3. On the list of servers, click markview_server and go to Configuration > Server Start tab.
4. In the Arguments field, remove the following arguments, if any:

-Xms1024m -Xmx1400m -XX:CompileThreshold=8000 -XX:MetaspaceSize=128m -
XX:MaxMetaspaceSize=256m

The values for your environment may differ.

 Do not remove other arguments in order for MarkView to function correctly.

Set up the log files location
To set up the log files location, configure the markview.home variable.
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WebLogic
1. Log in to the WebLogic Server Administration Console.
2. Go to Environment > Servers.
3. On the list of servers, click markview_server and go to Configuration > Server Start tab.
4. In the Arguments field, add the following to the end of the line:

-Dmarkview.home=<path>

Where <path> is the location where you installed MarkView.
The WebLogic log files will be located in the <path>/log directory.

5. Click Save.

WildFly or JBoss EAP
1. Open one of the following configuration files depending on the mode you use to run the 

application server:

a. For Unix: JBOSS_HOME/bin/standalone.conf or JBOSS_HOME/bin/domain.conf

b. For Windows: JBOSS_HOME/bin/standalone.conf.bat or JBOSS_HOME/bin/
domain.conf.bat

2. Locate the JAVA_OPTS value and add the markview.home parameter to the end of the string as 
follows:
JAVA_OPTS="... -Dmarkview.home=<path>"

Where <path> is the location where you installed MarkView.
The WildFly or JBoss EAP log files will be located in the <path>/log directory.

Configure the print function (for WebLogic 12.1.3 only)
To set up the print function for MarkView Viewer on WebLogic 12.1.3 application server, perform the 
following steps.

1. Log in to the WebLogic Server Administration Console.
2. Go to Environment > Servers.
3. On the list of servers, click markview_server and go to Configuration > Server Start tab.
4. In the Arguments field, add the following to the end of the line:

-DUseSunHttpHandler=true

5. Click Save.

Standard/Basic WebLogic license
In case you have a Standard/Basic license for WebLogic, you need to make the following changes to 
the frameworks deployment after the installation:

1. Log in to the WebLogic Server Administration Console.
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2. Shut down markview_server.
3. Delete frameworks deployment.

a. Go to Deployments.

b. Select the frameworks deployment and click Delete.
4. Install and rename the application. Do not rename the ear file, only the application.

a. On the Deployments tab, click Install.

b. Update the path to point at
<installation_directory>/applications/frameworks.ear

Where <installation_directory> is the MarkView installation directory.

c. Select the frameworks.ear and click Next.

d. Select Install this deployment as application and click Next.

e. Select markview_server and click Next.

f. Change the name of the application from frameworks to aframeworks and click Finish.

 Repeat the renaming step (4.f) after major updates or when you apply fix packs.

Restart the application server

WebLogic
1. Log in to the WebLogic Server Administration Console.
2. Go to Environment > Servers > Control tab.
3. Select the check box next to markview_server.
4. Click Shutdown and select Force shutdown now.
5. Select the check box next to markview_server and click Start.

 When you restart markview_server the first time after installing or upgrading applications, not 
all applications transition to the Active state. At this point, not all applications need to be active.

WildFly or JBoss EAP
If you used the MarkView installer to install and configure WildFly, before starting the application 
server, configure the memory properties. See Set up memory properties (standalone mode only) on 
page 30 or Set up memory properties (domain mode only) on page 30 for more information.

1. Set the JBOSS_HOME environmental variable, such as:
JBOSS_HOME=<drive&path>/wildfly

For specific details related to UNIX or Windows, see the installation guide on the JBoss website.
2. Start the WildFly or JBoss EAP application server in standalone or domain modes. See the JBoss 

website for more information about the operating modes.
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Check for invalid packages
1. Log in as the MarkView database user.
2. Enter the following SQL statement:

SELECT OBJECT_NAME, OBJECT_TYPE FROM USER_OBJECTS WHERE STATUS 
      = 'INVALID';

3. If invalid database objects exist, save the output from the SQL statement and run 
@gencomp.sql in <distribution_directory>\installer\scripts, where
<distribution_directory> is the location where you downloaded and decompressed the 
installation files.
A message similar to the following appears:
Recursively compiling 2 object(s).
Please wait...
All objects compiled successfully.

4. Review the information in the COMPILE.LOG. If the message says that it is recursively 
compiling more than 0 objects, rerun @gencomp.sql. Dependencies between objects can 
require more than one execution to complete compilations successfully before the other 
completes compilations.

5. If any objects still fail to compile, run SQL*Plus SHOW ERRORS to view the error messages. Use 
the following format for this command:
SHOW ERRORS { FUNCTION | PROCEDURE | PACKAGE | PACKAGE BODY | TRIGGER | VIEW }  
 name

For example, to view the PL/SQL errors for the package body 
MVERP_DFM_DESCR_FLEX_CUSTOM, enter:
SQL> SHOW ERRORS PACKAGE BODY MVERP_DFM_DESCR_FLEX_CUSTOM

The errors that occurred during compilation of the object are displayed.

Start MarkView Home
MarkView Home is a dynamically generated web page from which tools and utilities draw data from 
database queries. Starting MarkView Home verifies that the installation succeeded.

1. Open a Web browser and navigate to the MarkView Home URL.
MarkView Home is installed in the following default location:
http://host.domain.extension:port/markview/MVT_MV_Home.Home
For example, the URL might look like this:
http://my_host.company.com:7777/markview/MVT_MV_home.home

2. Enter the following MarkView credentials:
• User Name: admin
• Password: change_on_install

3. If the MarkView interface is not displayed properly, log in to the application server 
Administration console; navigate to Deployments, and verify the status of your MarkView 
applications.
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Access the MarkView help
To launch the online help for the installed version of the product, click the Help icon within the 
application.

To access the MarkView help in offline mode, perform the following procedure.
1. After you obtained KofaxMarkViewDocumentation_10.5.0_EN.zip from the product package, 

create a directory for the MarkView help, such as:
<MarkView_installation_directory>/applications/OLH/

2. Create subfolders for each language, such as en_US for English or de_DE for German, and 
extract all help files to folders with the corresponding language codes.

3. Deploy the help to the application server.
4. In MarkView Admin, change the default value for the HELP_BASE_URL preference from:

https://docshield.kofax.com/MarkView/[lang]/10.5.0-yw2qf8m7r6/

To:
http(s)://host:port/<deployment_path>/[lang]/

Set the application server host and port as applicable to the location where you deployed the 
help in the previous step. Do not change the [lang] value. The language code is substituted 
automatically.

Configure MarkView to use the Oracle Wallet (for SSL only)
Skip this section if you do not use SSL to provide secure web communications for the application 
server.

1. Log in to MarkView and navigate to Administration > MarkView Admin.
2. Select the Preferences tab.
3. Locate and change the settings for the following preferences:

a. Set SECURITY_SSL_WALLET_LOCATION to <WalletFolder>.

b. Set SECURITY_SSL_WALLET_PASSWORD to <WalletPasswd>.
For information about the values, see Add SSL certificate to Oracle Wallet (for SSL only).

Verify the system setup
1. Log in to MarkView and navigate to Administration > Verify MarkView.
2. In the Test Folder that opens, click the document icon next to the About MarkView document. 

MarkView Viewer displays the document, which validates that the viewer operates correctly.

 The first time that you try to view a document after installation, you may get a null pointer 
exception. If this happens, restart the application server and retry this step.

3. Navigate to Utilities > Bar Code Generation and generate a bar code for Supplier Document.
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Verify that database jobs are running
1. Log in to MarkView and navigate to Utilities > System Status.
2. Locate DBMS User Jobs Broken.

Status Current 
Value

Limit Over Limit Description

DBMS User Jobs 
Broken

2 0 Y The number of current MarkView database user 
jobs and scheduler jobs that are in error.

Disconnected Bar 
Code Server

1 0 Y Checks v$session to see if the Bar Code server 
has a connection to the database.

3. Contact Kofax Technical Support if the current value for DBMS User Jobs Broken is greater 
than 0.
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Set up your environment and install 
MarkView Oracle Objects

Follow these steps if you installed MarkView manually. If you installed MarkView Oracle Objects in 
silent mode, continue at After you run the installer.

Install MarkView Oracle Objects
Complete the following procedures:
• Create the $c_MARKVIEW_TOP environment variable
• Download the Oracle Objects installer and Verify files
• Run Verify on the Oracle E-Business Suite host
• Run the MarkView Oracle Objects installer

Create the $c_MARKVIEW_TOP environment variable
Before you install MarkView Oracle Objects, create the environment variable that Oracle E-Business 
Suite uses to locate the MarkView Forms.

Determine the forms mode
In the following table, locate the version and mode that you are running to determine the correct 
procedure for adding the $c_MARKVIEW_TOP environment variable to your system. Complete the 
appropriate procedure.

Oracle EBS 
version

Forms Mode Procedure

12.x (except 
12.2)

Servlet or Socket Add c_MARKVIEW_TOP to your environment for Oracle EBS 12.x 
(except Oracle EBS 12.2): Socket and servlet modes on page
71.

12.2 Servlet or Socket Add c_MARKVIEW_TOP to your environment for Oracle EBS 12.2: 
Socket and servlet modes on page 72

For information about how to check if the forms server is configured in servlet or socket mode, see 
Oracle MetaLink Note 417216.1.
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Add c_MARKVIEW_TOP to your environment
Perform the correct procedure for your environment.

Add c_MARKVIEW_TOP to your environment for Oracle EBS 12.x (except 
Oracle EBS 12.2): Socket and servlet modes

1. Log in to Oracle E-Business Suite as System Administrator.
2. Navigate to System Administrator > Oracle Application Manager > OAM Setup > Site Map >

AutoConfig.
3. The Applications Dashboard opens the Context Files window. Find the Related Links section at 

the bottom, and click Manage Custom Parameters.
4. On the next page (Customized Parameters), click Add.

 If you see the error message: "Customization is not allowed on different versions of 
configuration files.", see Oracle MetaLink 762590.1: Create a Custom Parameter Fails With - 
Customization Is Not Allowed On Different Versions of Configuration Files.

5. Select Applications Tier and click Next.
6. Set up the next page as follows:

Field Description and Setting

OA_VAR The name of the environment variable. Select c_MARKVIEW_TOP.

Default Value The c_MARKVIEW_TOP directory.
For installation set to:
%s_at%/markview/12.0.0
(%s_at% is APPL_TOP).
For upgrade set to
%s_at%/<your TOP name>/12.0.0
(Use 12.0.0 for R12.1)

Title MarkView Top

Description MarkView for Oracle Forms Top

OA Type PROD_TOP

7. On the Step 2 page, click Next.
8. On the confirmation page verify your values and click Next.

Step 4 summarizes the files that change when you change the TOP variable. You can read the 
XML file listed here in your shell by viewing $CONTEXT_FILE.

9. Click Finish.
10. Go to Set up c_MARKVIEW_TOP in Oracle E-Business Suite on page 72.

AutoConfig loads the contents of $CONTEXT_FILE into your shell and the Oracle Forms 
environment via $ORACLE_CONFIG_HOME/forms/server/default.env.

71



Kofax MarkView Installation Guide for Oracle E-Business Suite

Add c_MARKVIEW_TOP to your environment for Oracle EBS 12.2: Socket 
and servlet modes

1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-
Business Suite owner. The default account for this user is applmgr.

2. To set the environment variables, source the run file system environment file.
For example, from a UNIX shell, run the following command:
$ source $APPL_TOP/../../../EBSapps.env run

3. Create the $customfile custom environment file (if it does not already exist).
4. Add the following lines to the end of the $customfile custom environment file:

    export c_MARKVIEW_TOP=`dirname ${BASH_SOURCE[1]}`/markview/12.0.0 
  export C_MARKVIEW_TOP=$c_MARKVIEW_TOP

5. To set the environment variables, source the patch file system environment file.
For example, from a UNIX shell, run the following command:
$ source $APPL_TOP/../../../EBSapps.env patch

6. Create the $customfile custom environment file (if it does not already exist).
7. Add the following lines to the end of the $customfile custom environment file:

export c_MARKVIEW_TOP=`dirname ${BASH_SOURCE[1]}`/markview/12.0.0 
  export C_MARKVIEW_TOP=$c_MARKVIEW_TOP

8. To set the environment variables, source the run file system environment file.
For example, from a UNIX shell, run the following command:
$ source $APPL_TOP/../../../EBSapps.env run

9. Go to Set up c_MARKVIEW_TOP in Oracle E-Business Suite on page 72.

Set up c_MARKVIEW_TOP in Oracle E-Business Suite
1. Run AutoConfig to load c_MARKVIEW_TOP into your environment and ensure that future runs 

of AutoConfig will not unset c_MARKVIEW_TOP. See Oracle documentation for more detailed 
information on AutoConfig.
On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-
Business suite owner. The default account for this user is applmgr. Run the AutoConfig script:
$INST_TOP/admin/scripts/adautocfg.sh

2. After AutoConfig finishes running, restart Oracle EBS Applications.

3. Confirm that the variable is set:

a. Log out of your shell and close your remote connection.

b. Log in to the shell and run echo $c_MARKVIEW_TOP to display the variable.

 If after running AutoConfig and logging into your shell, the variable is not available, see 
MetaLink Note: 461326.1 for a bug that may apply to your system.
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Download the Oracle Objects installer and Verify files
1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-

Business suite owner. The default account for this user is applmgr.
2. Create a temporary distribution directory for the compressed MarkView installer and 

verification files. For example, <home_directory>/mvforms_dist where <home_directory> is 
the user home directory.

3. In the distribution directory, create these subdirectories:
• <distribution_directory>/verify

• <distribution_directory>/installer

Where <distribution_directory> is the temporary distribution directory you just created.
4. Download the following file into the verify directory (where <version_number> is the MarkView 

version number):
KofaxMarkView-<version_number>_Oracle_Verify.zip (for all hosts)

5. Download the following file into the installer directory (where <version_number> is the 
MarkView version number):
KofaxMarkView-<version_number>_Oracle_Objects.zip

6. Decompress the files.
7. Create the MarkView installation directory for Oracle Objects modules. This is typically the 

same as the MarkView installation directory.
The directory name must not contain any XML special characters, such as an ampersand (&) 
and it cannot be a subdirectory of the temporary installer directory.

Add SSL certificate to the MarkView Oracle Objects installer 
Java truststore (for SSL only)

Skip this section if you do not use SSL to provide secure web communications for the application 
server.

Add the certificate to the MarkView installer Java truststore on the system where you plan to run the 
Oracle Objects installer:

keytool -import -alias <alias> -keystore "<installer_java_home>\jre\lib\security
\cacerts" –file <certificate>

Where:
• <alias> is a keystore entry unique name.
• <certificate> is a file that contains the self-signed certificate or any other certificate received 

from the certificate authority.
If you have a certificate received from the certificate authority, verify that root and intermediate 
certificates from the certification chain are in MarkView installer Java truststore and run the 
indicated command to add the missing certificates.
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The default Java certificate authority keystore is cacerts. The default password for cacerts is
<changeit>.

Run Verify on the Oracle E-Business Suite host
Use the information that you entered on the MarkView Installation Worksheet to respond to the 
Verify prompts. Run Verify before  installing MarkView.

1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-
Business suite owner. The default account for this user is APPLMGR.

2. Ensure that the environment variables are correctly set up:
• $PATH: Confirm the appropriate Java version comes first (or run java –version). For 

the Java version, see the Kofax MarkView Technical Specifications document on the Kofax 
MarkView Product Documentation site.

• $APPL_TOP: Confirm this is the correct instance of Oracle E-Business Suite
• $FORMS_PATH: Confirm that it includes $AU_TOP/resource and $AU_TOP/forms/US.

Also, for more information, see:
• Set locale-sensitive environment variables
• Configure environment variables for WebLogic or Configure environment variables.

3. Ensure that the MarkView application server is running.
4. Navigate to <distribution_directory>/verify/bin, where <distribution_directory> is the 

location where you downloaded and decompressed the installation files.
5. Run Verify:

• On Unix, enter ./verify_oracle_objects.sh.
• On Windows, enter verify_oracle_objects.bat.

6. Select the products you are planning to install with the Oracle Objects installer.
• Oracle Forms Integration
• OA Framework Integration for AP
• OA Framework Integration for Expense (only if you are running MarkView for Expense 

Management)

Consider these points when you select products:
• Only systems running Oracle EBS 12.x that also include MarkView for Account Payables can 

select OA Framework Integration for AP.
• Only systems running MarkView for Expense Management can select OA Framework 

Integration for Expense.
7. Follow the prompts.
8. Review the generated reports. The reports are located in the MarkView installation directory 

you selected during the verification. Save these logs in another directory to prevent overwriting 
them.
The file reports/EnvironmentReport.txt describes issues with your environment that will 
prevent successful installation.

9. Make changes as indicated in the failure reports. You are now ready to install.
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Run the MarkView Oracle Objects installer
To run the installer:

1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-
Business suite owner. The default account for this user is applmgr.

2. Make sure that all environment variables are correctly set up for this account, check:
• $PATH: Confirm the appropriate Java version comes first (or run java –version). For 

the Java version, see the Kofax MarkView Technical Specifications document on the Kofax 
MarkView Product Documentation site.

• $APPL_TOP: Confirm this is the correct instance of Oracle E-Business Suite
• $FORMS_PATH: Confirm that it includes $AU_TOP/resource and $AU_TOP/forms/US.

3. Ensure that the application server is running.
4. Navigate to <distribution_directory>/installer/bin, where <distribution_directory> is 

the temporary distribution directory.
5. Start the installer by running either:

• For Unix: ./install.sh
• For Windows: install.bat

6. Select the applications to install. Available choices are:
• Oracle Forms Integration
• OA Framework Integration for AP
• OA Framework Integration for Expense

Consider the following when selecting products:
• Only systems running Oracle Release 12 that also include MarkView for Account Payables 

can select OA Framework Integration for AP.
• Only systems running MarkView for Expense Management can select OA Framework 

Integration for Expense.
7. Click Next.
8. Select Standard Full Install and click Next.
9. Click Select Folder to navigate to the MarkView installation directory and click Next.

10. Enter your MarkView schema password and click Next.
11. Enter your Oracle Applications schema password and click Next.

The order and appearance of the next few steps vary depending on the installation options.
12. Review the values displayed and click Next:

• Location of APPL_TOP value: Confirm this is the instance of Oracle E-Business Suite where 
you want to install Forms.

• Location of AU_TOP and FND_TOP values: Confirm this is the instance of Oracle E-Business 
Suite where you want to install Forms (both directories should be under $APPL_TOP).

• Location of $c_MARKVIEW_TOP value: It should be the value you set up in the Pre-Install 
steps.

13. Verify the Oracle Framework Environment Variable values APPL_TOP, COMMON_TOP, and 
JAVA_TOP and click Next.

75

https://docshield.kofax.com/Portal/Products/en_US/MarkView/10.5.0-yw2qf8m7r6/MarkView.htm
https://docshield.kofax.com/Portal/Products/en_US/MarkView/10.5.0-yw2qf8m7r6/MarkView.htm


Kofax MarkView Installation Guide for Oracle E-Business Suite

14. Review the Summary and click Next.
15. Click Install.

The process can take several minutes. To track the progress, click Show Details.
The installation finishes with a message indicating whether the installation is successful.
The installation script creates log files in the MarkView installation directory.

16. Click Exit.

After you run the installer
If you are installing on Oracle EBS 12.2, follow the steps in Add MarkView classes to the EBS class 
path (Oracle EBS 12.2 only) to add the MarkView classes to the $JAVA_TOP/customall.jar file that is 
on the EBS class path.

Otherwise, continue at Disable Inline Attachments in Oracle E-Business Suite to configure the 
MarkView Oracle Forms Server for use with MarkView products.

Add MarkView classes to the EBS class path (Oracle EBS 12.2 only)
After running the Oracle Objects installer on Oracle EBS 12.2, you must add the MarkView classes to 
the $JAVA_TOP/customall.jar file that is on the EBS class path by following the steps in this section. If 
you do not add the MarkView classes, you may encounter errors while working with Oracle Forms, 
for example an unexpected error may occur in the iExpenses module.

1. Run the Oracle Adadmin utility to generate the new jar files.

a. In the Oracle Adadmin utility, select option 1: Generate Applications Files menu.

b. Select option  4: Generate product JAR files.

c. If you wish to force regeneration of all jar files, when prompted, enter Y.
2. Restart Oracle EBS Applications.

Disable Inline Attachments in Oracle E-Business Suite
We recommend that you disable the following option for appropriate interaction with attachments.

1. Log in to Oracle E-Business Suite as System Administrator.
2. Navigate to System Administrator > Profile > System.
3. In the Find System Profile Values window, select Site.
4. In the Profile field, to locate the Disable Inline Attachments option, enter FND%Inline% and 

click Find.
5. In the Site field, set the value to True and save changes.
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Configure Oracle Forms

The Forms configuration process includes required and optional steps:

1. Verify the environment (Oracle EBS 12.2 only)

2. Test the $c_MARKVIEW_TOP environment variable

3. Set up the Oracle Forms environment variables

4. Update the Oracle Attachments form (FNDATTCH.fmb)

5. Configure Oracle Forms for multi-language support (optional) If your system uses a language 
other than US English, configure Oracle Forms for multi-language support.

6. Update the custom library (CUSTOM.pll)

7. Enable Invoice Workbench (optional)

8. Enable MarkView Quick Invoices (optional)

9. Synchronize the run and patch file systems (Oracle EBS 12.2 only)

Verify the environment (Oracle EBS 12.2 only)
Follow these steps if you are integrating MarkView with Oracle E-Business Suite 12.2 or higher

When configuring Oracle Forms, run any shell commands on the run file system.
1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-

Business Suite owner.
The default account for this user is applmgr.

2. Source the run file system environment file.
For example, from a UNIX shell, run the following command:
$ source $APPL_TOP/../../../EBSapps.env run

3. Verify that the environment is properly set by examining the relevant environment variable.
For example, from a UNIX shell, run the following command:
$ echo $FILE_EDITION  
    run

Test the $c_MARKVIEW_TOP environment variable
1. Log in to Oracle Applications and open any form (except Invoice Workbench).
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2. Select Help > Diagnostics > Examine.
3. When prompted, enter the <password>.
4. Navigate to Block and press CTRL-L.
5. Select $ENVIRONMENT$.
6. In Field, enter one of the following commands and click Tab:

• For servlet mode, enter: C_MARKVIEW_TOP
• For socket mode, enter: c_MARKVIEW_TOP

 The command is case-specific.

 Do not press CTRL-L to display the list of values.

7. Verify the Value setting.
• If the pathname for either the c_MARKVIEW_TOP variable or the C_MARKVIEW_TOP variable 

appears in the field, the variable is configured correctly.
• If the pathname does not appear for either c_MARKVIEW_TOP or C_MARKVIEW_TOP, 

try steps 1-6 again, but use the alternative case. For example, if you initially used 
c_MARKVIEW_TOP, try C_MARKVIEW_TOP.

• If the pathname does not appear for either c_MARKVIEW_TOP or C_MARKVIEW_TOP after 
using the alternative case, there is a configuration error. Check if the variable was configured 
correctly.

8. Verify the value in the database:

a. Log in to the database as the APPS user.

b. Run the following SQL command:
select basepath from fnd_application where   
      basepath like '%MARKVIEW_TOP%';

c. If the return value corresponds to the variable that you verified in step 7, continue at Set 
up the Oracle Forms environment variables.

d. If the return value does not correspond to the variable that you verified in step 7, there 
may be an error when opening a MarkView form such as Invoice Workbench (SFXINWKB).

e. From the SQL prompt, update the base path to correspond to the environment. Enter the 
correct code for the value that you verified in step 7:
• For c_MARKVIEW_TOP, enter:

update fnd_application set basepath= 'c_MARKVIEW_TOP' where 
      basepath like '%MARKVIEW_TOP%'; commit;

• For C_MARKVIEW_TOP, enter:
update fnd_application set basepath= 'C_MARKVIEW_TOP' where 
      basepath like '%MARKVIEW_TOP%'; commit;
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Set up the Oracle Forms environment variables
Before launching Oracle Forms Builder, set environment variables. Log in to the Forms host as a 
user with write privileges in the $APPL_TOP directory (for example, applmgr).

Oracle Forms Builder must run through a windowing system. Initiate this session on a desktop 
environment or from an X Windows client.

For X Windows clients, set the DISPLAY environment variable to the IP address of your local 
machine. For example:

export DISPLAY=xxx.xxx.xxx.xxx:0

The $APPL_TOP directory contains configuration files which have the suffix .env and set 
environment variables. These environment variables must be set properly so you can compile forms 
and libraries.

Before invoking Oracle Forms Builder, nvoke the appropriate configuration file to establish the 
proper working environment. Use the shell command that runs scripts or batch files in your current 
environment:
• C shell: source APPS<sid>_<hostname>.env
• KornShell: APPS<sid>_<hostname>.env

where <sid> is the database SID and <hostname> is the server name.

The configuration file establishes several environment variables, including the following:

Variable What it Holds

APPL_TOP The name of the directory where the configuration files reside.

FORMS_PATH in R12.x One or more directories required to compile forms and libraries.

AU_TOP The source code for all forms.

To verify FORMS_PATH:
1. Check FORMS_PATH to make sure that it includes $AU_TOP/resource.
2. Oracle Forms Builder must have $AU_TOP/forms/US in its path. Either:

• Launch Oracle Forms Builder from the directory $AU_TOP/forms/US.
• Set the variable FORMS_PATH to include $AU_TOP/forms/US.

Start Oracle Forms Builder
Before running the Oracle Forms Builder installer, verify that the Java version on the system 
matches the Oracle EBS Java (32-bit or 64-bit versions).

To start Oracle Forms Builder for Oracle Release 12, enter the following command in a shell:

frmbld
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Update the Oracle Attachments form (FNDATTCH.fmb)
By default, Oracle Applications support attachments on most standard Oracle Applications forms. 
A user clicks the Attachments (paper clip) button on the Oracle Applications toolbar, which starts 
the FNDATTCH form. The FNDATTCH form searches for and returns any attachments to the current 
Oracle Applications record. Modify the FNDATTCH form so that it shows attachments with MarkView 
categories.

Many of the changes to the FNDATTCH form are encapsulated in a source form named 170ATTCH 
that is installed by the MarkView installer. As you update the FNDATTCH form, cut and paste some 
of the MarkView modifications from 170ATTCH to FNDATTCH.

Step 1: Open the FNDATTCH and 170ATTCH forms
1. Copy:

$AU_TOP/forms/US/FNDATTCH.fmb

to:
$c_MARKVIEW_TOP/forms/US

2. Start Oracle Forms Builder as described in Start Oracle Forms Builder on page 79.
3. Connect to the Oracle APPS database schema.

a. Select File > Connect.

b. Enter the Oracle APPS database user, password, and connect string (the same credentials 
specified during MarkView for Oracle Applications installation).

4. Select File > Open and open $c_MARKVIEW_TOP/MVOA/<version_number>/
forms/170ATTCH.fmb (where <version_number> is the Oracle version number).
The name of the form, ATTCH170, appears at the top of the navigation tree.

5. Select File > Open and open $c_MARKVIEW_TOP/forms/US/FNDATTCH.fmb.
The name of the form, FNDATTCH, appears at the top of the navigation tree.

Step 2: Paste the GET_MV_DOCUMENT_ID item into the FNDATTCH form
1. In the Object Navigator, expand ATTCH170 > Data Blocks > DOCUMENT_CONTROL > Items

and select GET_MV_DOCUMENT_ID.
2. Right-click and select Copy.
3. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_CONTROL and 

select Items.
4. Right-click and select Paste.

Step 3: Paste the MarkView package into the FNDATTCH form
1. In the Object Navigator, expand ATTCH170 > Program Units and highlight these packages:

• MARKVIEW* (Package Spec)
• MARKVIEW* (Package Body)

2. Right-click and select Copy.
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3. In the Object Navigator, expand FNDATTCH and select Program Units.
4. Right-click and select Paste.

Step 4: Edit the PRE-FORM trigger
1. In the Object Navigator, expand FNDATTCH > Triggers and select PRE-FORM.
2. Right-click and select PL/SQL Editor.
3. Make the following changes to the PRE-FORM trigger:

a. Append .170 to the revision number to indicate that the form is edited for MarkView 
integration.
For example, change:
FND_STANDARD.FORM_INFO('$Revision: 115.155.11591.2')
to:
FND_STANDARD.FORM_INFO('$Revision: 115.155.11591.2.170')

b. Add the following code to the end of the trigger as a separate line:
MarkView.Event('PRE-FORM');

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 5: Edit the PRE-QUERY trigger
1. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_HEADER > Triggers

and select PRE-QUERY.
2. Right-click and select PL/SQL Editor.
3. In the PL/SQL Editor, add the following line of code to the end of the trigger:

MarkView.Initialize;

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 6: Edit the POST-QUERY trigger
1. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_HEADER > Triggers

and select POST-QUERY.
2. Right-click and select PL/SQL Editor.
3. Add the following line of code to the end of the trigger:

MarkView.Event('POST-QUERY');

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 7: Edit the PRE-INSERT trigger
1. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_HEADER > Triggers

and select PRE-INSERT.
2. Right-click and select PL/SQL Editor.
3. Add the following code to the beginning of the trigger:

If MarkView.IsMarkView then
MarkView.Event('PRE-INSERT');
End if;

81



Kofax MarkView Installation Guide for Oracle E-Business Suite

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 8: Edit the WHEN-NEW-RECORD-INSTANCE trigger
1. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_HEADER > Triggers

and select WHEN-NEW-RECORD-INSTANCE.
2. Right-click and select PL/SQL Editor.
3. In the PL/SQL Editor, add the following code to the end of the trigger:

MarkView.Default_Show_Document;

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 9: Create the KEY-NEXT-ITEM trigger
1. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_HEADER > Items >

DATATYPE_NAME and select Triggers.
2. Click the plus sign + button in the toolbar to create a new trigger.

A list of trigger names appears.
3. In the list, select KEY-NEXT-ITEM and click OK.

The PL/SQL Editor opens.
4. Add the following code to the new KEY-NEXT-ITEM trigger:

MarkView.Event('KEY-NEXT-ITEM');

5. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 10: Edit the WHEN-VALIDATE-ITEM trigger for the DATATYPE_NAME 
item

1. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_HEADER > Items >
DATATYPE_NAME > Triggers and select WHEN-VALIDATE-ITEM.

2. Right-click and select PL/SQL Editor.
3. Append the following code to the end of the trigger:

MarkView.Event('WHEN-VALIDATE-ITEM');

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 11: Edit the WHEN-VALIDATE-ITEM trigger for the 
CATEGORY_DESCRIPTION item

1. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_HEADER > Items >
CATEGORY_DESCRIPTION > Triggers and select WHEN-VALIDATE-ITEM.

2. Right-click and select PL/SQL Editor.
3. Append the following code to the end of the trigger:

MarkView.Event('WHEN-VALIDATE-ITEM'); 

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 12: Add an alert to the FNDATTCH form
1. In the Object Navigator, expand ATTCH170 > Alerts and select MVOA_MESSAGE.
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2. Right-click and select Copy.
3. Expand FNDATTCH and select Alerts.
4. Right-click and select Paste.

Step 13: Edit the WHEN-BUTTON-PRESSED trigger
1. In the Object Navigator, expand FNDATTCH > Data Blocks > DOCUMENT_CONTROL >

Items > OPEN_OTHER_DOCUMENT > Triggers and select WHEN-BUTTON-PRESSED.
2. Right-click and select PL/SQL Editor.
3. Replace any existing code with the following code:

if MarkView.IsMarkView then   
copy(:document_header.file_name, 'GLOBAL.ATCHMT_FILE_NAME');  
APPCORE_CUSTOM.EVENT('OPEN-DOCUMENT');  
else  
ATCHMT_OPEN_OTHER_DOCUMENT.open_document('document_header');  
end if;

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 14: Save your changes
1. In the Object Navigator, select File > Save to save FNDATTCH.
2. Close Oracle Forms Builder.
3. Navigate to $c_MARKVIEW_TOP/forms/US.
4. Using Oracle Forms generator, issue the following command to compile the form into an .fmx 

file, substituting the appropriate userid information.

 These commands must be run on a single line. If you cut and paste from this guide, 
remove any line breaks.

For Oracle R12:
frmcmp userid=apps/apps-pw@connectstring module=$c_MARKVIEW_TOP/forms/US/
FNDATTCH.fmb module_type=FORM compile_all=YES

The compiled form is now in the US forms directory at FNDATTCH.fmx.

 MarkView has encountered problems when compiling forms in some versions of Forms 
Builder. Compile from the command line to safeguard against these problems.

5. In the host operating system, copy FNDATTCH.fmx to $FND_TOP/forms/US.
For example, from a UNIX shell using socket mode, run the following command:
$ cp $c_MARKVIEW_TOP/forms/US/FNDATTCH.fmx $FND_TOP/forms/US

 You do not need to copy FNDATTCH.fmb to $FND_TOP/forms/US. At runtime, the system 
uses the .fmx file, not the .fmb file.
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Update the custom library (CUSTOM.pll)
The custom library (CUSTOM.pll) is an Oracle Forms library shipped with Oracle Applications. The 
custom library is attached to all forms in the E-Business Suite. As shipped by Oracle, this library 
performs no functions, but provides callouts for custom logic.

The MarkView installer overwrites CUSTOM.pll to integrate it with MarkView. Therefore, if you added 
your own customizations to CUSTOM.pll, restore the version of CUSTOM.pll that contains your 
modifications and manually add the MarkView integration code.

Step 1: Back up the active CUSTOM.pll and CUSTOM.plx files
Back up the active versions of the CUSTOM.pll and CUSTOM.plx files before you restore the 
modified CUSTOM.pll file.

1. Create the following directory (if it does not already exist):
$c_MARKVIEW_TOP/MVOA/<version_number>/restore

where <version_number> is the Oracle version number.
2. Copy:

$AU_TOP/resource/CUSTOM.plx

to:
$c_MARKVIEW_TOP/MVOA/<version_number>/restore

3. Copy:
$AU_TOP/resource/CUSTOM.pll

to:
$c_MARKVIEW_TOP/MVOA/<version_number>/restore

Step 2: Restore the modified CUSTOM.pll file
If you did not modify the CUSTOM.pll file, skip this step and proceed to Step 3: Open CUSTOM.pll for 
editing on page 85.

If you added your own customizations to CUSTOM.pll, restore the version of the file that contains 
your changes. The MarkView installer creates restore directories with both CUSTOM.pll and 
CUSTOM.plx files in

$c_MARKVIEW_TOP/MVOA/<version_number>/Restore_<timestamp>

where <version_number> is the Oracle version number, and <timestamp> is the date and time when 
the MarkView installer ran.

1. Locate the original CUSTOM.pll file in $c_MARKVIEW_TOP/MVOA/<version_number>/
Restore_<timestamp>.
If multiple restore directories exist, use the directory which contains the most recent version of 
your modified files.

2. Copy:
$c_MARKVIEW_TOP/MVOA/<version_number>/Restore_<timestamp>/CUSTOM.pll
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to:
$c_MARKVIEW_TOP/MVOA/<version_number>/libraries/

Step 3: Open CUSTOM.pll for editing
1. Start Oracle Forms Builder as described in Start Oracle Forms Builder on page 79.
2. Connect to the Oracle APPS database schema.

a. Select File > Connect.

b. Enter the Oracle APPS database user, password, and connect string (the same credentials 
specified during MarkView for Oracle Applications installation).

3. Select File > Open and open:
$c_MARKVIEW_TOP/MVOA/<version_number>/libraries/CUSTOM.pll

where <version_number> is the Oracle version number.
The name of the library, CUSTOM, appears under PL/SQL Libraries in the navigation tree.

Step 4: Attach libraries (customized versions of CUSTOM.pll only)
If you did not customize CUSTOM.pll, skip this step and proceed to Step 5: Edit the zoom_available 
and style functions and the event procedure on page 86. If you customized CUSTOM.pll, 
manually attach the following MarkView libraries to CUSTOM.pll:
• MVOAUTIL.pll
• MVVIEWER.pll
• MVFOLDER.pll
• SFAPI.pll

1. In the Object Navigator, expand PL/SQL Libraries > CUSTOM and select Attached Libraries.
2. Click the plus sign + button in the toolbar to create a new attached library.

The Attach Library window opens.
3. Click Browse.

The PL/SQL Library File window opens.
4. Navigate to $AU_TOP/resource and select MVOAUTIL.pll.
5. Click OK.

The PL/SQL Library File window closes.
6. Click Attach.
7. Repeat these steps for MVVIEWER.pll, MVFOLDER.pll, and SFAPI.pll.

All four attached libraries are visible under Attached Libraries in the tree.
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Step 5: Edit the zoom_available and style functions and the event 
procedure

The following changes modify zoom_available, style, and event so that they call the MVOAUTIL 
library. Since these modifications require some additional analysis, contact Kofax Technical Support 
before you make these changes to CUSTOM.pll.

1. In the Object Navigator, expand PL/SQL Libraries > CUSTOM > Program Units and select
CUSTOM* (Package Body)@.

2. Right-click and select PL/SQL Editor.
3. In the function zoom_available section, comment out any existing return lines, such as:

# return(FALSE);

4. Add the following code to the function zoom_available section immediately before the end 
line:
return(MVOA_Util.Zoom_Available);

5. In the function style section, comment out any existing return lines, such as:
# return(FALSE);

6. Add the following code to the end of the function style section immediately before the end 
line:
return(MVOA_Util.Zoom_Style);

7. In the procedure event section, comment out any existing return lines, for example:
# return(FALSE);

8. Add the following code to the end of the procedure event section immediately before the end 
line:
MVOA_Util.Event(event_name);
if ( (GET_APPLICATION_PROPERTY(Current_Form_Name) ='APXXXEER'  
or GET_APPLICATION_PROPERTY(Current_Form_Name) = 'SFXIISIM'
or GET_APPLICATION_PROPERTY(Current_Form_Name) ='APXINWKB')  
and event_name = 'ZOOM') then
execute_trigger('WHEN-WINDOW-ACTIVATED');
end if;

9. Select File > Save and close the PL/SQL Editor.

Step 6: Compile and copy CUSTOM.pll
1. Using Oracle Forms generator, issue the following command to compile CUSTOM.pll into 

CUSTOM.plx. In this command, <version_number> is the Oracle version number:

 These commands must be run on a single line. If you cut and paste from this guide, 
remove any line breaks and update the version number.

Oracle R12
frmcmp userid=apps/apps-pw@connectstring module=$c_MARKVIEW_TOP/MVOA/  
<version_number>/libraries/CUSTOM.pll module_type=LIBRARY compile_all=YES

2. Copy:
$c_MARKVIEW_TOP/MVOA/<version_number>/libraries/CUSTOM.pll
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to:
$AU_TOP/resource

where <version_number> is the Oracle version number.
3. Copy:

$c_MARKVIEW_TOP/MVOA/<version_number>/libraries/CUSTOM.plx

to:
$AU_TOP/resource

where <version_number> is the Oracle version number.

Enable Invoice Workbench (optional)
If you plan to use Oracle Forms with the MarkView Process GetNext or Open Work Item operations, 
modify the copies of the original Oracle Forms. This section describes how to enable Invoice 
Workbench functionality for MarkView Process workflow processing, by creating a modified version 
of the Invoice Workbench form (APXINWKB). This modified form (SFXINWKB) will be enabled for 
both GetNext and Open Work Item.

The following instructions assume that the MarkView base path is the default, $c_MARKVIEW_TOP.

Step 1: Image-enable the default Invoice Workbench form (optional)
There are two versions of the Invoice Workbench form:
• The integrated version (SFXINWKB.fmb). Use this version when you require GetNext and Open 

Work Item workflow processing from the Invoice Workbench.
• The unintegrated version (APXINWKB.fmb). Use this version when you do not require GetNext or 

Open Work Item workflow processing from the Invoice Workbench.

If you use the integrated version, skip this step and go to Step 2: Copy the Invoice Workbench form
on page 87.

If you use the unintegrated version, image-enable the default invoice workbench form.
1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-

Business suite owner. The default account for this user is applmgr.
2. Navigate to:

<distribution directory>\modules\erp-integration-oracle-dist-x.x.x\erp-
integration-oracle-db\schema\seed_data\oracle_forms

where x.x.x is the MarkView version number.
3. Run APXINWKB.sql.
4. Continue at Configure Oracle Forms for multi-language support (optional) on page 90.

Step 2: Copy the Invoice Workbench form
1. Copy:

$AU_TOP/forms/US/APXINWKB.fmb

to:
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$c_MARKVIEW_TOP/forms/US

2. Rename:
$c_MARKVIEW_TOP/forms/US/APXINWKB.fmb

to:
$c_MARKVIEW_TOP/forms/US/SFXINWKB.fmb

Step 3: Open the SFXINWKB form
1. Start Oracle Forms Builder as described in Start Oracle Forms Builder.
2. Connect to the Oracle APPS database schema.

a. Select File > Connect.

b. Enter the Oracle APPS database user, password, and connect string (the same credentials 
specified during MarkView for Oracle Applications installation).

3. Select File > Open and open $c_MARKVIEW_TOP/forms/US/SFXINWKB.fmb.

 The name of the form, APXINWKB, appears at the top of the navigation tree. Do not 
change this name to SFXINWKB. Only the .fmb and .fmx file names change.

Step 4: Edit the IMG_IMAGE_ID item
1. In the Object Navigator, expand APXINWKB > Data Blocks > INV_SUM_FOLDER > Items.
2. Click the plus sign + button in the toolbar to create a new item.

The new item appears at the top of the tree.
3. Right-click the item and select Property Palette.
4. In the Property Palette General section Name field, enter IMG_IMAGE_ID.
5. In the Item Type field, select Text Item.
6. In Subclass Information, click the button to the right of the blank field.

The Subclass Information window opens.
7. Select Property Class and click OK.
8. In the Property Palette Data section Maximum Length field, enter 240.
9. In the Property Palette Database section Database Item field, select No.

10. Close the Property Palette.

Step 5: Edit the Invoice Folder
1. Expand APXINWKB > Program Units and select INV_SUM_FOLDER_BLOCK_INSERT1* 

(Package Body).
2. Right-click and select PL/SQL Editor.
3. Add the following code immediately before the END Insert_Row line:

IF :INV_SUM_FOLDER.IMG_IMAGE_ID IS NOT NULL THEN
APPCORE_CUSTOM.EVENT('INVOICE-IMAGE-ASSOCIATED');
END IF;

4. For Oracle R12: ClickProgram > Compile PL/SQL > Incremental and close the window.
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Step 6: Edit the KEY-DUPREC trigger
1. In the Object Navigator, expand APXINWKB > Data Blocks > INV_SUM_FOLDER > Triggers

and select KEY-DUPREC.
2. Right-click and select PL/SQL Editor.
3. Replace the existing text with the following:

-- inv_sum_folder.event('KEY-DUPREC');  
Declare  
      cur_image_id Varchar2(240);  
Begin  
      cur_image_id := :inv_sum_folder.img_image_id;  
      inv_sum_folder.event('KEY-DUPREC');  
      :inv_sum_folder.img_image_id := cur_image_id;  
End;

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 7: Create the WHEN-WINDOW-ACTIVATED trigger
1. In the Object Navigator, expand APXINWKB and select Triggers.
2. Click the plus sign + button in the toolbar to create a new trigger.

A list of trigger names appears.
3. In the list, select WHEN-WINDOW-ACTIVATED and click OK.

The PL/SQL Editor opens.
4. Add the following code to the new WHEN-WINDOW-ACTIVATED trigger:

APPCORE_CUSTOM.EVENT('MVOA-WHEN-WINDOW-ACTIVATED');

5. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 8: Edit the SFXINWKB form revision number
1. In the Object Navigator, expand APXINWKB > Program Units and select APXINWKB 

(Package_Body).
2. Right-click and select PL/SQL Editor.
3. Append .170 to the revision number to indicate that the form is edited for MarkView 

integration.
For example, change:
FND_STANDARD.FORM_INFO('$Revision: 115.155.11591.2')
to:
FND_STANDARD.FORM_INFO('$Revision: 115.155.11591.2.170')

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 9: Compile the Invoice Workbench form
1. In the Object Navigator, select File > Save to save SFXINWKB.
2. Close Oracle Forms Builder.
3. Navigate to $c_MARKVIEW_TOP/forms/US.
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4. Using Oracle Forms generator, issue the correct command to compile the form into an .fmx 
file, substituting the appropriate userid information.

 These commands must be run on a single line. If you cut and paste from this guide, 
remove any line breaks.

For Oracle R12:
frmcmp userid=apps/apps-pw@connectstring module=$c_MARKVIEW_TOP/forms/US/
SFXINWKB.fmb module_type=FORM compile_all=YES

The compiled form is now at $c_MARKVIEW_TOP/forms/US/SFXINWKB.fmx.

 MarkView has encountered problems when compiling forms in some versions of Forms 
Builder. Compile from the command line to safeguard against these problems.

Configure Oracle Forms for multi-language support (optional)
To configure Oracle Forms to support languages in addition to the default, US English, edit 
language-specific versions of the forms to include the MarkView integration code.

1. Locate the FNDATTCH.fmb file for the target language. For example, the US English version of 
this file is located at:
$AU_TOP/forms/US/FNDATTCH.fmb

and the French version of the file is located at:
$AU_TOP/forms/F/FNDATTCH.fmb

2. Create a new language-specific subdirectory under $c_MARKVIEW_TOP/forms. For example, if 
you are adding support for French, create:
$c_MARKVIEW_TOP/forms/F

3. Modify the FNDATTCH.fmb file for the target language to include the MarkView integration 
code, as described in Update the Oracle Attachments form (FNDATTCH.fmb) on page 80.

4. Copy the APXINWKB.fmb file from the language-specific subdirectory in $AU_TOP/forms to the 
new language-specific subdirectory under $c_MARKVIEW_TOP/forms that you created in step
2.

5. Rename the APXINWKB.fmb file to SFXINWKB.fmb.
6. Modify the SFXINWKB.fmb file for the target language to include the MarkView integration 

changes, as described in Enable Invoice Workbench (optional) on page 87 .
7. Use the Oracle Forms Generator to compile SFXINWKB.fmb into SFXINWKB.fmx.

Make sure the .fmx file is in the correct language-specific subdirectory.
8. Repeat these steps for each language that you want to support.

Enable MarkView Quick Invoices (optional)
If Kofax Transformation Modules for MarkView is a part of your solution, enable MarkView Quick 
Invoices.
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Step 1: Copy the Quick Invoices form
1. Copy:

$AU_TOP/forms/US/APXIISIM.fmb

to:
$c_MARKVIEW_TOP/forms/US

2. Rename:
$c_MARKVIEW_TOP/forms/US/APXIISIM.fmb

to:
$c_MARKVIEW_TOP/forms/US/SFXIISIM.fmb

Step 2: Open the SFXIISIM form
1. Start Oracle Forms Builder as described in Start Oracle Forms Builder.
2. Connect to the Oracle APPS database schema.

a. Select File > Connect.

b. Enter the Oracle APPS database user, password, and connect string (the same credentials 
specified during MarkView for Oracle Applications installation).

3. Select File > Open and open $c_MARKVIEW_TOP/forms/US/SFXIISIM.fmb.
4. In the Property Palette, update the form name from APXIISIM to SFXIISIM at the top of the 

tree.

Step 3: Edit the IMG_IMAGE_ID item
1. In the Object Navigator, expand SFXIISIM > Data Blocks > INVOICES_FOLDER > Items.
2. Click the plus sign + button in the toolbar to create a new item.

The new item appears at the top of the tree.
3. Right-click the item and select Property Palette.
4. In the Property Palette General section Name field, enter IMG_IMAGE_ID.
5. In the Item Type field, select Text Item.
6. In Subclass Information, click the button to the right of the blank field.

The Subclass Information window opens.
7. Select Property Class and click OK.

The Subclass Information window closes.
8. In the Property Palette Data section Maximum Length field, enter 240.
9. In the Property Palette Database section Database Item field, select No.

10. Close the Property Palette.

Step 4: Edit the ON-INSERT trigger
1. In the Object Navigator, expand SFXIISIM > Data Blocks > INVOICES_FOLDER > Triggers and 

select ON-INSERT.
2. Right-click and select PL/SQL Editor.
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3. Add the following code after the call to INVOICES_FOLDER.INSERT_ROW:
IF :INVOICES_FOLDER.IMG_IMAGE_ID IS NOT NULL THEN 
 APPCORE_CUSTOM.EVENT('INTERFACE-INVOICE-IMAGE-ASSOCIATED');
END IF;

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 5: Edit the KEY-DUPREC trigger
1. In the Object Navigator, expand SFXIISIM > Data Blocks > INVOICES_FOLDER > Triggers and 

select KEY-DUPREC.
2. Right-click and select PL/SQL Editor.
3. Replace the existing text with the following:

--invoices_folder.key_duprec;
Declare 
 cur_image_id Varchar2(240);
Begin 
 cur_image_id:=:invoices_folder.img_image_id; 
 invoices_folder.key_duprec; 
 :invoices_folder.img_image_id:=cur_image_id;
End;

4. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 6: Create the WHEN-WINDOW-ACTIVATED trigger
1. In the Object Navigator, expand SFXIISIM and select Triggers.
2. Click the plus sign + button in the toolbar to create a new trigger.

A list of trigger names appears.
3. In the list, select WHEN-WINDOW-ACTIVATED and click OK.

The PL/SQL Editor opens.
4. Replace the existing code with:

default_value(null, 'global.mvoa_open_opening_work_item');
if :GLOBAL.MVOA_OPEN_OPENING_WORK_ITEM = 'Y' then 
 clear_block(no_validate);
end if;
APPCORE_CUSTOM.EVENT('MVOA-WHEN-WINDOW-ACTIVATED');

5. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.

Step 7: Edit the WHEN-NEW-FORM-INSTANCE trigger
1. In the Object Navigator, expand SFXIISIM > Triggers and select WHEN-NEW-FORM-

INSTANCE.
2. Right-click and select PL/SQL Editor.
3. Comment out the following line:

--EXECUTE_TRIGGER('QUERY_FIND');

4. Add the following line:
set_window_property('INVOICES_FOLDER_WINDOW', title, 'MarkView Quick Invoices');

5. For Oracle R12: Click Program > Compile PL/SQL > Incremental and close the window.
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Step 8: Edit the SOURCE_DSP item
1. In the Object Navigator, expand SFXIISIM > Data Blocks > QF_ INVOICES > Items and select

SOURCE_DSP.
2. Right-click the item and select Property Palette.
3. In the Data section, set Required to No.
4. Close the Property Palette.

Step 9: Edit the GROUP_ID item
1. In the Object Navigator, expand SFXIISIM > Data Blocks > QF_ INVOICES > Items and select

GROUP_ID.
2. Right-click the item and select Property Palette.
3. In the Data section, set Required to No.
4. Close the Property Palette.

Step 10: Edit the Query Data Source Name
1. In the Object Navigator, expand SFXIISIM > Data Blocks and select INVOICES_FOLDER.
2. Right-click and select Property Palette.
3. In the Database section, set Query Data Source Name to MVCN_AP_INVOICES_INTERFACE_V.
4. Close the Property Palette.

Step 11: Edit PRE_UPDATE, LOCK_ROW, and UPDATE_ROW procedures for 
Oracle EBS 12.x

Oracle enhancements to APXIISIM and party_site_id in now enable you to create two invoices with 
the same invoice number, vendor, and vendor_site_id.

If you applied the Oracle patches, edit the PRE_UPDATE, LOCK_ROW, and UPDATE_ROW procedures 
to configure MarkView to support the enhancements. If you are not sure whether or not you 
applied the patches, follow these instructions; if the text of your PRE_UPDATE, LOCK_ROW, and 
UPDATE_ROW procedures do not match those in a particular step, skip that step.

1. In the Object Navigator, expand SFXIISIM > Program Units.
2. Right-click INVOICES_FOLDER_EVENT (Package Body) and select PL/SQL Editor.
3. Edit the PRE_UPDATE procedure:

a. In the PRE_UPDATE procedure, locate the ap_invoices_interface section:
  select count(1) 
  into   x_cnt_inv_int 
  from    ap_invoices_interface
  where  invoice_num = :invoices_folder.invoice_num 
  and    vendor_id = :invoices_folder.vendor_id
and (party_site_id = :invoices_folder.party_site_id
/*Bug9105666*/
OR (party_site_id is null and :invoices_folder.party_site_id is
null)) /*Bug9105666*/
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 If the PRE_UPDATE procedure does not include these lines, continue at step 4.

b. Edit these lines:
and (party_site_id = :invoices_folder.party_site_id
/*Bug9105666*/
OR (party_site_id is null and :invoices_folder.party_site_id is
null)) /*Bug9105666*/

• To allow the same invoice number for another vendor_site_id, replace those lines with:
  
and  (vendor_site_id = :invoices_folder.vendor_site_id /*Bug9105666*/ 
        OR (vendor_site_id is null and :invoices_folder.vendor_site_id is 
 null)) /*Bug9105666*/

• To prevent the same invoice number from being used twice for the same vendor, 
comment out the lines.

4. Click Program > Compile PL/SQL > Incremental and close the window.
5. Right-click INVOICES_FOLDER_EVENT_LOCK (Package Body) and select PL/SQL Editor.
6. Edit the INVOICES_FOLDER_EVENT_LOCK.LOCK_ROW procedure:

a. Locate the LOCK_ROW procedure.

b. If the following line appears in the LOCK_ROW procedure, comment out the line:
x_party_site_id => :invoices_folder.party_site_id 
      /*Bug 16361548*/  
       

7. Click Program > Compile PL/SQL > Incremental and close the window.
8. Right-click INVOICES_FOLDER_EVENT_UPDATE (Package Body) and select PL/SQL Editor.
9. Edit the INVOICES_FOLDER_EVENT_UPDATE.UPDATE_ROW procedure:

a. Locate the UPDATE_ROW procedure.

b. If the following line appears in the UPDATE_ROW procedure, comment out the line:
 x_party_site_id => :invoices_folder.party_site_id 
      /*Bug 16361548*/  
       

10. Click Program > Compile PL/SQL > Incremental and close the window.

Step 12: Edit INVOICES_CONTENT
1. In the Object Navigator, expand SFXIISIM > Canvases and select INVOICES_CONTENT.
2. Right-click and select Layout Editor.
3. Right-click Save and Next in the lower right corner of the form to open the Property Palette.
4. In the Functional section, set Enabled to No.
5. In the Physical section, set Visible to No.
6. Close the Property Palette.
7. Close INVOICES_CONTENT.
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Step 13: Save your changes
1. In the Object Navigator, select File > Save to save SFXIISIM.
2. Close Oracle Forms Builder.
3. Navigate to $c_MARKVIEW_TOP/forms/US.
4. Using Oracle Forms generator, issue the following command to compile the form into an .fmx 

file, substituting the appropriate userid information.

 These commands must be run on a single line. If you cut and paste from this guide, 
remove any line breaks.

For Oracle R12:
frmcmp userid=apps/apps-pw@connectstring module=$c_MARKVIEW_TOP/forms/US/
SFXIISIM.fmb module_type=FORM compile_all=YES

The compiled form is now at $c_MARKVIEW_TOP/forms/US/SFXIISIM.fmx.

 MarkView has encountered problems when compiling forms in some versions of Forms 
Builder. Compile from the command line to safeguard against these problems.

Synchronize the run and patch file systems (Oracle EBS 12.2 
only)

Follow these steps if you are integrating MarkView with Oracle E-Business Suite 12.2 or higher.

Proceed to one of the following procedures to synchronize the MarkView files between the run and 
patch file systems:
• Synchronize the MarkView files using adop phase=fs_clone command

The file systems synchronization with adop phase=fs_clone command requires a large amount 
of free disk space to be available for adop operations. The synchronization procedure is time-
consuming. For more information about space requirements, refer to the Oracle documentation.

• Synchronize the MarkView files using custom synchronization driver (for UNIX only)
This procedure requires less time and disk space compared to the synchronization using adop 
phase=fs_clone.

Synchronize the MarkView files using adop phase=fs_clone command
If you configured Oracle Forms or applied any changes to the Oracle Forms, do the following:

1. Before synchronizing the run and patch file systems, verify that no patching cycle is currently 
active.
For example, from a UNIX shell, run the following command:
$ adop -status

2. To propagate the changes to the secondary file system, run the following command:
 $ adop phase=fs_clone
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adop phase=fs_clone command recreates the patch edition file system as an exact copy of 
the run edition file system.

3. For more information about using the Oracle adop (the AD Online Patching) utility, refer to the 
Oracle adop utility documentation.

Synchronize the MarkView files using custom synchronization driver (for 
UNIX only)

If you configured Oracle Forms or applied any changes to the Oracle Forms, do the following:
1. Before synchronizing the run and patch file systems, verify that no patching cycle is currently 

active.
For example, from a UNIX shell, run the following command:
$ adop -status

2. In <distribution_directory>\installer\tools, locate the copy_mv_objects.sh shell 
script,
where <distribution_directory> is the location where you downloaded and decompressed the 
installation files.

3. Copy copy_mv_objects.sh to: $APPL_TOP_NE/ad/custom/
Verify that the copied script has the Execute permissions.

4. In $APPL_TOP_NE/ad/custom/adop_sync.drv, add the following line between #Begin 
Customization and #End Customization:
sh %s_ne_base%/EBSapps/appl/ad/custom/copy_mv_objects.sh 
      %s_current_base% %s_other_base%

Next time you start a new patching cycle with the adop phase=prepare command, the 
MarkView files will be synchronized between the file systems.

 The files will be automatically synchronized between the file systems each time you start a new 
patching cycle with the adop phase=prepare command.

If you do not want to propagate any subsequent changes in the MarkView files (for example, 
temporary changes in the customized Oracle Forms) from the run file system to the patch file 
system, comment out the added line in $APPL_TOP_NE/ad/custom/adop_sync.drv to stop 
synchronization.
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Chapter 10

Capture and Output modules

MarkView Capture and Output modules control how documents enter into and are output from 
the MarkView system. MarkView requires at least one Capture and Output module. You can install 
Capture and Output components at the same time or separately.

For more information about the MarkView Capture and Output modules, see the following 
documents on the Kofax MarkView Product Documentation site:
• Kofax MarkView Planning Guide
• Kofax MarkView Technical Specifications.

Each Capture and Output component has its own installer. You can choose modules to install and 
run their installers:
• MVBarcodeServer.Installer forMarkView Bar Code Server
• sfMailService.Installer for MarkView Mail Gateway
• MVImport.Installer forMarkView Import Server
• MVDataExport.Installer for MarkView Data Export Server.

About installing Data Export Server for Kofax Transformation 
Modules

The Data Export Server provides data from Oracle and MarkView to Kofax Transformation Modules 
for validation and is required for MarkView AP.

Install the Data Export Server on all machines running Kofax Transformation Modules.

Before you start
Install MarkView Application Server and Database components before you install  any Capture and 
Output module. For more information, see Run the MarkView installer on page 59.

Download and extract the installer and Verify files
Download the compressed MarkView System setup files from the Kofax Fulfillment Site.
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To access the files:
1. Log in as the local administrator for the operating system for the Windows Capture and Output 

server.
2. Create a temporary distribution directory for the compressed MarkView installer file, for 

example, C:\mvcodist.
3. Download the following file into the distribution directory:

KofaxMarkView-<version_number>_Capture_Output.zip
4. Extract the file.

 The built-in ZIP utilities in certain versions of Windows have issues with lengthy directory 
paths. Use a third-party extraction utility if your directory paths are more than 200 characters 
long.

Install Oracle Database 19c Client (19.3) for Microsoft Windows
For the Oracle Data Access Components supported, see "Required Third-Party Technologies" in the
Kofax MarkView Technical Specifications document. Look at the table and select between the 32-bit or 
64-bit version.

If you plan to integrate with Kofax Capture and Kofax Transformation Modules on Windows Server 
2019, complete the following procedure.

1. Install Oracle Database 19c Client (19.x) (ODAC).

a. Run the installer.

b. Select the Custom installation type.

c. On the Available Product Components page, select the following components.
• Oracle ODBC Driver.
• Oracle Provider for OLE DB.
• Oracle Data Provider for .NET.

d. Install the product.
2. If you installed ODAC Xcopy version, register Oracle.DataAccess.dll in the GAC by running the 

following commands:
OraProvCfg.exe /action:gac /providerpath:<oracle_client>\odp.net\bin
\4\Oracle.DataAccess.dll
OraProvCfg.exe /action:config /force /product:odp /frameworkversion:v4.0.30319
/providerpath:<oracle_client>\odp.net\bin\4\Oracle.DataAccess.dll

3. If you installed ODAC Xcopy version and you encounter problems with database connectivity, 
run the following commands to register Oracle products in the GAC manually.
cd <oracle_client>\odp.net\bin\4

OraProvCfg.exe /action:ungac /providerpath:<oracle_client>\odp.net\bin
\4\Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy
\4\Policy.4.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
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/providerpath:<oracle_client>\odp.net\PublisherPolicy
\4\Policy.4.121.Oracle.DataAccess.dll

cd <oracle_client>\odp.net\bin\4

OraProvCfg.exe /action:gac /providerpath:<oracle_client>odp.net\bin
\4\Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy
\4\Policy.4.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy
\4\Policy.4.121.Oracle.DataAccess.dll

cd <oracle_client>\odp.net\bin\2.x

OraProvCfg.exe /action:ungac /providerpath:<oracle_client>\odp.net\bin\2.x
\Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.102.Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.111.Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.121.Oracle.DataAccess.dll

cd <oracle_client>\odp.net\bin\2.x

OraProvCfg.exe /action:gac /providerpath:<oracle_client>\odp.net\bin\2.x
\Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.102.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.111.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.121.Oracle.DataAccess.dll

Where <oracle_client> is the Oracle Database 19c Client installation folder.

 Some Windows folders (such as C:\Users\<USER NAME>) may be protected and have 
permission restrictions.
Folder location values that contain spaces must be enclosed in double quotation marks. 
Example: "C:\oracle client\network\admin".
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Customize the tnsnames.ora file
Your tnsnames.ora file is an Oracle DBMS file that specifies the names and locations of your 
databases. MarkView uses the information to communicate with the database. A template 
tnsnames.ora file is installed with the Oracle components.

Edit the template tnsnames.ora file to:
• Refer to the correct databases
• Contain the name and location of your Oracle DBMS

 Edit tnsnames.ora for each instance of ODAC installed on your system.

Bar Code and Mail Gateway prerequisites
Kofax VirtualReScan (VRS) includes a bar code reader. Determine whether you need to install VRS 
separately:
• If you are installing Bar Code Server on a system with Kofax Capture, you do not need to install 

VRS separately. VRS is installed silently as part of all Kofax Capture installations.
• If you are installing Bar Code Server on a system without Kofax Capture, install VRS. See the Kofax 

VirtualReScan (VRS) Installation Guide for information about installing VRS. For a list of supported 
versions, see the Kofax MarkView Technical Specifications document on the Kofax MarkView 
Product Documentation site.

Install Capture and Output modules
Install  each Capture and Output module separately.

1. Log in as the local administrator for the operating system for the Windows Capture and Output 
server.

2. Navigate to <distribution_directory> and run one of the available installers: 
MVBarcodeServer.Installer.msi, MVDataExport.Installer.msi, MVImport.Installer.msi, or 
sfMailService.Installer.msi.

3. Follow the prompts to install the components you selected.
4. Run another component installer that you need.

Configure Capture and Output modules
Installing any of the Capture and Output modules creates a default unconfigured service named 
DB1. It also places configuration shortcuts on the desktop. Complete the steps in the following 
sections to configure Capture and Output modules.
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Configure Data Export Server
Follow these steps to configure newly installed instances of Data Export Server. Upgrades to 
existing instances of Data Export Server do not require reconfiguring.

1. Double-click the MV Data Export Server - Configuration shortcut on your desktop.
2. Enter an instance Name that identifies the function that the instance will perform, such as 

Contacts, and click OK.
3. Select the instance and click Preferences.
4. In the MarkView Data Export Server Preferences window, provide the following:

• Database user: The MarkView schema user
• Database password: The password for the MarkView schema user
• Database host: The TNS alias name that was configured in the TNS names file (such as 

tnsnames.ora) for the database instance of the MarkView schema
5. In the Data Function list, select the data function for the instance.

Data Function Description

Provides vendor information to Kofax Transformation Modules Validation for 
selecting valid vendors/vendor sites to associate with invoices. Each record in this 
data feed is a Supplier Site, so you might have multiple records for Suppliers with 
multiple Sites. Provides the following values for each vendor/vendor site:

Get Vendor

Company
Active/Inactive
Enabled/Disabled
Organization Name/Org Short 
Name
Supplier Site Code
Street Name
Street 2

Street 3
City Name
State
Zip
Phone
Fax
Supplier ID

Supplier Site ID
Org ID
Tax ID 1 (VAT Registration 
Number)
Tax ID2
Bank Code
Bank Account
IBAN

Get Contacts Provides contact information to Kofax Transformation Modules Validation for 
associating contacts with invoices. Provides the following values for each invoice 
approver.
• Last Name
• First Name
• User ID

Each invoice approver must have an email address configured for use with 
MarkView.

Get Organizations Provides organization information to Kofax Transformation Modules Validation 
for associating valid organizations with invoices. This data is derived from 
Organizations configured in MarkView; it is not the full list of Organizations 
defined in Oracle Applications. Provides the following values for each 
organization:
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Data Function Description

ORGID
ORGNAME
ADDRESSLINE1
ADDRESSLINE2
CITY

REGION
POSTALCODE
COUNTRY
BASECURRENCY

Get Purchase Order 
Numbers

Provides purchase order information to Kofax Transformation Modules Validation 
UI for associating valid purchase orders with invoices. Provides the following 
values for each purchase order:
• Purchase Order #
• PO Type (Blanket or Standard)
• Release Number (for Blanket POs only)

Generate Tax 
Regime Feed

Provides tax Regime information for Oracle EBS 12.x (data available is specific to 
the Org of the invoice)

Generate Tax Feed Provides tax code information for Oracle EBS 12.x (data available is specific to the 
Org and Tax Regime of the invoice)

Generate Tax 
Jurisdiction Feed

Provides the Tax Jurisdiction information for Oracle EBS 12.x (data available is 
specific to the Org, Tax Regime, and Tax of the invoice)

Generate Tax 
Status Feed

Provides the Tax Status information for Oracle EBS 12.x (data available is specific 
to the Org, Tax Regime, and Tax of the invoice)

Other Provides custom information for use in the Validation UI.

When you select a data function, MarkView populates the following fields:
• Output folder
• Output file
• XSL Transform

6. Ensure that the Output folder points to the location of the Kofax Transformation Modules 
project file. The default is C:\KTM\MarkView\KTM Source Files\Databases.

7. Set the database polling interval and the connection retry interval, then click OK.
8. Repeat these steps for the remaining functions: Contacts, Vendors, Purchase Orders, and 

Organizations.
9. Open the Windows Service Manager.

10. Specify the startup type (automatic or manual) as follows:

a. Right-click the MarkView service name.

b. Select Properties.

c. In the Startup Type list, select Automatic or Manual.
11. If your configuration requires access to network resources requiring authentication:

a. Right-click the MarkView service name.

b. Select Properties.

c. Select the Log On tab.

d. Log in as a user with access to the network resources.
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Configure Bar Code Server and Mail Gateway

Configure Bar Code Server
Follow the steps in this section to configure the Bar Code Server source and Bar Code Server 
Instances.

Configure the Bar Code Server source
Configure a Kofax VirtualReScan (VRS) file import scan source and set that source as the default. The 
process to use depends on your VRS version. Use the following procedure as a guideline. See the
Kofax VirtualReScan (VRS) User Guide for information.

1. Open the VRS configuration tool, the Scanner Configurator.
2. If a Kofax Software Import Source (no image processing) appears in the list of configured 

sources, remove it.
3. Configure a file import scan source.
4. Set the source you create as the default.

Configure the Bar Code Server instances
To create a new instance or modify DB1:

1. Double-click the MarkView Bar Code Server Configuration shortcut on the desktop.
2. In the Bar Code Server window, either:

• Click New to create a new instance.
• Click Preferences to edit DB1.

The Bar Code window opens.
3. Enter the name (either a new instance name or DB1), and click OK.

The Preferences window opens.
4. Enter the following information to complete the window fields:

Control Description

Server Name The name of the bar code server as defined in MarkView Administration.
Default: DEFAULT_BARCODE_SERVER

DbAccount The name associated with the MarkView schema user.

DbPassword The password associated with the MarkView schema user.

DbHost The name of the Oracle host database defined in the Oracle TNS file.

MVAccount The MarkView User ID of a user defined in MarkView Administration with privileges 
to download files from the Document Server, such as ADMIN.

MVPassword The password associated with the MVAccount.

WorkStation The workstation serial number that, in conjunction with database preferences, 
selects the protocol used to save and retrieve documents.
Default: WEB_CLIENT
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Control Description

Polling Period The number of seconds that the server instance waits when checking for new bar 
code requests. The server processes bar code requests found in the queue until 
none are left. It then waits the duration of the polling period before checking again.
Default: 10

Reconnect after 
error

The number of minutes that the server instance waits before retrying a failed bar 
code request.

Include in event 
log

Event log option to record errors only, or to record errors and information 
messages.

5. Click Save.
The default service DB1 is set up with a startup type of Manual. To take advantage of Windows 
services features, set the startup type of the new instance to Automatic.

6. Click Test to validate the server name, workstation name, and database connectivity.
7. Click OK to clear the success window. If the MarkView Bar Code Properties window does not 

open automatically:

a. Click Bar Code Settings.

b. Click OK to close the MarkView Bar Code Properties window without making any 
changes.

 Do not alter the settings in the MarkView Bar Code Properties window unless 
instructed to do so by Kofax Technical Support.

Configure Mail Gateway
To open the Mail Gateway window and configure server instances, double-click the MarkView 
Process Mail Gateway Configuration shortcut on your desktop.

Configure the instance
1. Open MarkView Mail Gateway and click either

• New
OR:

• Preferences.
2. Enter a new instance name and click OK.

The Preferences window, which includes five tabs, opens.
3. Complete the fields on each tab as described in the sections that follow.

Configuration settings take effect the next time you start the service.

Configure monitoring options

The Monitoring tab settings specify which accounts to monitor and how often.
1. Set the following information to complete the tab.
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Field Name Description

Process Outbound 
Messages

Select this option to monitor and process outbound mail messages.

Process Inbound 
Messages

Select this option to monitor and process inbound mail messages.

Polling Period (seconds) Set this value to the number of seconds to wait before checking for new 
messages. Mail Gateway processes any messages it finds until none remain 
to process. The gateway waits the duration of the polling period before 
checking again.
Default: 60

2. To continue, do one of the following:
• Select another tab.
• Click OK to confirm your selections and close the window.

Configuration settings take affect the next time you start the service.

Configure error options

The Error tab settings specify the actions that Mail Gateway takes in response to errors.
1. Set the following information to complete the tab.

Field Name Description

Reconnect on Errors Select this option to have Mail Gateway periodically attempt to reconnect at 
the retry interval specified. Otherwise, Mail Gateway remains disconnected on 
errors and stops the service.
Mail Gateway automatically disconnects from the database and the mail 
system when a database or a mail error occurs.

Error Retry Period 
(minutes)

The number of minutes to wait between retry attempts when reconnecting.
Default: 1

2. To continue, do one of the following:
• Select another tab.
• Click OK to confirm your selections and close the window.

Configuration settings take affect the next time you start the service.

Configure MarkView process options

The MarkView tab specifies which settings to use to connect to the database and the database 
objects to use to process outbound message.

1. Enter the following information to complete the tab.

Field Name Description

Username The name of the database account.

Password The password associated with the database account.

Host The name of the host database as defined in the TNS file.
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Field Name Description

User ID SQLFLOW_MAIL
This is the user account created to connect to the system for processing inbound 
and outbound messages.

Application 
Function

SQL*Flow Mail Gateway
This is the application function created to retrieve work items for processing 
outbound messages.

Completed 
Action

Sent Outbound Email
This is the action created to retrieve work items for processing outbound messages.

Work Item Class Outbound Email Message
This is the work item class created for outbound messages.

2. Click Test to validate database connectivity.
3. To continue, do one of the following:

• Select another tab.
• Click OK to confirm your selections and close the window.

Configuration settings take effect the next time you start the service.

Configure mail options

Mail tab settings specify which options the gateway uses to send and receive email.
1. Select a protocol which determines the available options.
2. Complete the tabs for your outbound protocol.

SMTP Outbound Protocol Options

Field or checkbox Value

Protocol SMTP

SSL Enable to use SSL on authentication.

Server Enter the host name or IP address of the SMTP server or servers to use, 
such as SMTP.KOFAX.COM.
To allow Mail Gateway to try multiple mail servers in case of failures, use a 
semicolon to delimit a list of servers.

Port Enter the TCP/IP port on which to communicate with the SMTP server.
Default: 25

Enable authentication Select if your SMTP server requires authentication.

Enable OAuth Select to use OAuth credentials to authenticate without password.
To configure OAuth credentials, click OAuth Credentials.
The credentials set saved as default is automatically applied for any 
protocol with OAuth authentication enabled.
Register Mail Gateway on your OAuth provider site. When you enable 
OAuth, the password is no longer used to access the mailbox, although it 
remains unchanged.
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Field or checkbox Value

Timeout Specify how many seconds Mail Gateway waits for a response from the 
server before returning an error.
Default: 30

Username If you selected a type of authentication, enter the name of the account to 
use to access the SMTP server.

Password If you selected a type of authentication, enter the password for the 
Username account that accesses the SMTP server.

MAPI Outbound Protocol Options

Field or checkbox Value

Server The host name or IP address of the MAPI server or servers to use.
To allow Mail Gateway to try multiple mail servers in case of failures, use 
semicolons to delimit a list of servers.

Username If the MAPI client requires a user name, enter a user name.
The Microsoft Exchange Inbox client does not require a user name.

Password If the MAPI client requires a password, enter a password.
The Microsoft Exchange Inbox client does not require a password.

3. Click Test Connection to verify your settings.
4. Complete the tabs for your inbound protocol.

POP Inbound Protocol Options

Field or checkbox Value

Protocol POP

SSL Enable to use SSL on authentication.

Server Enter the host name or IP address of the POP3 server to use.

Port Enter the TCP/IP port on which to communicate with the POP3 server.
Default: 110

Timeout Specify how many seconds Mail Gateway waits for a response from 
the server before returning an error.
Default: 30

Preferred Format Select the message format to use.
Some inbound mail messages may contain the same message in 
both text and HTML formats.

Enable OAuth Select to use OAuth to authenticate without password.
To configure OAuth credentials, click OAuth Credentials.
The credentials set saved as default is automatically applied for any 
protocol with OAuth authentication enabled.
Register Mail Gateway on your OAuth provider site. When you 
enable OAuth, the password is no longer used to access the mailbox, 
although it remains unchanged.
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Field or checkbox Value

Username Enter the name of the account to use to access the POP3 server.

Password Enter the password for the user name account that accesses the 
POP3 server.

Mailbox Select the folder. The field is disabled for the POP3 server.
Default: Inbox

MAPI Inbound Protocol Options

Field Value

Server If you use the Microsoft Exchange Inbox client, enter the name of the Profile 
you created when you configured the Microsoft Exchange Inbox client
For other MAPI clients, see the client documentation.

Username If the MAPI client requires a user name, enter a user name.
The Microsoft Exchange Inbox client does not require a user name.

Password If the MAPI client requires a password, enter a password.
The Microsoft Exchange Inbox client does not require a password.

IMAP Inbound Protocol Options

Field or checkbox Value

Protocol IMAP

SSL Enable to use SSL on authentication.

Server Enter the host name or IP address of the IMAP server to use.

Port Enter the TCP/IP port on which to communicate with the IMAP server.
Default: 143

Enable OAuth Select to use OAuth to authenticate without password.
To configure OAuth credentials, click OAuth Credentials.
The credentials set saved as default is automatically applied for any 
protocol with OAuth authentication enabled.
Register Mail Gateway on your OAuth provider site. When you 
enable OAuth, the password is no longer used to access the mailbox, 
although it remains unchanged.

Timeout Specify how many seconds Mail Gateway waits for a response from 
the server before returning an error.
Default: 30

Preferred Format Select the message format to use.
Some inbound mail messages may contain the same message in 
both text and HTML formats.

Username Enter the name of the account to use to access the IMAP server.

Password Enter the password for the user name account that accesses the 
IMAP server.
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Field or checkbox Value

Mailbox Select the folder.
Default: Inbox

5. Click Test Connection to perform connection with the current settings.
6. Click OK to confirm your selections and close the window.

For the configuration settings to take affect, restart the service.

Configure OAuth credentials

To use OAuth credentials, you must register Mail Gateway on your OAuth provider site, such as 
Google Developer Console. This is required to enable the application to access your email account 
without the password. If you experience troubles with registering the application on the OAuth 
provider site, contact the OAuth provider customer service.

 We recommend that you create all instances of Mail Gateway before saving OAuth credentials.
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OAuth Credentials UI elements

UI element Value

Client ID The identifier provided to an application during the registration on the 
OAuth provider site.
Example:
Google Client ID: 1072099888437-8q5k7u2ibf1m7r3m3v9lg6j2qgb6h6 
oj.apps.googleusercontent.com

Microsoft Client ID: ba98929d-45ec-4cbd-91af-0ad6f4416fb9

Client Secret The secret code received from the OAuth provider.
This code is specific for an application. Some providers do not use a client 
secret, so the field may be left empty in such a case.

Authorization URL The URL of the page that a user enters manually to grant access rights to the 
registered application.
This URL should contain the Client ID parameter to enable the "Authorize 
application" button.
Example:
Google Authorization URL: https://accounts.google.com/o/oauth2 
/auth?scope=https%3A%2F%2Fmail.google.com&redirect_uri=urn 
:ietf:wg:oauth:2.0:oob&response_type=code

Microsoft Authorization URL: https://login.microsoftonline.com/6f8 
c8d80-c6d3-4b33-b30a-f45fda35bca5/oauth2/v2.0/authorize?res 
ponse_type=code&redirect_uri=https%3A%2F%2Flogin.microsoft 
online.com%2Fcommon%2Foauth2%2Fnativeclient&response_mod 
e=query&scope=offline_access%20https%3A%2F%2Foutlook.office 
.com%2FIMAP.AccessAsUser.All&state=12345&client_id=aef27f 
c4-7763-465e-8152-cfd3b6fb604b

Append Client ID Click to add your Client ID to the Authorization URL.

Authentication URL The URL that the application uses to perform authentication for operations 
in the service mode.
In the Authentication URL, the values for parameters "scope" and
"redirect_uri" should correspond to the values in the Authorization URL.
Example:
Google Authentication URL: https://accounts.google.com/o/oauth2 
/token?scope=https%3A%2F%2Fmail.google.com&redirect_uri=urn 
:ietf:wg:oauth:2.0:oob

Microsoft Authentication URL: https://login.microsoftonline.com 
/6f8c8d80-c6d3-4b33-b30a-f45fda35bca5/oauth2/v2.0/token?sco 
pe=offline_access%20https%3A%2F%2Foutlook.office.com%2FSMTP 
.Send%20User.Read&redirect_uri=https%3A%2F%2Flogin.microsoft 
online.com%2Fcommon%2Foauth2%2Fnativeclient
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UI element Value

Authorize Application Click to perform the provider authorization and get the access tokens. The 
access tokens represent the authorization of an application to access specific 
parts of a user's data.
After you click the button, the Authorize Application window appears. Then, 
the system default browser window appears prompting to authorize the 
application and providing the authorization code. The code is shown on the 
interactive page or is given as a value of the URL parameter after the OAuth 
provider redirects you to the new page. Copy the code without parameters (if 
any) and paste it in the Authorize Application window. Then click Submit to 
pass the code to Mail Gateway.
Example:
In this example, the code is in bold.
login.microsoftonline.com/common/oauth2/nativeclient?
code=0.AX0AgI2Mb9PGM0uzCvRf2jW8pZ2SmLrsRb1Mka8K1vRBb7mcAAA

AgABAAIAAAAmoFfGtYxvRrNriQdPKIZ

&state=12345&session_state=286eff1d-cf79-4172-

8a74-2ba4e3e2ab79

Status The text in the Status field is self-adjusting depending on the values in other 
fields. For example, once the authorization code is submitted, the Status field 
text is changed.
• READY: The access tokens are received successfully.

The OAuth credentials can be used to connect to the mail service.
• NOT READY: Read the proceeding message to troubleshoot the issue.

The OAuth credentials set cannot be saved.

Save as Default for all 
protocols

Select to share the same tokens among several Mail Gateway instances.
When selected, the current tokens are accessible for every Mail Gateway 
instance.

 If you select "Save as Default for all protocols," you rewrite the 
default credentials for all protocols. All previously configured protocols 
remain unchanged, but their OAuth settings are no longer default.

Use Default Credentials Click to insert the default settings into the OAuth Credentials window fields.

Save Click to store the access tokens.

Cancel Click to discard changes.

Once you save the OAuth credentials, the window is closed and the connection starts using the 
access tokens. To verify the configuration, click Test Connection on the mail configuration tab.

Configure logging options

The Log tab settings specify the types of messages that appear in the Event Log:
• Errors
• Errors and Warnings (Default)
• Errors, Warnings, and Normal Messages
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To continue, do one of the following:
• Select another tab.
• Click OK to confirm your selections and close the window.

Configuration settings take affect the next time you start the service.

Configure Microsoft Outlook with MAPI protocol for Mail Gateway
If you use the MAPI protocol and use Microsoft Outlook as your MAPI client for Mail Gateway, 
disable the Outlook Email Security Update option in Microsoft Outlook. The security update 
prevents Microsoft Outlook from operating as a MAPI client through a Windows NT Service. The 
Outlook Email Security Update is built into Outlook 2002 and higher and is an optional update to 
older versions of Outlook.

Configure Mail Gateway to support invoice approval and rejection by 
email
Configuration settings take affect the next time you start the service.

Set up the Outbound instance
1. Double-click the MarkView Process Mail Gateway Configuration shortcut on your desktop.
2. In the MV Mail Gateway window, create a new OUTBOUND instance and click Preferences.
3. Click the Monitoring tab and do the following:

a. Enable Process Outbound Messages.

b. Clear Process Inbound Message.

c. Set the Polling Period (seconds) to 30.
4. Click the MarkView tab and complete the Database fields, for example:

• Username: markview
• Password: markview
• Host: r4ebsr12.vis01

Where r4ebsr12.vis01 is a TNS name in the TNSNAMES.ORA file for the database connection.
5. Click Test to verify your connection.
6. On the MarkView tab, complete the MarkView Process fields, for example:

• User ID: SQLFLOW_MAIL
• Application Function: SQL*Flow Mail Gateway
• Completed Action: Sent Outbound Email
• Work Item Class: Outbound Email Message

7. Click the Mail tab and complete the Outbound section, for example:
• Protocol: SMTP
• SSL: (if needed)
• Server: smtp.kofax.com
• Port: 25
• Enable authentication: (if needed)
• Timeout: (if needed)
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• Username: (if needed for authentication)
• Password: (if needed for authentication)

8. Click Test Connection to verify your settings.
9. Click OK.

Set up the Inbound instance
1. Double-click the MarkView Process Mail Gateway Configuration shortcut on your desktop.
2. In the MV Mail Gateway window, create an INBOUND instance and click Preferences.
3. Click the Monitoring tab and do the following:

a. Clear Process Outbound Messages.

b. Enable Process Inbound Message.

c. Set the Polling Period (seconds) to 30.

d. Click Test to verify your connection to the host server.
4. Click the MarkView tab and complete the Database fields as follows:

• Username: markview
• Password: markview
• Host: r4ebsr12.vis01

5. Click Test to verify your connection.
6. On the MarkView tab, complete the MarkView Process fields, for example:

• User ID: SQLFLOW_MAIL
• Application Function: SQL*Flow Mail Gateway
• Completed Action: Sent Inbound Email
• Work Item Class: Inbound Email Message

7. Click the Mail tab and complete the Inbound section, for example:
• Protocol: IMAP
• SSL: (if needed)
• Server: imap.gmail.com
• Port: 25
• Enable authentication: (if needed)
• Preferred format: Text
• Username: chorton@gmail.com
• Password: ********
• Mailbox: Inbox

8. Click Test Connection to verify your settings.
9. Click OK.

Enable the feature in MarkView
Once you set up Mail Gateway to support invoice approval and rejection by email, complete the 
following task in MarkView Administration.

1. Log in to MarkView and navigate to Administration > MarkView Admin.
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2. Select the Preferences tab.
3. Locate and change the settings for the following preferences:

• MVAP_CONTROL_EMAIL_ADDRESS: Enter an SMTP email address. This is the email address 
from which Mail Gateway sends approval and rejection emails.

• MVAP_ENABLE_APPROVAL_REJECTION_EMAIL: Set to TRUE.
• MVAP_ENABLE_SUCCESS_MESSAGE: Set to TRUE.

Configure Capture and Output services
1. After installation, open the Windows Service Manager.
2. Specify the startup type (automatic or manual) as follows:

a. Right-click the MarkView service name.

b. Select Properties.

c. In the Startup Type list, select Automatic or Manual.
3. If your Capture and Output configuration requires access to network resources requiring 

authentication:

a. Right-click the MarkView service name.

b. Select Properties.

c. Select the Log On tab.

d. Log in as a user with access to the network resources.

Add SSL certificate to Windows (for SSL only)
Skip this section if you do not use SSL to provide secure web communications for the application 
server.

If you have a self-signed certificate for the application server, add the certificate to Trusted Root 
Certification Authorities of the Windows Computer account or user account.

If you have any other certificate received from the certificate authority, add all root and 
intermediate certificates from the certification chain to Trusted Root Certification Authorities of 
the Windows Computer account or user account.

1. Start the mmc console.
2. On the File menu, click Add/Remove Snap-in.
3. In the Available snap-ins list, select Certificates and click Add.
4. Select the account and expand Certificates.
5. Expand Trusted Root Certification Authorities and click Certificates.
6. Right-click the list on the right and, on the context menu, select All Tasks.
7. Click Import to import the certificates and follow the steps in the Certificate Import Wizard.
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Troubleshoot Capture and Output configuration utilities
Windows Security settings may cause issues when running the Capture and Output configuration 
utilities. If you see errors when you run a configuration utility, right-click the desktop shortcut for 
the utility, select the Compatibility tab, and select Run as Administrator to set the access-level 
permanently.
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Chapter 11

Configure MarkView for Accounts Payable

To configure MarkView for Accounts Payable:

• Configure the Oracle Payables Open Interface import job to move data from the AP Invoice 
Interface tables to the AP Invoice tables. See Configure the Oracle Payables Open Interface 
Import job.

• Add organizations to MarkView. See Add organizations to MarkView.
• Add users to user groups associated with organizations. Either configure AUSS to assign 

MarkView users to user groups associated with organizations (see Set up MarkView users with 
AUSS on page 119) or add the users manually (see the Kofax MarkView Administrator's Guide, 
Volume 1.) Ensure that every MarkView user has a corresponding Oracle HR  record with a valid 
email address. Users without email addresses cannot participate in MarkView workflows.

• Configure an optional default GL account to create dummy lines on a Non-PO Invoice. See
Configure default GL accounts for organizations.

• Set system preferences for email senders. See Set email addresses for system alerts on page
136.

• Complete additional setup for Oracle systems. See Perform additional setup in Oracle on page
139.

Configure the Oracle Payables Open Interface Import job
Configure the Oracle Payables Open Interface Import job to move data from the AP Invoice 
Interface tables to the AP Invoice tables.

The Payables Open Interface Import job creates the invoices in the Oracle AP Invoice tables after 
Kofax MarkView Export Connector has prepared the invoice and image data. This concurrent 
request can be submitted as a single or recurring request. For MarkView, the key parameters for 
this Payables Open Interface Import concurrent request are:
• Source: MarkView Connector
• Hold Name: 170_SYSTEMS_HOLD
• Hold Reason: 170_SYSTEMS_HOLD

The Hold Name was configured during the installation of MarkView. The default is 
170_SYSTEMS_HOLD. Your hold name may be different. It is also stored as the value of the 
MarkView preference MVAP_170_MARKVIEW_HOLD.
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 When configuring and scheduling the Payables Open Interface Import, configure the import 
to apply the 170_SYSTEMS_HOLD during the process. Doing so guarantees that MarkView 
immediately applies the hold to each imported invoice. The hold remains in place until all 
workflow actions are completed and the invoice is ready for payment. Applying the hold prevents 
an imported invoice from circumventing the workflow if a system component malfunctions.

For information about configuring Oracle Payables Open Interface Import jobs, see the Oracle 
documentation.

Add organizations to MarkView
When you add organizations to MarkView, the records populate the Oracle Org ID list from which 
you select approval organizations when setting up approval hierarchies. For more information 
about approval hierarchy administration, see the Kofax MarkView Administrator's Guide, Volume 1.

Required configuration tasks
To add organizations to MarkView:

1. Add organizations defined in Oracle to MarkView. Optionally, you can change from the default 
configuration values.
(Optional) Although not required to set up organizations in MarkView, adding Sub Types (if 
you use them) when you add organizations simplifies the required task of assigning MarkView 
users (see the MarkView Administrator's Guide).

2. Assign MarkView users to the user group associated with an organization. By convention, the 
name is “MVERP - Org”, where Org is the unique organization Short Name. For example, for an 
organization named VISOP, the user group name is MVERP - VISOP.

 Although you can manually assign MarkView users, running AUSS may overwrite the 
manual assignments. For more information, see Set up MarkView users with AUSS.

Prerequisites
Before adding organizations to MarkView, verify the following:
• MarkView for Accounts Payable is installed.
• If using Expense Management, MarkView for Expense Management is installed.
• Organizations exist in Oracle for the organizations being set up in MarkView.
• In Oracle:

• Responsibilities are set up and configured to access organizations.
• Users are assigned to these responsibilities.

• Oracle Forms are set up (part of MarkView post-installation).

Before adding and configuring organizations in MarkView, set up default GL accounts in Oracle. 
Configure a default GL account for an organization, which is used to create dummy lines on a Non-
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PO Invoice when it is created in Oracle. For more information, see the Kofax MarkView Installation 
or Upgrade Guides.

Add an organization to MarkView
When you add an organization to MarkView, MarkView creates a new MarkView User Group that 
includes authorization to the new organization.

1. Log in to MarkView and navigate to Administration > Module Admin.
2. Select the Organizations tab.

The Org Admin window opens.

3. Click Add.
The Org Admin - Create a New Org Record form appears.

4. In the Org Name list, select the organization to add.

 You cannot add an organization that is not defined in Oracle.
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5. Enter a new Org Short Name or accept the default Org Short Name, which MarkView 
populates with the name specified in Oracle. (If you use lowercase letters, MarkView converts 
them to uppercase.)
MarkView uses the Org Short Name to more efficiently retrieve information. An Organization 
Name can have up to 260 characters with spaces and special characters, whereas the Org 
Short Name is limited to 8 alphanumeric characters with no spaces.

6. (Optional) To use the configuration of an existing organization as the configuration for the new 
organization, select an organization under Copy Configuration From.
For example, if your shared service center has 15 organizations that will follow the same 
workflow processes and have the same Sub Types, you can fully define and configure one 
organization and copy that configuration to the other 14 when you add them to MarkView.

7. Click Insert.

After you add an organization, MarkView creates a MarkView User Group and associates the 
group with the organization. MarkView adds the organization to the Org ID list from which you 
select approval organizations when setting up approval hierarchies. For more information about 
organizations, see the Setting Up Organizations section of the Kofax MarkView Administrator's Guide, 
Volume 1.

Add users to user groups associated with organizations
After adding an organization to MarkView, add users to user groups associated with organizations. 
Either configure AUSS to assign MarkView users to user groups associated with organizations (see
Set up MarkView users with AUSS on page 119) or add the users manually (see the Kofax MarkView 
Administrator's Guide.)

Configure default GL accounts for organizations
If you did not use an existing organization as a template, enter a valid default GL account number:

1. Log in to MarkView and navigate to Administration > Module Admin.
2. Select the Organizations tab.
3. Click Configuration on the new organization line.

The Preferences window for the organization opens.
4. On the menu on the left, click GL Account, Hierarchy, and Instance.
5. Click Update.

The Update GL Account, Hierarchy, and Instance window for the organization opens.
6. Enter the Default GL Account.
7. Click Update.

Set up MarkView users with AUSS
Automated User Setup and Synchronization (AUSS) maps user Source System Groups to 
corresponding MarkView Groups and Roles through MarkView Profiles. This mapping provides 
MarkView users with privileges required for the tasks they perform in MarkView. Thus, AUSS 
leverages user information from Oracle E-Business Suite or Microsoft Active Directory Service 
without requiring an administrator to manually recreate it in MarkView per each Source System 
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user. You can also use MarkView Profiles to add users to default user groups associated with 
organizations.

When integrated with Oracle Source System, ensure that the users to be synchronized have a valid 
email address in their Oracle HR record. Oracle users without email addresses cannot participate in 
MarkView workflows. The user must have an entry in the FND_USER and PER_ALL_PEOPLE_F tables 
in the Oracle APPS database schema. The FND_USER and PER_ALL_PEOPLE_F tables are joined by 
the EMPLOYEE_ID and PERSON_ID fields.

The following table contains terms and definitions used in AUSS.

Term Description

Source System The system from which AUSS loads user information into MarkView. 
Your options are Oracle E-Business Suite (Oracle) and Microsoft Active 
Directory Service (Active Directory).

Source System Group The AUSS term for Oracle Application Responsibilities and Active 
Directory Groups.

MarkView Profile The profile that maps the Source System Groups to MarkView Groups 
and MarkView Roles.

MarkView Group The group that determines user access to MarkView documents and 
related privileges in MarkView.

MarkView Role Workflow functions the user can access.

Oracle Application Responsibility The Oracle Source System Group to which an AUSS administrator maps 
MarkView Profiles.

Active Directory Group The group in the Active Directory server to which an AUSS 
administrator maps. The users in Active Directory are members of 
security groups.

LDAP Search Filters Search filters that select the entries on the LDAP server to be returned 
for a search operation.

LDAP Attributes Mapping Mapping of LDAP user attributes to MarkView user attributes. Set 
Active Directory Attributes to manage Active Directory filter results.

Manually created MarkView user A user created in MarkView by a MarkView administrator.

Source System user A user in the Source System. If the user is synchronized, an account of 
the same user name is created/updated in MarkView.

AUSS managed user Such MarkView user that is subject to synchronization: has or had at 
least one assignment to the Source System Groups added in AUSS 
setup.

Full synchronization AUSS conducts a complete comparison of user accounts in the Source 
System and MarkView.

Initial synchronization AUSS conducts a first-time full synchronization during which user 
information is transferred from the Source System to MarkView.

Incremental synchronization AUSS looks for changes only since the previous synchronization.
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AUSS interface
• Current Status: Displays the current AUSS status on near real-time basis. The visual refresh 

occurs every 10 seconds. See Current Status.

• Source System: Accesses Source System Groups information for both Active Directory and 
Oracle. If you use Active Directory as a source system, Source System also displays the Active 
Directory Connection tab, LDAP Search Filters, and LDAP Attributes Mapping. See Source System.
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• MarkView Profiles: Lists available MarkView Profiles. See for a list of the default profiles. See
MarkView Profiles for information about adding, editing, importing and exporting profiles.

• AUSS Options: Opens the window in which you can set up synchronization schedules, set 
passwords, create backup files, configure notifications, and set up queues. See AUSS Options.

• Synchronization: Enables manual synchronization of user information between AUSS and the 
Source System. See Synchronization.
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• Journal: Displays the synchronization process history and changes. See Journal for information 
about the Journal tab.

Active Directory source system connection information
If you select Active Directory as a source system, you will need to specify the LDAP data.

Use this list as a reference for all fill-in fields in the Source System tab for Active Directory.

Field Description

Active Directory Connection
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Field Description

LDAP connection 
URL

<protocol>://<host>:<port>/<root>

Where:
<protocol> is the LDAP protocol, such as ldap or ldaps
<host> is the LDAP server name or IP address
<port> is the LDAP server port to which AUSS connects. Default: 389
<root> is the root entry of the LDAP server you are connecting to, such as 
dc=AUSS,dc=local

User name LDAP admin user DN (Distinguished Name), such as CN=Administrator, DC=local

Password LDAP admin user password

LDAP Search Filters

User base DN(s) The base Distinguished Name (DN) subtree that is used when searching for user entries 
on the LDAP server.

User search filter Filter string for objectclasses required by AUSS: (objectClass=person)

Group base DN(s) The base Distinguished Name (DN) subtree that is used when searching for group entries 
on the LDAP server.

Group search 
filter

Filter string for objectclasses required by AUSS: (objectClass=group)

LDAP Attributes Mapping
(Objects such as Last Name are described by LDAP attributes. MarkView uses Attributes to filter Active 
Directory users for AUSS.)

User name LDAP user attribute for Common Name (CN) or logon account name (sAMAccountName)

First name LDAP user attribute for first name (givenName)

Last name LDAP user attribute for last name (SN)

Email LDAP user attribute for email address (mail)

Source group LDAP user attribute for user group (memberOf)

Run the MarkView AUSS Setup Wizard
1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.

The MarkView AUSS Setup Wizard opens.
2. Follow the prompts of the MarkView AUSS Setup Wizard.
3. If you have the AUSS configuration backup file, click the corresponding link to upload it.

With this file, you upload the information about your source system settings, initial user 
options, MarkView profiles, synchronization schedule, and notifications. When prompted to 
select the source system, continue with the previously used source system.
For Active Directory Source System, the backup file fills in the source system connection 
information fields automatically.

4. For Active Directory Source System only: After you fill in the source system connection 
information fields (see Active Directory source system connection information), click Test 
connection.
• If you see an error message, verify if the field settings are correct.
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• If the test is successful, click Next and then apply changes.
5. Review the steps to complete the configuration and click Go to AUSS Home.

Configure AUSS
Run the MarkView AUSS Setup Wizard and perform the following tasks to configure AUSS:

1. Configure the source system as described in Source System.
2. Set up the user options. Navigate to AUSS Options > Initial User Options and follow the 

instructions in Initial User Options.
3. Configure MarkView Profiles as described in MarkView Profiles.
4. Set up the synchronization schedule. Navigate to AUSS Options > Sync Schedule and Options

and follow the instructions in Synchronization schedule and options.
5. If you want to run the first synchronization manually, see Synchronize for the first time.

Source System
Select the source system that you use to supply user data and follow the required configuration 
procedure:
• Microsoft Active Directory Service source system
• Oracle E-Business Suite source system

Microsoft Active Directory Service source system
If you use the Active Directory source system, see Active Directory source system connection 
information for the source system connection details.

1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.
2. On the Source System tab, open Active Directory Connection, enter or verify the LDAP 

connection information, and click Test connection.
• If you see an error message, confirm the field settings.
• If the test is successful, click Save changes.

3. Open LDAP Search Filters, configure the LDAP search filters using the context sensitive help, 
and click Check filter.
• If you see an error message, confirm the field settings.
• If the test is successful, the search results are displayed.
• Click Save changes.

4. Open LDAP Attribute Mapping, type a user personal information and a source group, and 
click Check mapping.
• If you see an error message, confirm the field settings.
• If the test is successful, click Save changes.

5. Use Source System Groups to limit the scope of AUSS users by selecting specific groups from 
the user's Source Systems.
AUSS allows mapping of the selected groups in Source System with MarkView Profile.
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Oracle E-Business Suite source system
If you use the Oracle E-Business Suite source system, add Source System Groups.

1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.
2. On the Source System Groups tab, click Add Source Groups.
3. In the Application drop-down list, select an application. Available Source Groups are listed.
4. To find a specific source group on the list, in the Filter field, start typing the name.
5. Select Source System Groups that contain MarkView users and click Add selected.
6. Optionally you can remove a previously added Source System Group. In the list, select the 

Source System Group and click Remove.
7. To apply the changes, click Save changes.

Initial User Options
Use the Initial User Options tab to configure the default setup for all synchronized users.

1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.
2. On the AUSS Options tab, click Initial User Options.
3. Change the default Initial user password, if required.
4. Select Print queue and Export queue assigned for work item processing.
5. Click Save changes.

MarkView Profiles
The MarkView Profiles screen displays MarkView profiles with configured MarkView Groups and 
Roles.

Use the MarkView Profiles tab to review a brief description of the selected MarkView Profile with the 
list and the count of associated MarkView Groups, MarkView Roles, and Source System Groups.

You can add, delete, or edit profiles. Select a profile to add Source System Groups, MarkView 
Groups, and MarkView Roles and to map multiple groups from User Source Systems to MarkView 
Groups and MarkView Roles.

Create or edit a profile
Edit the existing profiles or create new profiles and map MarkView Groups, Roles, and Source 
Groups before you import users.

1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.
2. On the MarkView Profiles tab:

• To add a profile, click New.
• To edit a profile, select the profile and click Edit or double-click the profile.

3. To create a new profile, enter the Profile Name and Profile Description and add at least one 
MarkView group or role.

4. Select MarkView Groups:

a. On the MarkView Groups tab, click Add.
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The Select MarkView Groups window opens.

b. To find a specific group on the list, in the Filter field, start typing the name.

c. Click Add selected.
5. (Optional) Select Auto-populate MarkView Roles based on MarkView Groups.

When you select Auto-populate, MarkView Roles with the same names as the MarkView User 
Groups are automatically made part of this profile. However, each role name must be unique 
within MarkView.

6. If you did not select Auto-populate, select MarkView Roles now:

a. On the MarkView Roles tab, click Add.
The Select MarkView Roles window opens.

b. To find a specific role on the list, in the Filter field, start typing the name.

c. Click Add selected.
7. Click Save changes to save the new profile.
8. Select Source Groups:

a. On the Source System Groups tab, click Add.
The Select Source Groups window opens.

b. To find a specific source group on the list, in the Filter field, start typing the name.

c. Click Add selected.

d. Click Save changes to edit the profile.

e. To verify that the source system group is mapped to the profile, navigate to Source 
System > Source System Groups.

MarkView profile export and import
The AUSS Import/Export feature enables bulk updates to profile mappings. An Administrator can:
• Export selected profiles to a comma separated value file (CSV)
• Edit the CSV file.
• Import the updated CSV file into AUSS.

AUSS then processes the imported CSV file and updates the profiles.

CSV file format

The CSV file format is identical for both export and import purposes. The first line of the CSV file 
must be the field names in the order specified later. All fields in the CSV file are required for both 
importing and exporting. All field names and values, except for MarkView Group names, are case 
insensitive.

The following table lists the CSV file fields and their content.

Order .csv Field Name Field Content

1 AUSS Profile Profile name (1–100 single-byte characters)

2 Description Profile description (0–1000 single-byte characters)
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Order .csv Field Name Field Content

3 Source Group Source group name (1–100 single-byte characters)

4 Source Application Source application name

5 Source System Source system type (Oracle or Active Directory)

6 MarkView Group A MarkView group name (1–200 single-byte characters)

7 MarkView Role A MarkView role name (1–200 single-byte characters)

8 User Controllable User controllable flag for MarkView Role (Y or N)

If a profile has multiple associated source groups or MarkView groups and roles, you can add 
additional rows in the CSV file to represent the one-to-many relationship of the MarkView profile to 
its source groups or MarkView groups and roles.

Tips for CSV files:
• Before you import or export, check your file path to ensure that you have read/write/modify 

access.
• Imported profiles are identified by the name.

• If the profile name does not exist, AUSS adds the new profile name.
• If the profile name exists, AUSS overwrites the profile information with the imported values 

from the CSV file including the mapping for that profile. The values in the CSV file replace the 
values for that profile in the database.

• If a profile name is not in the imported CSV file, AUSS does not make any changes to that 
profile. Importing a CSV file does not delete any profiles.

Export profile CSV files from AUSS

You should be a user in the AUSS Mapping Administrator user group to perform this task.
1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.
2. On the MarkView Profiles tab, select the MarkView Profiles to export and click Export.

 If you do not select specific profiles, AUSS exports all profile data.

3. Follow the prompts to download the CSV file. Validate the path and file name to ensure that 
you have access to the exported file.

Edit a CSV file
1. Make a backup copy of the exported CSV file. If editing errors exist, you can reimport this 

backup file to revert to the pre-edited profile settings.
2. Open the exported CSV file in Microsoft Excel or a text editor.
3. Edit the profile lines.
4. Save the file as a CSV file. If you save the file in another format, you cannot import the data 

back into AUSS.

Import profile CSV files to AUSS
1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration >

MarkView Profiles.
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2. Export your profile data to a backup CSV file. See #unique_252. Validate the path and file name 
to ensure that you can recover your backup data.

3. Click Import and select the CSV file to import.
4. Correct any errors reported. See Troubleshoot AUSS.
5. If no errors exist, the changes made to the CSV file appear in the MarkView Profiles.

Synchronize for the first time
To complete the initial AUSS setup, run the synchronization for the first time. Either follow manual 
steps in this section, or configure AUSS automatic synchronization schedule as described in
Synchronization schedule and options.

1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.
2. Ensure that your Source System Group to MarkView Profile mappings are correct and 

complete.
3. On the Synchronization tab, click Synchronize to synchronize users.

The Start Manual Synchronization window opens.

4. In the Start Manual Synchronization window, select Override manually created MarkView 
users if you want to update manually created MarkView users during AUSS synchronization.
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 This option determines whether to update manually created users or not. If the option is 
selected and there is a Source System user with the same user name as a manually created 
user, the MarkView user receives assignments in accordance with AUSS mappings and 
loses all the previous assignments that do not match AUSS mappings. Such overridden user 
becomes managed by AUSS in subsequent synchronizations. If the option is not enabled, 
AUSS does not update such users. Subsequent incremental synchronizations can also 
override manually created MarkView users with the option enabled, but only for the users 
which AUSS detects as updated since the previous synchronization.
If you will need to override manually created MarkView users at a different time later, you will 
be able to do it by running manual synchronization with both Override manually created 
MarkView users and Force full synchronization options enabled.

5. Select a synchronization method:
• Synchronize all Source System users: For the first-time synchronization, adds all Source 

System users to MarkView even if they do not belong to any Source System Group 
configured in AUSS.

• Synchronize only AUSS managed users: For the first-time synchronization, adds only the 
Source System users that belong to at least one Source System Group configured in AUSS.

6. For the initial synchronization, do not select Force full synchronization.
7. Click Start sync to start synchronization.

About using AUSS
With Kofax MarkView AUSS, you can map your Source System Group users to corresponding 
MarkView Groups and Roles through MarkView Profiles.

In addition to the AUSS settings specified in Configure AUSS, use the following AUSS options:
• View the information about the current AUSS state and analyze synchronization data in near real 

time.
• Create a backup file with the current AUSS configuration data.
• Reset AUSS configuration and revert to initial setup.
• Enable email notifications about successful or unsuccessful synchronization.
• Configure the synchronization schedule and options.
• Review the synchronization history and track changes.

Current Status
The Current Status screen displays the overview information about the current AUSS state. Select 
the Current Status tab to review and analyze the following near real-time data. The data updates 
every 10 seconds.
• Synchronization Status: Displays current synchronization progress including the AUSS state in 

general (success, failure, or unknown after the first upgrade), the date and time of last successful 
and unsuccessful synchronization with the synchronized users count and the duration of the 
process.
If required, download log files to view the synchronization details.
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• Current Synchronization: Displays the information about current synchronization status 
including the percentage value of the process completeness, the start time and duration, 
synchronization options, and the synchronized users count. If sync is started, a user may see the 
process by clicking the link View process log.
During the synchronization process, you may view the process log.

• System Statistics: Displays general information about synchronization statistics including 
MarkView profiles count and source system groups count. Click the corresponding links to review 
the full list of profiles and groups. System Statistics provides the maximum memory data and the 
schedule details. Click Edit schedule to configure the synchronization schedule.
The System Statistics information remains if you clear the configuration.

AUSS Options
Use the following additional options to set up AUSS:
• Set the initial password that users need when logging in to MarkView for the first time on the

Initial User Options tab.
• Define print and export queues to use for AUSS.
• Enable automatic synchronization. See Synchronization schedule and options.
• Back up your current AUSS configuration or reset the configuration information.
• Configure email notifications about successful or failed jobs.

Configuration Management

In Configuration Management, you can create a backup file with your AUSS configuration data. 
Use this file if you Run the MarkView AUSS Setup Wizard.

The backup file includes the information about a source system, MarkView profiles, a 
synchronization schedule and options, notifications, and initial user options.

Use Configuration Management to delete the AUSS configuration. MarkView AUSS will only keep 
the Journal and System Statistics information. Before you click Reset configuration, verify that you 
backed up your current AUSS configuration.

 Once you click Reset configuration, your Source System Groups, Initial User Options, 
MarkView Profiles, Synchronization Schedule and Options, and Notifications will be deleted.
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After you reset the configuration, MarkView AUSS Setup Wizard starts. For details, see Run the 
MarkView AUSS Setup Wizard.

Notifications
Use the AUSS Notifications tab to configure email notifications that indicate if the synchronization 
process is a success or a failure.

To send email notifications, select Enable the Successful Job notification and Enable the Failed 
Job notification. Customize the email address from which notifications are sent, email recipients, 
email subject and content.

The From field is filled in automatically according to the MVFC_OUTBOUND_SMTP_USER preference 
value.

Do not use spaces in the To field for email recipients.

If you enable the Failed Job notification, you can also select the option to attach a log file that does 
not exceed 10 MB to the notification. After you verify the settings, save changes.

After you fill in all required fields, you may type a test email address in the To field and click Verify
to receive the example of notification immediately.

Synchronization
AUSS synchronization adds new users to MarkView from the source system and updates groups and 
roles to which users are assigned.

The initial AUSS synchronization moves the group and user data from the source system to 
MarkView. AUSS assigns users to the appropriate MarkView Groups and Roles, based on MarkView 
Profile mappings. After running the initial synchronization, you can configure an automatic 
synchronization schedule to keep Source System user changes synchronized with MarkView user 
data and assignments. To enable automatic synchronization, see Synchronization schedule and 
options.

AUSS performs synchronization in one direction only: from the source system to MarkView. Do not 
maintain users in MarkView that you manage with AUSS. Manual changes in MarkView might be 
overwritten the next time you synchronize users.

 If a user record is deleted in your source system, AUSS disables the MarkView user record. 
AUSS does not delete MarkView user records.

If the synchronization is running, the Synchronization window displays manual synchronization 
status, including the time when the process was started, the user who started it, the 
synchronization duration, options, and processed users count. The window also displays the last 
lines of a log file as they appear in a real-time mode. The Synchronize one user and Synchronize
buttons are disabled during the synchronization. If the synchronization is not running, you may 
start the synchronization for a selected user or for all users with the required options.

The synchronization process varies depending on your situation:
• For the first synchronization after a new MarkView installation, see Synchronize for the first time

on page 129.
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• For the first synchronization after an upgrade, see Manually synchronize the source system and 
MarkView after initial synchronization on page 134.

• To set up periodic synchronization, see Synchronization schedule and options.

Synchronization schedule and options
Use Sync Schedule and Options to enable automatic synchronization.

1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.
2. On the AUSS Options tab, click Sync Schedule and Options.
3. Select the required synchronization options from the list.

a. Select or clear Override manually created MarkView users.

 Scheduled synchronization searches for changes in the source system since the 
previous synchronization. Only users updated since the previous synchronization or 
users that belong to updated Source System Groups are processed during incremental 
synchronization and thus affected by the Override manually created MarkView 
users option. To process all Source System users and override manually created 
MarkView users, run manual synchronization with both the Override manually created 
MarkView users and Force full synchronization options enabled.

b. Select a synchronization method:
• Synchronize all source system users: Adds/modifies all Source System users that were 

added/updated since the previous synchronization or belong to updated Source System 
Groups.

• Synchronize only AUSS managed users: Adds/modifies Source System users that 
belong to updated Source System Groups. Modifies only those updated users who 
already exist in MarkView. For example, if there is a new Source System user added 
since the previous synchronization and this user does not belong to any Source System 
Group managed by AUSS, then this user is not added in MarkView in this case.

4. In the synchronization schedule, select one of the following options and configure the 
synchronization time if required:
• One-Time: In the drop-down list, select the HH:MM value that increments by 30 minutes.

The synchronization starts in HH:MM.
• Daily: In the drop-down list, select the HH:MM value that increments by 30 minutes.

The synchronization starts every day at HH:MM.
• Periodically: In the Time interval (hours) field, specify the time period over which the 

synchronization repeats.
Select the Starting point field if you want to set the time of the day when the 
synchronization starts. The synchronization starts when the next time interval is reached.

• Disable: Select to disable automatic synchronization schedule.
5. Click Save changes to apply the synchronization settings.
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Manually synchronize the source system and MarkView after initial 
synchronization
To synchronize MarkView users with AUSS:

1. Log in to MarkView and navigate to Administration > AUSS Mapping Administration.
2. Ensure that your Source System Group to MarkView Profile mappings are correct and 

complete.
3. If you want to synchronize all users manually, navigate to Synchronization and click

Synchronize.

a. Determine whether or not to overwrite your manually created MarkView user information 
with user information from Active Directory or Oracle. If you select Override manually 
created MarkView users, this option replaces the MarkView user information with the 
Source System user information provided that the following conditions are met:
• A user exists in both MarkView and Active Directory or Oracle
• A user is enabled and active in the source system

To overwrite your MarkView user information, select Override manually created 
MarkView users. The synchronization replaces the MarkView user information with 
the Source System user information for any user who appears in both places. Unless 
you select the Force full synchronization option, AUSS will process only users added/
updated since the previous synchronization or users that belong to updated Source 
System Groups. The Override manually created MarkView users option affects only the 
users to be processed in the current synchronization session.
To keep your existing MarkView user information, clear Override manually created 
MarkView users. The synchronization keeps the MarkView user information for any user 
who appears in both places.

b. Select a synchronization method:
• Synchronize all Source System users: Updates all users that have a valid record in the 

ERP system. For incremental synchronization, adds/modifies all Source System users 
that were added/updated since the previous synchronization or belong to updated 
Source System Groups. For full synchronization, adds/modifies all Source System users 
even if they do not belong to any Source System Group configured in AUSS.

 Full synchronization is performed initially. All subsequent synchronizations are 
incremental, unless you select the Force full synchronization option.

• Synchronize only AUSS managed users: Updates only such Source System users 
that have at least one assignment to a Source System Group. For incremental 
synchronization, adds/modifies Source System users that belong to updated Source 
System Groups. Modifies only the updated users who already exist in MarkView. For full 
synchronization, adds/modifies only the Source System users that belong to at least one 
Source System Group configured in AUSS.

c. Select Force full synchronization if required.
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
• If the Force full synchronization option is disabled, the synchronization will only 

capture changes since the previous synchronization. If any user information is missing 
and is not re-captured the next time you synchronize, use Force full synchronization
to synchronize all the differences between the source system and MarkView according 
to the current AUSS settings. During the full synchronization AUSS also disables 
all the users who are currently inactive in the source system and removes manual 
assignments to groups and roles for other users.

• If you use Oracle EBS as a source system, with Role Based Access Control (RBAC) 
configured, incremental synchronization will not track Role Hierarchy changes 
correctly because Oracle EBS does not track such changes. For example, if a user 
has Role A and Responsibility B is connected to this role, the user will indirectly have 
Responsibility B and the respective record in the database. However, if Responsibility 
B is deleted from Role A in Role Hierarchy, the respective record for the user 
will not be end-dated but completely removed in Oracle EBS, so incremental 
synchronization will not be able to track such a change. In this case, use the Force 
full synchronization option to synchronize all the differences including indirect 
responsibilities deleted as a result of Role Hierarchy changes.

4. To manually synchronize a specified user, click Synchronize one user. If you choose this 
type of synchronization, the selected user will be removed from any groups and roles 
manually assigned in MarkView. To remove manual assignments for a MarkView-created 
user (a manually created user with a valid record in the ERP system), also select the Override 
manually created MarkView users option (see Step b below).

a. In the Start User Manual Synchronization window, start typing the name of the user you 
want to synchronize and select the user in the drop-down list.
You can only synchronize one user at a time.

b. Determine whether or not to overwrite your manually created MarkView user information 
with user information from Active Directory or Oracle. If you select Override manually 
created MarkView users, this option replaces the MarkView user information with the 
Source System user information provided that the following conditions are met:
• A user exists in both MarkView and Active Directory or Oracle
• A user is enabled and active in the source system

To overwrite your MarkView user information, select Override manually created 
MarkView users. The synchronization replaces the MarkView user information with the 
Source System user information for any user who appears in both places.
To keep your existing MarkView user information, clear Override manually created 
MarkView users. The synchronization keeps the MarkView user information for any user 
who appears in both places.

5. Click Start sync to start synchronization.
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Journal

The Journal tab displays the synchronization history and change tracking.

The Sync History table includes the following data:
• Started by: The user who started the synchronization.
• Result: The actual status of the synchronization. For example, Success.
• Started on: The date and time when the synchronization started.
• Stopped: The date and time when the synchronization ended.
• User count: The number of synchronized users.
• Options: The synchronization method and the Override manually created MarkView users

option selection.

Use additional Sync History options to refresh the page, to export the information to a XLS file, or 
to remove records.

The Change History table displays:

• Action: Added, Changed, or Deleted
• Area: The area where the change took place.
• Element: The item that was changed. This field can include MarkView Groups and MarkView 

Roles, fill-in fields in AUSS Options.
• Old value: If the item was added, the column is blank.
• New value: If the item was deleted, the column is blank.
• User name: The user who performed the action.
• Date: The date and time when the action was performed.

It may help to troubleshoot some issues. The administrator user can export the information to a XLS 
file.

Set email addresses for system alerts
1. Log in to MarkView and navigate to Administration > Module Admin.
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2. Select Organizations > Global Configuration > AP Settings.

3. Click Update, complete the Email Address fields, and click Update again to save the 
information.

Prepare for mobile access
Use the following procedure as a guideline to set up your system to allow user access to MarkView 
Viewer through mobile devices.

1. Install and configure MarkView for Accounts Payable.
2. Contact your mobile device users and instruct them to do the following on their mobile 

browsers:

a. Enable Cookies.

b. Disable Private Browsing.

If your company uses reverse proxy for security purposes, you may need to perform additional 
mapping in the reverse proxy. For the mobile user to view document images, they need access to 
the MarkView document server.

If you mapped the proxy server on the MarkView server, you do not need to perform any additional 
setup.

(Optional) Information for adding a bookmark
Most users will follow a link in an email notification to access invoices in the mobile viewer. 
However, you might have users who want to add a bookmark to their mobile devices for easy 
access to their Web Inbox.

To allow users to create a bookmark, give them:
• The MarkView mobile-access URL, such as http://IP_address:port/mobile
• The host name, such as http://<host>:<port>/mobile

The URL or host name must access the MarkView application server. Access can be through wireless 
connection or through a VPN connected to the your network. The system setup must be able to 
accurately translate the server name to an IP address to allow access.

Giving users the mobile-access URL or host name is not required for mobile access. However, users 
need the mobile-access URL or host name to create bookmarks on their mobile devices.

Configure what appears on the mobile device
MarkView lets you control what appears when a mobile user accesses their Web Inbox or views an 
invoice in the viewer. Settings that you establish for viewing on a mobile device affect what appears 
on all mobile devices that access the system. However, the settings for mobile do not affect the 
settings that you establish for desktop access to the Web Inbox and viewer.
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Use the following procedure as a guideline for configuring mobile devices. Details about using 
Module Admin appear throughout this guide, depending on what you are doing.

1. Log in to MarkView and navigate to Administration > Module Admin.
2. Continue as follows:

• To configure what a mobile user sees in their Web Inbox, see Configure what appears in Web 
Inbox on page 138.

• To configure what a mobile user sees when they view an invoices in the mobile viewer, see
Configure what appears in MarkView Viewer.

Configure what appears in Web Inbox
By default, MarkView ships with a number of fields visible in Web Inbox, such as Invoice Number.

1. Log in to MarkView and navigate to Administration > Module Admin.
2. Select the Display Type tab.
3. Under Name, locate the option to make visible in the mobile Web Inbox, scroll to the Query 

Page column, and click Show Query.
4. Locate the line with the field name to appear, scroll to the far right, and click Update.
5. Under Include in Mobile, select Y to display the field, or select N to hide the field.
6. Under Mobile Display Order, enter a number to specify where in the order of fields the field 

will appear.
7. Click Update.

When a user accesses the Web Inbox, the fields that you selected appear.

Configure what appears in MarkView Viewer
By default, MarkView ships with a number of fields associated with detail types visible when a user 
views an invoice in MarkView Viewer, such as the Supplier Name in the Invoice Details section.

1. Log in to MarkView and navigate to Administration > Module Admin.
2. Select the Detail Type tab.
3. Under Detail Name, locate the option to make visible in the mobile Web Inbox, scroll to the

Layout Page column, and click Show Layout.
4. Locate the line with the field name to appear, scroll to the far right, and click Update.
5. Under Layout Query, click Show Query.
6. Locate the field name to appear, scroll to the far right, and click Update.
7. Under Include in Mobile, select Y to display the field or N to keep from displaying the field.
8. Under Mobile Display Order, enter a number to specify where in the order of fields the field 

will appear.
9. Click Update.

When a user views an invoice in MarkView Viewer, the field containing the information that you 
configured appears as part of the invoice details.
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Perform additional setup in Oracle

Configure the Oracle concurrent managers
Configure the Oracle concurrent managers to run a MarkView procedure as part of a RequestSet 
with Oracle Invoice Validation. The MarkView procedure alerts a MarkView event that causes work 
items to transition to the appropriate next queue in the workflow based on the status of each 
invoice.

The MarkView procedure must run right after the Oracle Payables Approval request runs.

Specify Concurrent Program Executable
1. Log in as a user with access to Application Developer responsibility to open Oracle E-Business 

Suite home.
2. In the Concurrent category, click the Executable link.

An Oracle Applications menu appears, containing a Navigator window.
3. Fill out the Concurrent Program Executable form:

• Executable: AlertApprovalCheck
• Short Name: AlertApprovalCheck
• Application: SQL*Flow
• Description: Alert MarkView Accounts Payable Approval Check Event
• Execution Method: PL/SQL Stored Procedure
• Execution File Name: mvoain_workflow_util.AlertEventFromManager
• Subroutine Name: Leave blank
• Execution File Path: Leave blank

4. Click Save.

Configure concurrent programs
1. To ensure that you have Application Developer responsibility:

a. Click the top hat icon.

b. On the Responsibilities menu, select Application Developer .
2. On the Navigator menu, select Concurrent > Program.
3. Complete the Concurrent Programs form as shown next.
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4. Click Parameters to open the Concurrent Program Parameters form.
5. Specify the EventName, add a description, and select the Enable check box. Complete the

Validation and Display panels as shown.
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6. Specify the PropName as shown and complete the Validation section as follows.
• If every organization will use the same validation process, leave the Default Type field blank.
• If you use Oracle Invoice Validity to validate on a per-organization basis, set DefaultType

to Constant, and DefaultValue to OrganizationID.
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7. Specify the PropValue as shown and complete the Validation section as follows.
• If every organization will use the same validation process, leave the Default Type field blank.
• If you use Oracle Invoice Validity to validate on a per-organization basis, set DefaultType

to Constant and the DefaultValue to the organization ID.
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8. Save and close the Concurrent Program Parameters form.

 Set up one executable for each organization for which the Oracle Invoice Validation 
process is configured.

Associate a program with a group
1. Click the top hat icon to switch to System Administrator responsibility.
2. On the Responsibilities menu, select System Administrator.
3. On the Navigator menu, select Security > Responsibility > Request.
4. In the Request Groups form:

• Click the Flashlight to search for All Reports.
• Select the record with All Reports and with the Application set to Payables (the text may 

differ slightly, depending your version of Oracle Applications.)
If the Find window does not load, close and re-open the Request Groups window.

 Although the system automatically populates the remainder of the form, add another 
request.

Scroll to the bottom of the existing requests and add a new entry with the following settings:
• Type: Program.
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• Name: MarkView Alert Approval Check.

The system sets Application to SQL*Flow (MarkView Process).
5. Save and close the Request Groups form.

Specify a concurrent request set
After completing the MarkView installation, configure Oracle Applications to run Alert Approval 
Check immediately after running the Oracle Payables Approval request:

1. Click the top hat icon to switch to Payables Manager responsibility.
The Responsibilities form appears.

2. In the Responsibilities form, select Payables Manager.
3. On the Navigator menu, select Other > Requests > Set.
4. Complete the Request Set form as shown next, except for the Active Dates field. The Active 

Dates field must be your current date.
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If a pre-populated field does not match the information shown here, change the information.
5. Click Define Stages and complete the Stages form as shown next.

6. Click Requests and complete the Stage Requests form as shown next.
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7. Save and close the Stage Requests and Stages forms.
8. In the Request Set form, click Define Stages to reopen the Stages form.
9. Add a second stage, completing the form as shown next.

146



Kofax MarkView Installation Guide for Oracle E-Business Suite

10. Click Requests and complete the Stage Requests form as shown next.
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11. Save and close the Stage Requests form.
12. Save and close the Stages form.
13. To link the stages you created:

• In the Request Set form, click Link Stages.
• Complete the Link Stages form as shown next.
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• After completing the Link Stages form, click Done.

(Optional) Add concurrent programs or sets to Request Groups
Perform this step if one of the following is true:
• You completed the tasks in Specify a concurrent request set as someone without Payables 

Manager responsibility.
• You need to add this requisition set to other responsibilities within Oracle Applications.

The following example illustrates how to add a concurrent program to the All Reports request 
group. Identify the request group for the concurrent programs or sets that you created in this 
chapter and use the following format to complete the setup.

1. Click the top hat icon to open the Responsibilities form.
2. In the Responsibilities form, select System Administrator.
3. In the Navigator form, select Security > Responsibility > Request.
4. In the Group field, enter the group to add.
5. Set up the new concurrent set as shown next.
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Add workflow menus to user responsibilities
When you assign a user to your accounts payable organization, add the workflow menus to that 
user’s responsibilities.

1. Log in to Oracle Applications Navigator as the system administrator.
2. Select Application > Menu. The Menus window opens.
3. In the Menu field, enter the name of the menu to update.
4. In the additional fields, add the name of the menu to add to the user’s responsibilities.

 You do not need to sequentially number the submenus. Leave gaps in the numbering 
to allow you to add menus later. For example, if you number menus by fives, you could add 
another menu between ten and fifteen if needed.

5. Click Save.

Add the Workflow Maintenance menu to responsibility menus
The creation process adds the MarkView Workflow Maintenance menu to the AP_NAVIGATE_GUI12
menu. To include the Workflow Maintenance menu on other responsibility menus, manually add it 
to those menus.
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The following procedure using the "AP_NAVIGATE_GUI12" (Payables Manager responsibility) menu 
as an example. When you use the procedure, substitute the responsibility menus that need to 
access workflow forms.

To add the MarkView Workflow Maintenance menu to other responsibility menus:
1. Select Apps Logon Links and navigate to the E-Business home page.
2. Log in as the system administrator.
3. Click System Administrator.
4. In the Oracle Navigator:

a. Select Security:Responsibility > Define.

b. Query the responsibility name.
The form displays the main menu name associated with the responsibility in the Menu
field.

c. Search for the Payables Manager responsibility and click OK. The main menu is 
AP_NAVIGATE_GUI12.

5. In the Oracle Navigator:

a. Select Application > Menu.

b. Query the menu name you retrieved.

c. Search for AP_NAVIGATE_GUI12.

d. In the Menus form that appears, add the Workflow Maintenance menu for the Payables 
Manager responsibility, as shown next.

Use the value in the Seq column to create space between menu items and allow for future 
modifications.

6. Add the Workflow Maintenance menu to each responsibility that needs access to the 
workflow forms.

7. Close the Oracle Applications window.
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Expense Management Configuration

MarkView Expense Management is an optional MarkView product. If a user enters an expense 
report that requires receipts, MarkView temporarily stores the current Oracle expense report status 
in a configurable field and assigns a MarkView status of "Awaiting Receipts". After the user submits 
and attaches the required receipts to the expense report, MarkView changes the report status to 
the original status and releases the expense report to continue through the Oracle workflow.

MarkView Expense Management uses a system-level preference, 
EXPENSE_REPORT_STATUS_BACKUP_ATTRIBUTE, to store the value of the configurable field in 
the Oracle iExpense table ap_expense_report_headers_all. Valid values are ATTRIBUTE1 through 
ATTRIBUTE15. The default value is ATTRIBUTE15. Change the default value of this preference if you 
already use ATTRIBUTE15 for other purposes.

Configure Oracle Expenses workflow
To configure MarkView for Expense Management, you must have Oracle Workflow Builder installed 
and your system must include data.

The windows in this chapter may differ from the windows on your Oracle user interface. The 
appearance depends on the version of Oracle Internet Expenses to which you are integrating. 
Regardless of the appearance, the integration steps are identical.

Set the administrator access level
1. Open Oracle Workflow Builder.
2. In Oracle Workflow Builder, select Help > About Oracle Workflow Builder.

The About Oracle Workflow Builder window appears.
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3. Set the values in the About Oracle Workflow Builder window:
• Set Access Level to 0.
• Select Allow modification of customized objects.

4. Click OK.

Open the Expenses workflow
1. Start Oracle Workflow Builder.
2. Select File > Open.

The Open window appears.

3. Enter the following information in the Open window:
• Select Database.
• User: Enter the database user name.
• Password: Enter the password associated with the database user name.
• Connect: Enter the connect string information.
• Effective: Leave blank.

4. Click OK.
The Show Item Types window opens.
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5. Move Expenses from the Hidden column to the Visible column and click OK.
The expenses item type appears in a tree structure.

6. Expand the tree to display all the options under the Expenses menu tree. The Expenses 
workflow is now visible.

7. Ensure that the Developer mode is off in Oracle Workflow Builder. Clear the hammer icon in 
the button bar.

Add functions to the workflow process
1. Open Oracle Workflow Builder.
2. Log in with the Oracle Applications database user name and password.
3. In the Expenses item type, expand the Processes section.
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4. Double-click AP Standard Expense Report Process.
The main workflow opens in an edit window and the starting process diagram appears.

5. In the Navigator window, drag the MarkView Process Initialize function onto the Manager 
Approval transition.
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6. In the Navigator window, select and drag the MarkView Process Initialize function onto the AP 
Approval transition.
The process diagram contains two instances of MarkView Process Initialize.

 The instances of MarkView Process Initialize may be labeled SQLFLOW_INIT.
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7. Delete the Manager Approval transition between Determine Which Process To Start From
and Manager (Spending) Approval Process. Right-click the arrow and select Delete Selection.

8. Delete the Pass transition line between Server Side Validation Process and Manager 
(Spending) Approval Process. Right-click the arrow and select Delete Selection.

157



Kofax MarkView Installation Guide for Oracle E-Business Suite

9. Create a transition between the Determine Which Process To Start From and MarkView 
Process Initialize:
• Right-click and hold Determine Which Process To Start From.
• Drag the cursor over MarkView Process Initialize.
• Release the mouse button. A menu appears.
• Select Manager Approval.

10. Create a transition between Server Side Validation Process and MarkView Process Initialize:
• Right-click and hold Server Side Validation Process.
• Drag the cursor over MarkView Process Initialize.
• Release the mouse button. A menu appears.
• Select Pass.
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11. Create a transition between MarkView Process Initialize and Manager Approval Process:
• Right-click and hold MarkView Process Initialize.
• Drag the cursor over Manager Approval Process.
• Release the mouse button.
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12. Delete the AP Approval transition line between Determine Which Process To Start From and
AP Approval Process:
• Position the cursor on the arrow that connects them.
• Right-click and select Delete Selection.
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13. Create a transition between Determine Which Process to Start From and the second
MarkView Process Initialize function:

a. Right-click and hold Determine Which Process to Start From.

b. Drag the cursor over MarkView Process Initialize.

c. Release the mouse button. A menu appears.

d. Select AP Approval.
14. Create a transition between MarkView Process Initialize and AP Approval Process:

a. Right-click and hold MarkView Process Initialize.

b. Drag the cursor over AP Approval.

c. Release the mouse button.
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15. Click Save. Saving your changes can generate multiple validation failed for activity errors such 
as:
‘SAVE validation failed for activity ‘HRSSA/HR_SAVE_FOR_LATER’.

Ignore errors that do not relate to your changes.

Configure the missing-receipt timeout
When the MarkView Initialize function starts, the system creates the MarkView work item and waits 
for receipts.

If employees take too long to submit receipts, you can automatically move their expense reports 
into the Oracle Applications rejection process by configuring the system to reject expense reports 
after a specified number of days.

To configure the missing-receipt timeout:
1. Open Oracle Workflow Builder and log in as the application system user.
2. Open Expenses (APEXP) Item Type.
3. Expand the Processes list, and double-click the AP Standard Expense Report process. The 

process diagram opens.
4. Right-click the MarkView Initialize function and select Properties.

The system displays the Navigator Control Properties window.
5. Select the Node tab.
6. In the Timeout section of the tab, change Type to Relative Time.
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7. In the Value fields, enter the total time after which an expense report should time out. Enter 
whole numbers in the Value fields.

8. Right-click the MarkView Initialize function and draw a line to the REJECTION_PROCESS 
function. A menu appears.

9. Select <Timeout> and save your changes.
10. Repeat this procedure for all other functions that have names similar to MarkView Initialize, 

such as MarkView Initialize-1.

For this timeout subprocess to work, schedule the Workflow Background Process job to execute on 
a regular basis. A system integrator can configure the Workflow Background process.

Configure the workflow background process
Schedule the Workflow Background Process concurrent request to run periodically in Oracle 
Concurrent Manager. This concurrent request handles items in the Oracle workflow that are 
timed out, stuck, or notified. The following steps describe the settings required for use with 
your MarkView system. For information about setting up this process, see Oracle MetaLink note 
182936.1, the Oracle Workflow Developer’s Guide, and the Oracle Applications User’s Guide.

1. Log in to Oracle Concurrent Manager as a system administrator.
2. Follow the instructions in MetaLink note 182936.1 and the Oracle Applications User’s Guide for 

submitting the Workflow Background Process as a concurrent program.
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3. When the Parameters window appears, enter the following information.
• Item Type: Expenses
• Minimum Threshold: Leave blank
• Maximum Threshold: Leave blank
• Process Deferred: Yes
• Process Timeout: Yes
• Process Stuck: Yes

4. Click OK.
5. Click Schedule.

The Schedule window appears.
6. Schedule the job to run at 2-minute intervals.
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Ensure that the Expense Report Export request is completed. After that, in the Process Monitor, 
you can view the expense reports exported as invoices.
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Configure Self-Service Invoice

To configure SSI with MarkView:
• Schedule periodic Payables import scheduling with hold. See Configure the SSI Oracle Payables 

Open Interface job on page 166.
• If you plan to use AUSS to configure your SSI users, use the Self-Service Invoice profile in AUSS.

You can map the Source System Group (the Oracle EBS responsibility) for those users to the Self-
Service Invoice profile. See Configure AUSS on page 125 for information about configuring this 
profile.

• If you do not plan to use AUSS, see the Kofax MarkView Administrator's Guide, Volume 1  to add 
users to the SSI Users group in MarkView.

• If you plan to enable SSI users to submit follow-up documents in email messages, install Kofax 
Import Connector (KIC) with the MarkView system and install an email client on the SSI user's 
client machine.
The SSI_EMAIL_ADDRESS preference points to an address Kofax Import Connector monitors. See 
the Kofax MarkView Administrator's Guide, Volume 1  for information about setting preferences.

• After initial setup, see the Kofax MarkView Administrator's Guide, Volume 1  for information about:
• Setting SSI Preferences: At a minimum, set SSI_EMAIL_ADDRESS and review the default settings 

for
• SSI_FOLLOWUP_REMINDER_01
• SSI_FOLLOWUP_REMINDER_02
• SSI_FOLLOWUP_REMINDER_03

• Setting Invoice Header and Invoice Line field display for SSI invoice requesters.
• Configuring scan and email settings.

Configure the SSI Oracle Payables Open Interface job
Configure the Oracle Payables Open Interface import job to move data from the AP Invoice 
Interface tables to the AP Invoice tables. The Payables Open Interface Import job creates the 
invoices in the Oracle AP Invoice tables after SSI has prepared the invoice and image data. This 
concurrent request can be submitted as a single or recurring request. The key parameters for this 
Payables Open Interface Import concurrent request are:
• Source: MarkView Self-Service Inv
• Hold Name: 170_SYSTEMS_HOLD
• Hold Reason: 170_SYSTEMS_HOLD
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The default Hold Name is 170_SYSTEMS_HOLD. If you changed this value, your hold name may 
be different. See Configure the Oracle Payables Open Interface Import job on page 116 for more 
information.

 When configuring and scheduling the Payables Open Interface Import, configure the import 
to apply the 170_SYSTEMS_HOLD during the process. Doing so guarantees that MarkView 
immediately applies the hold to each imported invoice. The hold remains in place until all 
workflow actions are completed and the invoice is ready for payment. Applying the hold prevents 
an imported invoice from circumventing the workflow if a system component malfunctions.

For information about configuring Oracle Payables Open Interface import jobs, see the Oracle 
documentation.
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Integration with other Kofax products

After you install MarkView, follow the steps in this chapter to integrate with
• Kofax Capture (KC)
• Kofax Import Connector (KIC)
• Kofax Transformation Modules

Integration with Kofax Capture and Kofax Transformation 
Modules

Kofax MarkView Export Connector enables you to export documents from Kofax Capture to 
MarkView.

Kofax MarkView Export Connector does not support the following:
• Exporting non-image files, PDF files, or OCR full text files
• Using the original file name, as defined for Export Properties in Kofax Capture

Kofax Transformation Modules requires the Data Export Server to provide data from Oracle to Kofax 
Transformation Modules for validation.

Before you install Kofax MarkView Export Connector, verify that your system meets the minimum 
system requirements. For the version numbers, see the Kofax MarkView Technical Specifications
document on the Kofax MarkView Product Documentation site.

MarkView requires:
• Kofax Capture and 32-bit ODBC drivers

(64-bit ODBC drivers are required for MarkView Capture and Output components version 10.5.0. 
For more information, see the Kofax MarkView Technical Specifications document).

• ODAC with the following required components:
• Oracle Data Provider for .NET
• Oracle Provider for OLE DB

• For transformation, you also need Kofax Transformation Modules

Install Kofax Capture Server on the server, and the Kofax Capture client on all workstations before
installing Kofax MarkView Export Connector.
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 MarkView does not support the Kofax Transformation Modules annotation feature. See the 
Kofax Transformation Modules documentation for information about disabling annotation for 
MarkView.

Install Oracle Database 19c Client (19.3) for Microsoft Windows
For the Oracle Data Access Components supported, see "Required Third-Party Technologies" in the
Kofax MarkView Technical Specifications document. Look at the table and select between the 32-bit or 
64-bit version.

If you plan to integrate with Kofax Capture and Kofax Transformation Modules on Windows Server 
2019, complete the following procedure.

1. Install Oracle Database 19c Client (19.x) (ODAC).

a. Run the installer.

b. Select the Custom installation type.

c. On the Available Product Components page, select the following components.
• Oracle ODBC Driver.
• Oracle Provider for OLE DB.
• Oracle Data Provider for .NET.

d. Install the product.
2. If you installed ODAC Xcopy version, register Oracle.DataAccess.dll in the GAC by running the 

following commands:
OraProvCfg.exe /action:gac /providerpath:<oracle_client>\odp.net\bin
\4\Oracle.DataAccess.dll
OraProvCfg.exe /action:config /force /product:odp /frameworkversion:v4.0.30319
/providerpath:<oracle_client>\odp.net\bin\4\Oracle.DataAccess.dll

3. If you installed ODAC Xcopy version and you encounter problems with database connectivity, 
run the following commands to register Oracle products in the GAC manually.
cd <oracle_client>\odp.net\bin\4

OraProvCfg.exe /action:ungac /providerpath:<oracle_client>\odp.net\bin
\4\Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy
\4\Policy.4.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy
\4\Policy.4.121.Oracle.DataAccess.dll

cd <oracle_client>\odp.net\bin\4

OraProvCfg.exe /action:gac /providerpath:<oracle_client>odp.net\bin
\4\Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy
\4\Policy.4.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy
\4\Policy.4.121.Oracle.DataAccess.dll
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cd <oracle_client>\odp.net\bin\2.x

OraProvCfg.exe /action:ungac /providerpath:<oracle_client>\odp.net\bin\2.x
\Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.102.Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.111.Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:ungac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.121.Oracle.DataAccess.dll

cd <oracle_client>\odp.net\bin\2.x

OraProvCfg.exe /action:gac /providerpath:<oracle_client>\odp.net\bin\2.x
\Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.102.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.111.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.112.Oracle.DataAccess.dll

OraProvCfg.exe /action:gac
/providerpath:<oracle_client>\odp.net\PublisherPolicy\2.x
\Policy.2.121.Oracle.DataAccess.dll

Where <oracle_client> is the Oracle Database 19c Client installation folder.

 Some Windows folders (such as C:\Users\<USER NAME>) may be protected and have 
permission restrictions.
Folder location values that contain spaces must be enclosed in double quotation marks. 
Example: "C:\oracle client\network\admin".

Install Kofax MarkView Export Connector
Perform the following procedure on all machines running Kofax Capture or Kofax Transformation 
Modules, including all scan and validation stations.

1. Log in as an administrator.
2. On the MarkView Application Server host, navigate to the MarkView installation directory, open 

the export-connector folder, and locate the kcec-markview.msi file.
For example: <installation_directory>/export_connector/kcec-markview.msi

3. Copy kcec-markview.msi to a temporary directory on the Windows machine on which Kofax 
Capture is installed.
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4. To start the installation, run kcec-markview.msi as Administrator or use the Administrator 
command line.

5. When the installation wizard opens, follow the prompts.
When the installation is complete, a message indicates that Kofax MarkView Export Connector 
was successfully installed.

6. Click Finish.
7. Verify that the Kofax Capture service is running.
8. Repeat these steps on all scan and validation stations.

Set up the ODBC Data source
Configure the ODBC Data source on both the Kofax Transformation Modules server and Kofax 
Capture Network Server (KCNS). If you are not using Kofax Capture Network Server, also configure 
an ODBC data source on each MarkView scan station.

1. Configure a data source using the Microsoft ODBC Administrator application.
• For 32-bit operating systems, start Microsoft ODBC Administrator on the Microsoft Start 

menu.
• For 64-bit operating systems without Kofax Transformation Modules, run \Windows
\SysWOW64\odbcad32.exe to launch the 32-bit version of Microsoft ODBC Administrator.

• For 64-bit operating systems with Kofax Transformation Modules, start Microsoft ODBC 
Administrator on the Microsoft Start menu.

2. In the ODBC Data Source Administrator window, select the System DSN tab.
3. Click Add.

The Create New Data Source window opens.
4. In the list of drivers, select the driver installed by Oracle ODAC, usually Oracle in 

OraClientxxx_home1, and click Finish.
The configuration window opens.

5. Enter values in the following fields:
• Data Source Name (DSN): Enter the name, such as MarkView. Use this when Prepare the 

Kofax Transformation Modules project template for use.
• Description (optional)
• TNS Service Name: Configure the TNS Service Name and User ID to connect to the 

MarkView schema.
• User ID: Enter a MarkView schema name.

6. Clear Enable Query Timeout.
7. Click Test Connection.

The Oracle ODBC Driver Connect window opens.
8. When prompted, enter the password.

If you see an error message, confirm the field settings.
If the test is successful, you see a Connection Successful message.

9. Click OK to close the success message.
10. Click OK to close the configuration window.

The MarkView Data Source appears in the Data Source Name list. This ODBC connection 
corresponds to a listener running on your database server. Use the DSN to connect.
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11. For 64-bit operating systems with Kofax Transformation Modules, you need to also configure 
32-bit ODBC drivers:

a. Run \Windows\SysWOW64\odbcad32.exe to launch the 32-bit version of Microsoft ODBC 
Administrator.

b. Repeat steps 2 through 10 to install and configure 32-bit ODBC drivers.

About MarkView instances
Prior to setting up Kofax MarkView Export Connector, create at least one generic instance to work 
with Kofax Capture.

If you are using Kofax Transformation Modules, create two MarkView instances to define the 
parameters for communication between Kofax Capture and MarkView for invoice and non-invoice 
documents.

Create instances
Use the MarkView Import API Configuration Utility, which installs with Kofax MarkView Export 
Connector, to create the following, generic instance:

1. Log in as an administrator.
2. Locate the MVImportAPIConfig.exe file and create a shortcut on your desktop for future use. 

The file is located in the \bin directory on the server where Kofax Capture is installed.
3. Run MVImportAPIConfig.exe.

The Import API Configuration window opens.
4. Click New to create a new instance.
5. Enter the name of the new instance, such as MarkView Doc.
6. Select the MarkView tab and enter the appropriate information.

Field Description

Database User The MarkView schema user.

Database 
Password

The MarkView schema user password.

Database Host The TNS alias name that was configured in the TNS names file (such as 
tnsnames.ora) for the database instance of the MarkView schema

MarkView User The MarkView user:
• Must be a member of a group with Scan privileges in MarkView, such as the 

SCAN USERS group
• Must be a user in Oracle with invoice creation permissions.

MarkView 
Password

The MarkView user password.

Workstation 
Serial #

WEB_CLIENT

7. Select the Import tab and provide the information in the following table.
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Field Description

Import Source Leave blank.

Server Parameter Leave blank.

Parse XSL Transform 
File

Click Browse and select KofaxCapture82Generic.xslt. The .xslt files are located 
in the bin directory where Kofax Capture is installed.

Import XSL Transform 
File

Click Browse and select KofaxCapture82Generic.xslt.

8. Create a unique MarkView instance for invoice documents.

a. Run MVImportAPIConfig.exe.

b. When prompted, click New.

c. Specify the name for the new instance, such as Invoice.

d. Select the MarkView tab and provide the following information.

Field Description

Database User The MarkView schema user.

Database 
Password

The MarkView schema user password.

Database Host The TNS alias name that was configured in the TNS names file (such as 
tnsnames.ora) for the database instance of the MarkView schema.

MarkView User The MarkView user:
• Must be a member of a group with Scan privileges in MarkView, such as 

the SCAN USERS group
• Must be a user in Oracle with invoice creation permissions.

The MarkView User must also have a corresponding Oracle Security 
(FND_USER) record. See Designate an Oracle user for MarkView Invoice 
Import for Oracle Open Interface (for Kofax Transformation Modules only).

MarkView 
Password

The MarkView schema user password.

Workstation Serial 
#

WEB_CLIENT

e. Select the Import tab and provide the following information:

Field Description

Import Source Select MVCONNECTOR.

Server Parameter Select 170 MarkView ocrInvoice.

Parse XSL Transform 
File

Select the default (KofaxCapture82parse.xslt). The .xslt files are located in 
the bin directory where Kofax Capture is installed.

Import XSL 
Transform File

Select the default (KofaxCapture82importserver.xslt).

f. Click OK.
9. Repeat this procedure on all workstations running batches for export to MarkView.
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Installing Kofax MarkView Export Connector automatically registers it with Kofax Capture.

About MarkView Kofax Transformation Modules Project templates
MarkView automatically installs the project template "MarkView KTM Invoices 50" in C:\KTM
\Markview. When you customize the project, create a new runtime version of the project directory 
that stores the MarkView Kofax Transformation Modules project fpr file and all the files needed for 
the project.

Follow the instructions in this section to prepare the project template and batch class templates. 
For more information, see the user documentation for Kofax Transformation Modules and Kofax 
Capture.

Prepare the Kofax Transformation Modules project template for use
1. Ensure that you have a read-write access to the Kofax Transformation Modules project:

a. In Windows, navigate to your Kofax Transformation Modules project folder, such as
<MarkView_KTM_project>.

b. Select the Kofax Transformation Modules project and right-click Properties.

c. Select the General tab and clear Read-only.

d. Select Apply changes to this folder subfolders and files and click OK.

e. Click OK.
2. Start Kofax Transformation Modules Project Builder.
3. Open the Kofax Transformation Modules project:

a. Select File > Open Project.

b. Locate the MarkView Kofax Transformation Modules Invoices project folder, such as
<MarkView_KTM_project>.

c. Open the MarkView Kofax Transformation Modules Invoices 50 project file.
4. Click Save Project As and save the edited project to a new name.

MarkView creates a new directory under <MarkView_KTM_project>, such as
<MarkView_KTM_project>\MyProject and stores the Kofax Transformation Modules project 
fpr file and all the files needed for the project.

5. Select Project > Script Variables and set the following script variables:
• Project type : Enter Oracle.
• Oracle Version : Enter the Oracle version.
• Demo: Select True or False (set to False when connecting to a live MarkView environment).
• DatabaseDataSource: Specify the connection string for the Oracle database where the 

MarkView schema is located in the format of tns_names_entry.SID.
• DatabaseUID: Enter the MarkView schema name.
• DatabasePWD: MarkView database password.

6. For R12 environments, point the TaxCodes database to a blank TaxCodes.txt file.
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The data export service properties for TaxCodes do not apply to R12. However, for the Oracle 
R12 environment, you need to point the database to a blank TaxCodes.txt file to prevent Kofax 
Transformation Modules project validation errors.
• Create a blank TaxCodes.txt file in your Kofax Transformation Modules project folder, such as
<MarkView_KTM_project>\KTMSourceFiles\Databases.

• In the Kofax Transformation Modules project, select Project > Project Settings >
Databases.

• Select TaxCodes and click Properties.
• Specify the full path to the blank text file. For example, <MarkView_KTM_project>
\KTMSourceFiles\Databases\TaxCodes.txt.

7. Set the LineItems properties:

a. Select Project > Project Settings.
The Project Settings window opens.

b. Select the Tables tab.

c. In the Table Models area, highlight LineItems and click the Edit Table Model Properties
icon .

The Properties window opens.

d. In the Visible column, enable the check boxes for the following fields for Oracle EBS 12.x:
• R. Code
• Tax
• Tax Status
• J. Code

e. In the Visible column, clear the check boxes for the following fields for Oracle EBS 12.x:
• Receipt Year
• Service Entry Sheet Number
• Service Entry Sheet Line Number
• Tax Code

f. Click OK to close the window.

g. In the Project Tree panel, navigate to Project > Project Class > Invoice > Fields.

h. Double-click the LineItems field definition or right-click LineItems and select Properties.
The Properties window opens.

i. In the Always Valid column, enable the check boxes for the following fields for Oracle EBS 
12.x:
• Receipt Year
• Service Entry Sheet Number
• Service Entry Sheet Line Number
• Tax Code
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j. In the Always Valid column, clear the check boxes for the following fields for Oracle EBS 
12.x:
• R. Code
• Tax
• Tax Status
• J. Code

k. Click OK to close the window.
8. (Optional) If you need to set the default Organization ID value, configure the DefaultOrgId 

variable.
For example, if the Organization ID field is blank, the vendor list is not filtered by Organization 
ID correctly. The DefaultOrgId variable value used by Vendor Locator (VL locator) filters 
vendors.

a. Navigate to Project > Script Variables.

b. In Name, locate DefaultOrgId.

c. For the DefaultOrgId variable, set the appropriate Organization ID value and click OK.
9. (Optional) If you do not want to delete extracted lines for Non-PO and Pre-Approved Invoices, 

in Project > Script Variables, set AfterExtractDeleteLineItems to False and click OK.

Validate the Kofax Transformation Modules project
1. Select File > Validate Project.

Kofax Transformation Modules displays any error messages related to the project.
2. If you see database validation warning messages, reestablish links in the project to correct the 

database text files.

a. Select Project > Project Settings.

b. Select the Databases tab. Find and correct any database validation issues.
3. If you see library errors, reestablish links in the project to correct the dictionary text files.

a. Select Project > Project Settings.

b. Select the Dictionaries tab.

c. Select the dictionary with validation errors and click Properties.

d. In the Referenced import file box, select the text file of the server with the same name as 
the dictionary (such as <MarkView_KTM_project>\KTM Source Files\Dictionaries
\DocumentType_Validation.txt) and click OK.

e. Click Import to import the dictionaries.
4. Repeat the validation until the process no longer generates errors.
5. If you want to change the default online learning folder defined for the Kofax Transformation 

Modules project.

a. Select Project > Project Settings.

b. Select the General tab.

c. Under Online Learning, select Enable online learning.
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d. In the Path to online learning box, browse to the appropriate folder (such as C:\KTM
\OnlineLearning_MarkView) and click OK.

6. Select File > Save Project Settings.
7. Click File > Exit to close Project Builder.

About Kofax Capture batch class templates
The following batch class templates are available when imported:
• MarkView Document: Used to separate documents that do not go through Kofax Transformation 

Modules.
• MarkView Invoice: Used to separate documents that go through Kofax Transformation Modules.

The batch class templates are set up with batch fields based on Kofax Capture Values, such as Batch 
Name, Batch ID, Batch Creation Date, Batch Creation Time, and Scan Operator.

Import the batch class templates
1. Log in to Kofax Capture as an administrator.
2. Select Import.
3. In the Open window, select <MarkView_KTM_project>\Markview.cab and click Open.
4. In the Import/Export window, click OK when the unpacking is completed.
5. In the Import window, click Add All.
6. Select Save duplicates to new name.
7. Click Import.
8. Follow the prompts to save the batch classes to a new name.
9. Click OK when the import is completed.

Prepare the batch class templates
1. Highlight the MarkView Document batch class.
2. Select Properties.
3. On the Separation and Form Identification tab, select Custom. In the list, select MarkView 

Bar Code Separators and click Edit Profile.
The Custom Separation and Form Identification Profiles window opens.

4. Enter the following values:
• Enable Bar Code.
• In the list, select MarkView Bar Code.
• Set Found on stand-alone separator sheet as follows:

• To discard the bar code cover sheet after import, select this option.
• To keep the bar code cover sheet with imported documents, deselect this option.

• In the Search Text field, enter:
^(CP|DT)ID-

• Enable Treat search as regular expression.
5. Click Save and Close.
6. Click Apply.
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7. Select the MarkView Invoice batch class and repeat steps 2 through 6.

Prepare Kofax Import Connector to use MarkView Bar Code separators
1. From Kofax Capture Administration, highlight the MarkView Document batch class.
2. Expand the batch class to import through Kofax Import Connector until you see Sample Page 1 

with a bar code.
3. Right-click Page Level Bar Codes and select Properties.
4. On the Available Fields pane, select BarCode, click Add, and click Apply to add the Bar Code 

index field.
5. Highlight the MarkView Document batch class.
6. Select Properties.
7. On the Separation and Form Identification tab, select Custom. In the list, select MarkView 

Bar Code Separators12 and click Edit Profile.
The Custom Separation and Form Identification Profiles window opens.

8. Enter the following values:
• Enable Bar Code.
• In the list, select MarkView Bar Code12.
• Set Found on stand-alone separator sheet as follows:

• To discard the bar code cover sheet after import, select this option.
• To keep the bar code cover sheet with imported documents, deselect this option.

• In the Search Text field, enter:
^(CP|DT)ID-

• Enable Treat search as regular expression.
9. Click Save and Close.

10. Click Apply.
11. Select the MarkView Invoice batch class and repeat steps 2 through 10.

Synchronize MarkView batch classes with the Kofax Transformation Modules 
project

1. Open the Kofax Capture Administration module.
2. On the Batch tab, right-click the MarkView Invoice batch class and select Synchronize Kofax 

Transformation Project.
3. In the Synchronization Tool window, select the Classes tab.
4. Select File > Load Project.
5. In the Project File window, open the project (the .fpr file).
6. When the system notifies you that you are replacing the project, click Yes to keep the existing 

class and field settings.
7. Click Next Step.

The Synchronization Tool window displays data in two columns: Extraction Field and Index 
Field.
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8. If you have Kofax Capture 10, verify that Unit Price is set correctly in both the Extraction Field
and Index Field columns:

a. Scroll down in the Extraction Field list until you see Unit Price.

b. If necessary, use the drop down list to change the value in the Index Field column to Unit 
Price.

9. Click Next Step.
10. Click Synchronize.
11. When synchronization is complete, verify the batch class image folder location.

a. Right-click the batch class and select Properties.

b. In the Batch Class Properties window in the Image folder field, verify the path.
12. Click OK to save and exit.

Set up scan users
You must configure a Kofax Capture scan user and a MarkView scan user. Otherwise, the scan 
operation fails and generates an error message.
• See the Kofax Capture Administrator's Guide, Administration Module, for information about using 

the Kofax Capture Administration interface to add and configure a Kofax Capture scan user.
• See the Kofax MarkView Administrator's Guide, Volume 1  for information about using the MarkView 

Administration interface to add a MarkView scan user.

Scan user requirements:
• The Kofax Capture scan user and the MarkView scan user must have the same name.
• In MarkView, the scan user must be a member of a MarkView group with scan privileges, such as 

the SCAN USERS group.

 If separate users will perform Kofax Transformation Modules validation, add the validation 
users to the SCAN USERS group as well.

Set up Kofax MarkView Export Connector
After you associate a document class with a batch class in Kofax Capture, specify and set up Kofax 
MarkView Export Connector to use when exporting your documents.

1. Start Kofax Capture Administration.
2. Select the Batch tab.
3. Expand the batch class to view associated document classes.
4. Right-click the MarkView Document class and select Export Connectors.

The Export Connectors window lists all available export connectors. Available export 
connectors are those that are registered with Kofax Capture.

5. Under the Available Export Connectors column on the left side of the window, select Kofax 
MarkView Export Connector.

6. Click Add to add Kofax MarkView Export Connector to the list of assigned export connectors.
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7. In the Assigned Export Connectors section, select Kofax MarkView Export Connector and 
click Setup.

8. In the Kofax Capture Export Connector - MarkView window, specify the settings for 
exporting documents.
• Name: MarkView Document EC
• Export Settings Instance: MarkView Document
• Skip first page of each document: Clear this check box
• Threshold: Select Enable and change the Brightness level and Contrast level values, if 

required.
9. Click Apply and click OK.

10. Close the Export Connectors window.
11. Right-click the MarkView Invoice class and select Export Connectors.

The Export Connectors window lists all available export connectors. Available export 
connectors are those that are registered with Kofax Capture.

12. Under the Available Export Connectors column on the left side of the window, select Kofax 
MarkView Export Connector.

13. Click Add to add Kofax MarkView Export Connector to the list of assigned export connectors.
14. In the Assigned Export Connectors section, select Kofax MarkView Export Connector and 

click Setup.
15. In the Kofax Capture Export Connector - MarkView window, specify the settings for 

exporting invoices, such as:
• Name: MarkView Document EC
• Export Settings Instance: MarkView Invoice EC
• Skip first page of each document: Clear this check box.
• Threshold: Select Enable

16. Click Apply and click OK.
17. Close the Export Connectors window.

Set up Database Validation for batch classes
Perform the following procedure for each MarkView Document and MarkView Invoice class. 
Depending on the number of database tables in your environment, changing between tabs in this 
process can take a long time.

1. In Kofax Capture Administration, expand the batch class, right-click the document class and 
select Database Validation.

2. Click the Browse button and select the ODBC Datasource that you created for this 
environment.

3. Select Properties.
4. Update the user name and password.
5. When prompted that changing the value will break current mappings, click Yes.
6. On the Table Settings tab, select the following values:

• Index field to validate: Kofax.Separation.BarCodeValue
• Validate against table: MV_BAR_CODE_TYPE
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• Match Column: BAR_CODE_TYPE_ID
7. If you use Kofax Capture Network Server, select the KCN Server tab and enable the Use KCN 

Server for validation check box.
8. Click OK.
9. Click Close.

Publish a batch class
After you select the batch class settings, publish the batch class. The publishing process checks the 
integrity of the settings in your batch class and makes the batch class available for use. If problems 
exist with any of the settings, error and warning messages appear along with the recommended 
actions for fixing the problems.

If you edit your batch class, publish your batch class again before you use the batch class. Changes 
are not applied to batches created before the new publication date.

1. Open the Kofax Capture Administration module.
2. Select the Batch class tab.
3. Right-click the batch class and, on the context menu, select Publish.

The Publish window opens.
4. Select your batch class and click Publish. Kofax Capture checks all of your batch class settings 

and displays the results in the Results box.

• If no problems exist, the message "Publishing successful" appears.
• If problems exist, error and warning messages appear along with the recommended actions 

to resolve the problems. Perform the recommended actions, and then try to publish the 
batch class again.

After successfully publishing, you can create batches based on your batch class. As your batches 
flow through your Kofax Capture system, they are routed from module to module. The batch class 
definition specifies the modules that process a batch and the order that processing occurs.

Process batches in Kofax Capture
Use the following information to enhance your understanding of exporting batches. See the Kofax 
Capture documentation or help for more information.
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Set up scanning for MarkView documents
1. Log in to Kofax Capture Batch Manager as Admin.
2. Create a new batch.
3. In the Create Batch window, enter a batch name and description (optional).
4. In the Batch Properties Queues list, select Scan.
5. In Batch Manager, select the batch you just created and click Process Batch. The Kofax 

Capture Scan page opens.
6. In the left-hand panel, select a configured scanner as the source.
7. Scan a document with a bar code cover page.
8. To split a multi-page document, select the number of pages per document and optionally 

select Retain document properties in split documents.
9. Click Split.

10. In Batch Manager, click Process Batch to send the batch to Kofax Transformation Modules 
Server.

11. Click Process Batch to send the batch to Kofax Transformation Modules Validation.
12. Click Process Batch to send the batch to Learning Server.
13. Click Process Batch to send the batch to Export, and make the scanned documents available in 

MarkView.

Export batches
The Kofax Capture Export module processes batches based on the settings of the associated batch 
classes. The Export module exports documents and index data, using the properties defined during 
the export connector setup.

The Kofax Capture Export module usually runs as an unattended module on a Windows 
workstation, periodically polling the Export module for available batches. Configure the Export 
module to run during off-hours to avoid impact on the throughput of Kofax Capture and the 
network system.

Start the Export module
On the Start menu, select Programs > Kofax Capture > Export.

All batches queued for export are exported after initiation of the Export module.

Export a batch
Start the Kofax Capture Export module. The module main window opens. Any batches waiting to be 
exported are processed.

Once your batch is exported, it is removed from Kofax Capture. If any documents or pages are 
rejected, the batch is routed to the Kofax Capture Quality Control module.

Exit the Export module
On the Batch menu, select Exit.
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Set up Kofax Capture and Kofax Transformation Modules for 
MarkView

About Auto-Categorization
Auto-Categorization allows MarkView batch classes to bypass categorization in Kofax Capture to 
allow Kofax Transformation Modules to perform the categorization. Depending on the batch class 
property setting specified for RequireCategorizationInCapture, Kofax Capture handles batch classes 
as follows:
• 1 (ON): Prevents documents in the batch classes from moving out of Kofax Capture unless they 

are completely categorized.
• 0 (OFF): Allows documents in the batch classes to continue from Kofax Capture without being 

categorized.

If a document that has no categorization reaches Kofax Transformation Modules, Kofax 
Transformation Modules tries to categorize the document automatically based on extracted values.

Prerequisites:

• The Kofax Transformation Modules version is in compliance with the Kofax MarkView Technical 
Specifications document on the Kofax MarkView Product Documentation site.

• The Kofax Transformation Modules validation station is connected to the MarkView database.

Set the default document type for invoices without PO numbers
1. Open Kofax Transformation Modules Project Builder.
2. Open your MarkView Kofax Transformation Modules project and select Script Variables.
3. Near the bottom of the script variables table, locate DefaultNonPODocumentType.
4. Set the value to use as the default document type for invoices that enter the system without a 

PO number. Supported values include:
• NON-PO INVOICE
• PRE-APPROVED INVOICE

By default, Kofax Transformation Modules uses NON-PO INVOICE, which you can override.
5. Click OK.
6. Save the project.

Set the RequireCategorizationInCapture property
The RequireCategorizationInCapture property specifies how Kofax Capture processes MarkView 
batch classes.

1. Open Kofax Capture Administration.
2. Right-click the MarkView Invoice or MarkView Document batch class and select Properties.
3. Select the General tab and in the Batch Fields table, locate RequireCategorizationInCapture.
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4. Set the Default setting to one of the following:
• 1 (ON): Requires categorization
• 0 (OFF): Does not require categorization

5. Click OK.
6. Save the batch class and proceed as follows:

• For a MarkView Invoice batch class only, synchronize the batch class to the project and 
publish the batch class.

• For a MarkView Document batch class, publish the batch class.

About the MarkView Workflow Agent
The MarkView Workflow Agent enables Kofax Capture to handle MarkView batches introduced 
through non-scan Kofax Capture products in the same way that Kofax Capture handles batches 
introduced through Kofax Scan.

Kofax Capture processes MarkView batches based on the batch class settings. For example, in a 
batch imported through Kofax Import Connector:
• If the Workflow Agent cannot communicate with MarkView, Kofax Capture routes the batch to the 

Quality Control queue.
• If AlwaysStopForReview specifies that all documents go to review, Kofax Capture routes all 

imported batches to the configured review queue.

Workflow Agent batch class properties
Two MarkView batch class properties define how Kofax Capture processes MarkView batch classes 
imported through an application other than Kofax Scan. These properties do not affect MarkView 
batch classes imported through Kofax Scan.

• AlwaysStopForReview: When enabled, routes every document in the batch to review in Kofax 
Capture, whether or not the documents have a valid bar code.
• Disable (default): 0 (False)
• Enable: 1 (True)

• ReviewQueue: Specifies the review queue to which Kofax Capture routes documents in the batch 
that need review.
• Scan (default): Routes documents to the Scan queue
• QC: Routes documents to the Quality Control queue

To change how Kofax Capture processes a MarkView batch imported through an application other 
than Kofax Scan, edit the batch class properties for the destination associated with the connection. 
Workflow Agent properties appear on the Batch fields tab.

 If you access the Document fields tab and change or add a value for the BarCode or
Kofax.Separation.BarCodeValue fields, the Kofax.Separation.BarCodeValue always takes 
precedence.

See the Kofax Import Connector documentation for information about editing the destination.
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Interaction between Kofax Capture and Workflow Agent batch class 
properties
The combination of batch class settings that you use determines how Kofax Capture processes non-
scanned MarkView Invoice batch classes.
• If you set AlwaysStopForReview to 1 (ON), non-scanned documents always stop for review in the 

defined review queue.
• If you set AlwaysStopForReview to 0 (OFF) and RequireCategorizationInCapture to 1 (ON), non-

scanned documents only stop for review if Kofax Capture cannot decode the bar code value.

 For MarkView batch classes imported through an application other than Kofax Scan, the 
RequireCategorizationInCapture property appears on the Batch Fields tab of the destination that 
handles the batch.

Integration with Kofax Import Connector
Before configuring the integration between MarkView and Kofax Import Connector, verify that you 
have the following installed and configured:
• MarkView
• Kofax Capture
• Message Connector

For information about installing and configuring Message Connector and Kofax Capture Plug-In, 
see the documentation provided with the product from the fulfillment site.

The integration process involves completing the following processes in Kofax Import Connector and 
Kofax Capture Administration:
• Configure Message Connector
• Set up destinations on page 188
• Configure connections on page 192

Configure Message Connector
1. On the Start menu, select All Programs.
2. Select Kofax > KIC-Electronic Documents > Message Connector Configuration.

If a user access control prompt appears, click Yes to allow the configuration to proceed.
By default, the window displays a list of basic features.

3. Click Advanced.
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4. Expand the General panel and configure the following options.

Option Setting

Operator Email Specify the administrator email address to receive a copy of messages that fail 
conversion.

Email From Specify the email address from which the system sends notifications.

Keep Failed Failed inbound messages are those not imported into Kofax Capture and not 
forwarded to an operator. If you select the option to keep failed messages, the 
messages are treated as pending. To keep from running out of disk storage 
space, process or manually delete these messages.
• Disable: For the best result, clear the check box for this option.
• Enable: Stores messages on the message connector server. You must 

manually delete stored messages.

Storage Size Enter the amount of disk space in MB reserved for storing messages.
• Minimum: 10 MB
• Maximum: 64,000 MB

For SMTP protocol, use the default. Allocate enough space for mail storage.
For POP3 with KeepFailed disabled, allocate enough space for active email 
processing.

Storage File Enter the file name and location for file storage. The default file location is: C:
\Program Files\Kofax\KIC-ED\MC\Storage.bin. Monitor the size of this 
file and ensure that it does not exceed 50% of the available disk space.
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Option Setting

Prefetched Messages Enter the number of messages that the connector should prefetch from all 
boxes, folders, and other passive input methods.
• Minimum: 1
• Maximum: 100

Own Computer Name For SMTP and Web Services, enter the name of the computer or domain 
where you will install the solution.

Load Balancer Support For SMTP and Web Services input, select the supported load balancer.

5. To convert Microsoft Word plain text (.txt) or html files, expand the Document Conversion
panel and configure the following options.

Option Setting

MS Office Documents Select the software to use for converting Microsoft Word and plain-text (.txt) 
documents.

MHTML and HTML 
Documents

Select the software to use for converting MHTML and HTML documents.

MS Office User If you use MS Office for the conversions, Kofax recommends that you use a 
dedicated, named user for production mode.
To do so, select This User.

Name The Windows user name for MS Office. Verify that the user has the correct 
privileges to use Kofax Capture as well as MS Office.

Password The password for the selected Windows user. Set the password to never 
expire.

Custom Extension List Enter a list of extensions, separated by spaces, for file types to convert to 
PDF using a customizable script. Create the script in the Scripts sub-folder 
with the name "CustomToPdf.bat".

6. Expand the Email Outbound panel and configure the following settings, which send 
notifications to MarkView.

Option Setting

SMTP Server Mode Select how to locate the outbound SMTP server.

SMTP Smart Host Enter the domain name or IP address of the SMTP host for outgoing 
messages. (Use a fully qualified mail server name.)

TCP Port Specify the port on the SMTP host for outgoing messages (use 25).

User ID Enter the User ID for SMTP authentication.

Password Enter the password associated with User ID for SMTP authentication.

SSL Active Select the setting for Secure Sockets Layer protocol.

7. Click Save and Exit.
8. Restart the service to activate the changes.
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Configure destinations and connections
Configuring the Kofax Capture Plug-In to work with MarkView requires you to set destinations, 
configure connections, and map import types to destinations.

Set up destinations
For details about configuration settings, see the Kofax Import Connector documentation.

1. On the Start menu, select All Programs > Kofax Capture xx.x > Administration (where xx.x is 
the current version of Kofax Capture).
If prompted to log in, do so.

2. Select the Electronic Documents tab and click Configuration.
3. Proceed as follows:

• To create a destination: Go to the right-hand pane of the window, locate Destination Tasks
and click Add Destination.

• To edit a destination: In the Destinations list, select a <destination> to edit; in the right-hand 
pane, locate Destination Tasks and click Edit Destination.

A—Destinations List
B—Destination Tasks
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4. In the Destination configuration window, complete the fields on the Import settings tab 
with the following information.

Panel Settings

Destination information • Name: Enter a name for the destination.
• Description: Enter a description.

Message content 
options

• Import content:
• Attachments: Imports only email attachments
• Body and attachments: Imports the body of the email and the 

attachment
• Body only: Imports only the body of the email and no attachments

• Include original content: Enable to include original message content.
• Include complete message as EML file: Enable to include original content in 

EML format.
• Originals import mode: If you enable "Include original content" or "Include 

complete message as EML file," select whether to import the content to 
Kofax Capture or to save the content to a Kofax Capture batch folder.

Import mode • Convert to: Select the file format to which the Kofax Capture Plug-In should 
convert files.

• Conversion mode: If you select a "Convert to" file format, specify whether 
to convert the both the message body and attachment (All Content) or to 
convert only non-image parts of the message.

• Image format: 300x300 B/W
• Message rendering VRS: None

Batch settings • Batch size: 1 (Default)
• Batch timeout: 300 (Default)
• Batch priority: 5 (Default)

189



Kofax MarkView Installation Guide for Oracle E-Business Suite

5. Select the Import mappings tab, and complete the form using the following information.

Option Setting

Batch class • MarkView Document: Recommended setting
• MarkView Invoice: For importing into Kofax Transformation Modules

 For environments with multiple instances, select the instance 
batch class to which to import.

Document class Select a document class based on your Batch class selection. For example, 
if you select the MarkView Invoice batch class, select the MarkView Invoice 
document class.
• MarkView Document
• MarkView Invoice

To configure your system to read a bar code on the cover page of the 
imported document, select (Loose Pages - No document will be used.).

Create document per 
attachment

• Enable: Recommended setting
• Disable: To combine all incoming email attachments as a single 

MarkView document

Folder class Undefined: Recommended setting

Form type Select the Form type based on your Batch class selection. For example, if 
you select the MarkView Invoice batch class, select the MarkView Invoice 
form type.
• MarkView Document
• MarkView Invoice

To configure your system to read a bar code on the cover page of the 
imported document, select (Undefined Form Type - No Form Type will 
be used.).

6. At the bottom of window, change the settings for sub tab fields as described next. 
For fields not described, keep the default settings. For information about using 
RequireCategorizationInCapture, AlwaysStopForReview, and ReviewQueue, see Set up Kofax 
Capture and Kofax Transformation Modules for MarkView on page 183.

Sub Tab Name Field or Index Name Value

AlwaysStopForReview Disable (default): 0 (FALSE)
Enable: 1 (TRUE)

BatchName The name you specify appears as 
the origin information on MarkView 
documents.
If internal users forward emails 
that have informative subject lines, 
set this value to Message Field > 
KfxMessageSubject.

Batch Fields

Kofax.MarkView. BarCodeSepSearch ^(CP|DT)ID-
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Sub Tab Name Field or Index Name Value

MailTo KfxRecipientTo
If you enter a list of addresses, only 
the first address in the list is used.

MailCc Not used.

MailFrom KfxOriginatorNumber

MailFromName KfxOriginatorName

MailSubject KfxMessageSubject

RequireCategorizationInCapture • 1 (ON)
• 0 (OFF)

ReviewQueue Scan (default)
QC

Folder Fields Keep the default settings

BarCode • Set a constant value using a bar 
code string from the bar code 
cover sheet.

• To route documents to manual 
review, create a cover sheet for an 
Uncategorized Document and use 
that bar code string.

Comment Leave blank. This option creates 
a sticky note on the MarkView 
document with the comment that 
you specify here.

Kofax.Separation.BarCodeValue The value you set in this field takes 
precedence over the value set in the 
BarCode field.
• Set a constant value using a bar 

code string from the bar code 
cover sheet.

• To route documents to manual 
review, create a cover sheet for an 
Uncategorized Document and use 
that bar code string.

Document Fields
If you selected (Loose-
Pages - No document 
will be used.)  as the
Document Class, the
Document Fields are 
empty.

ScanStationID For location filtering in MarkView, 
set to a location name, such as 
TORONTO, HOUSTON.

Advanced Fields Leave fields empty.

7. Click OK.
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Configure connections
1. In the right-hand pane of the Kofax Capture Plug-In window, locate the Connection Tasks and 

proceed as follows:
• Click Add Connection.
• In the top half of the window, select a connection to edit, go to the Connection Tasks pane, 

and click Edit Connection.

A—Connections List
B—Connection Tasks

2. In the Connection configuration window, configure the following options:
• Connection name: Use a generic name
• Message Connector URL: Enter the URL of the computer where Message Connector is 

running.
• For a secure connection, use https://<address:port>.
• For a non-secure connection, use http://<address:port>.

• Default destination: Specify the default destination to associate with import connections 
that you configure.

3. To validate the connection, click Test Connection.

 If validation fails, you might need to perform additional configuration. See the Kofax 
Import Connector documentation or consult with your Kofax Capture administrator.

4. Under Import Connectors, click Add and select Mailbox Import to set up a mailbox import 
connector.
Set up one mailbox per organization-workflow-priority combination.

Option Setting

Display name Enter a descriptive, unique <name> for this mailbox.

Host Enter the POP3 or IMAP <host name> of the inbound mail server.
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Option Setting

Protocol Select the protocol to use for accessing the mailbox.
• IMAP
• POP3

SSL Select the security option to use:
• NEVER
• ALWAYS
• NEGOTIATE

User name (Required) Enter the User name associated with the mailbox.

Password (Required) Enter the Password associated with the user name for the mailbox.

For more information about setting up access to mailboxes and other import connectors, see 
the Kofax Import Connector Administrator's Guide.

5. To test the settings, click Test Mailbox.
You should see a successful connection message.
If the test fails, check with your mail server administrator to verify that you supplied the correct 
information.

6. Click OK to save the import connector settings, and OK again to save the Connection settings.
7. Restart the Kofax Capture Plug-In service to activate your configuration changes.

Map mailboxes to destinations
Map each mailbox to a corresponding destination using the following procedure as a guideline. For 
details, see the Kofax Import Connector documentation.

1. In the Kofax Capture Plug-In window, select a <connection>, go to the Connection Tasks pane, 
and click Add Rule.

2. Complete the form using the following settings:

Option Setting

Service filter Select EMAIL.

Recipient list Enter the <email address> of those to receive documents from this mailbox. 
Separate multiple email addresses with commas.

Address Enter the <email address> from which Message Connector receives the document. 
Kofax Capture imports documents with this address to the configured destination.

Destination Select a <destination> in the list. If you do not see any destinations, see Set up 
destinations on page 188 to set up destinations.

3. Click OK.
4. If prompted to restart the service, click Yes.

Configure the email subject to override bar codes
In addition to configuring email accounts for specific categorizations, Kofax Capture can read 
the text version of a MarkView bar code string. To enable this feature, complete the following 
procedure.
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Verify that you have a dedicated email server that can be polled from the Kofax Capture server for 
the subject line override.

1. Configure the mailbox.
2. Set up a new destination (see Set up destinations on page 188).
3. On the Destination configuration window, select the Import mappings tab.
4. Under Document fields, locate the BarCode row or the Kofax.separation.BarcodeValue row.
5. In the row to set, click the Value column and select Message Fields > KfxMessageSubject.
6. (Optional) If you reuse the field for location filtering, add a location to the ScanStationID Value 

field.

 To prevent the need for each user to generate a bar code for each use, an administrator can 
generate a set of bar codes in production and distribute them along with a chart. For example:
• OU (Organization): ORG1
• Document Type: PO Invoice
• Priority: Normal
• Mail Subject (Bar Code String): DTID-10$CPID-190846\

Use the bar code override

To email copies of invoices into the MarkView workflow when you do not have a dedicated mailbox 
for the document type-organization-priority combination, send the attachment in an email to the 
address that you configure using the instructions in Configure the email subject to override bar 
codes on page 193.

1. Using the chart provided, look up the bar code string based on the Organization (OU), 
Document Type, and Priority.

2. Copy and paste the bar code string into the email subject line. Verify that you do not add 
leading or trailing characters to the string.

3. In the body of the email, add information (such as the document type, organization, priority, or 
notes) to help the administrator with troubleshooting in case the conversion fails.
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Chapter 15

Integration with Kofax Analytics for 
MarkView

This chapter gives you information about settings needed to maintain and optimize Kofax Analytics 
for MarkView performance if you plan to use this Kofax product. Follow the steps in this chapter 
after you installed Kofax Analytics for MarkView according to the Kofax Analytics for MarkView 
Administrator's Guide.

About Kofax Analytics for MarkView
Kofax Analytics for MarkView is an extension of Kofax MarkView that produces a graphical business 
intelligence dashboard based on near real-time data collected during the batch processing 
workflow. Kofax Analytics for MarkView presents finance processes data in graphical and interactive 
views.

Kofax Analytics for MarkView is a browser-based product built on Kofax Insight. Kofax Insight 
is a process intelligence platform that monitors, analyzes and helps optimize your operational 
business activities to ensure compliance, eliminate risk and provide insight and visualization of all 
information.

Kofax Analytics for MarkView brings together data from the Oracle E-Business Suite system, 
MarkView, and Kofax Capture with Kofax Transformation Modules workflows to give you strategic 
information about your business activities. Kofax Analytics for MarkView provides the insight and 
metrics required to analyze the effectiveness of business processes.

With Kofax Analytics for MarkView you can:
• Prioritize daily activities
• Take advantage of available discounts
• Check for duplicate invoices and possible compliance violations
• Review invoice summary data
• Take action to meet key performance indicators
• Review invoice full history and status
• Optimize cash resources
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Configure access to Kofax Analytics for MarkView
Configure your MarkView menu to access Kofax Analytics for MarkView from MarkView.

1. Log in to MarkView and navigate to Administration > Module Admin.
2. Select the Menu Item tab.
3. Scroll to the bottom of the page and click Insert.
4. Complete the form and click Insert again to save the changes.

• Menu Name: Main Menu
• Menu Sequence: Next available value for Main Menu items.
• Item Type: URL
• Default Item Label: The name that appears in the interface, such as Kofax Analytics for 

MarkView.
• Item Value: The URL link to the Kofax Analytics for MarkView home page in the following 

format:
http(s)://<host>:<port>/Insight/View/

Where <host> is the name of the server where you installed Kofax Insight and <port> is the 
port used by Kofax Insight.

• MV Home Aware: Y

When you add a menu item, the item remains inactive until you assign it to a user group. For more 
information about assigning menu items to User Groups, see the Kofax MarkView Administrator's 
Guide, Volume 1.

User authorization in Kofax Analytics for MarkView
The Kofax Analytics for MarkView viewer user is the same as the MarkView user.

Verify that a user profile meets the following requirements:

• The user is enabled in MarkView.
• The user is added to the MV Analytics user group.

 You can create a number of groups for Kofax Analytics for MarkView to add different set of 
organizations.
When you create theKofax Analytics for MarkView user group, specify the group name as 
follows:
"MV Analytics - xxx", where "- xxx" is a unique value.

• The MV Analytics user group is assigned for at least one organization in MarkView.
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After a user is added to MarkView, verify that the viewer user follows the procedures in this section 
to ensure that data appears on the Kofax Analytics for MarkView viewer as expected.

1. To access Kofax Analytics for MarkView, open a web browser and enter the URL such as
http(s)://<host>:<port>/Insight/View, where <host> is the name of the server where 
you installed Kofax Insight and <port> is the port used by Kofax Insight.

 The URL address is defined by the settings used for IIS during Kofax Insight installation.

2. Log in to Kofax Analytics for MarkView using the MarkView user name and password.
3. Verify that you have access to the predefined data for organizations.

 Kofax Analytics for MarkView supports all organizations that a user is authorized in 
MarkView and Oracle EBS.

User authorization for invoice actions in MarkView
Kofax Analytics for MarkView lets authorized users take actions on invoices. You can Increase 
Priority, Reassign, or Escalate an invoice.

The MarkView administrator sets the access to Kofax Analytics for MarkView invoice actions in 
MarkView.

Increase Priority
The Increase Priority action is available with standard MarkView installation. To set the access to the 
Increase Priority action:

1. Log in to MarkView and navigate to Administration > MarkView Admin.

2. Select the Toolsets tab and click Add.

3. Enter the toolset name such as Analytics Toolset and the sequence, and click Save.

4. To create new mapping between the new toolset and the existing MarkView tools, select the
Toolsets Tool tab and click Add.

5. Click Select Tool and in the List of Values, locate the Increase Priority Tool.

6. Add the Increase Priority Tool to the appropriate Analytics Toolset and click Save.

7. Open User Groups and select the appropriate MV Analytics group or create a new one for users 
that must be authorized for Increase Priority action.

8. Open details, select the Document Toolset Auths tab, and click Add to add new document-
toolset authorization mapping.

9. In the Document Type filed, select ALL.

10. In the Toolset field, select the toolset that you created for the Increase priority action such as 
Analytics Toolset and click Save.

After you added the Increase Priority Tool to the appropriate User Group, the members of this 
group are authorized to use the Increase Priority action in Kofax Analytics for MarkView.
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Reassign
To set the access to the Reassign action:

1. Log in to MarkView and navigate to Administration > MarkView Admin.

2. Select the Tools tab and locate Reassign Document Tool in the list.
• If you have the Reassign Document Tool, follow the same process to add the tool to the 

appropriate user group as for the Increase Priority Tool.
After you added the Reassign Document Tool to the appropriate User Group, the members 
of this group are authorized to use the Reassign action in Kofax Analytics for MarkView.

• If you do not have the Reassign Document Tool, select the User Groups tab and create a 
new MarkView group and add users.
The user group name must be MV ANALYTICS REASSIGN which is case-insensitive.

Escalate
To set the Escalate Document action:

1. Log in to MarkView and navigate to Administration > MarkView Admin.

2. Select the Tools tab and locate Escalate Document Tool in the list.
• If you have the Escalate Document Tool, follow the same process to add the tool to the 

appropriate user group as for the Increase Priority Tool.
After you added the Escalate Document Tool to the appropriate User Group, the members 
of this group are authorized to use the Escalate action in Kofax Analytics for MarkView.

• If you do not have the Escalate Document Tool, select the User Groups tab and create a 
new MarkView group and add users.
The user group name must be MV ANALYTICS ESCALATE which is case-insensitive.

 If you do not have Reassign Document or Escalate Document Tool installed in MarkView,
Action History in MarkView Viewer does not display new items after reassign or escalate action in 
Kofax Analytics for MarkView.

Enable Kofax MarkView Export Connector notifications
If you want to use Kofax Analytics for MarkView with Kofax Capture and Kofax Transformation 
Modules, enable the integration after you install Kofax MarkView Export Connector. Perform the 
following steps for all systems where Kofax MarkView Export Connector is installed.

1. In the Kofax MarkView Export Connector installation directory, locate the 
Kofax.MarkViewExport.Notifier.dll.config file and open it for editing.

2. To enable Kofax Analytics for MarkView, locate the "EnableKofaxAnalytics" key and set the 
value to true as follows:
<appSettings> 
            <add key="EnableKofaxAnalytics" value="true"/> 
             …
        </appSettings>
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3. Save the .config file and reopen Kofax Capture.

199



Appendix A

Troubleshoot your installation

This appendix identifies conditions you might encounter and suggests ways to resolve them. For 
more information, see the Release Notes and the Kofax Knowledge Base.

Specify host names
The installer requires that you enter fully-qualified host names. A fully-qualified name consists of 
a host and domain name including the top-level domain. For example, if your top-level domain is 
mydomain.com, to specify the host myhost in the installer, enter:

myhostname.mydomain.com

 Do not use localhost in your hostname fields when you run the installers. The applications will 
not function as expected.

JVM location errors
If you encounter problems related to locating a JVM, take the following steps:

1. Use the java -version command to check your environment path for a valid version.
For the version supported, see the Kofax MarkView Technical Specifications document on the
Kofax MarkView Product Documentation site.

2. If the version returned is not supported, specify the Java version to determine how your path 
resolves.

Invalid JDK errors
Errors related to an invalid JDK vary depending on your platform, but the problem is usually caused 
by the location of the JDK in the path. To resolve the problem, modify your path environment 
variable so that the JDK version appears before all other JDKs, JREs, and JVMs.

200

https://knowledge.kofax.com/
https://docshield.kofax.com/Portal/Products/en_US/MarkView/10.5.0-yw2qf8m7r6/MarkView.htm


Kofax MarkView Installation Guide for Oracle E-Business Suite

Too many open files
The error "java.io.FileNotFoundException: Too many open files" indicates that open files limit on 
your system should be increased.

UNIX: increase ulimit nofile setting (max number of open files).

Oracle Forms runtime errors
FRM-40654: Record Has Been Updated By Another User. Re-Query To See Change
You may see this error for the Oracle Quick Invoices form in Oracle EBS 12.x if you applied certain 
Oracle patches. Follow the steps in Step 11: Edit PRE_UPDATE, LOCK_ROW, and UPDATE_ROW 
procedures for Oracle EBS 12.x on page 93.

FRM-40735: PRE-RECORD trigger raised unhandled exception ORA-06502
FRM-40735: PRE-RECORD trigger raised unhandled exception ORA-06502.
--------------------------------------------------------------
ORA-01403: no data found

This is the result of a form compilation problem.
In MarkView for Accounts Payable you might see this error from Invoices  > Entry > Invoices >
Actions if you have an invoice listed.
In MarkView for Expense Management, you might see the form compilation error after opening the 
Working Folder and clicking the Open button, or from an Expense form, after clicking GetNext.

FRM-40819: System variable is not modifiable
You may see this error from Accounts Payable if you try to search by invoice number. This error may 
result from having compiled the modified Oracle form in Form Builder rather than the compiling the 
modified Oracle form from the command line as recommended. To fix the problem, recompile the 
modified form from the command line as described in the appropriate section:
• For the Invoice Workbench form, see Step 9: Compile the Invoice Workbench form on page 89.

MarkView Viewer slow performance
Documents scanned at above 300 dpi degrade the MarkView Viewer performance. Ensure that 
documents are scanned in at 300 dpi.

Problems with fonts in PDFs
To avoid problems with the appearance of some Annotations, ensure that fonts used by MarkView 
(New Times Roman and Arial) are installed on the client machines and servers. Linux environments 
often have issues because they generally have no fonts installed.
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Troubleshoot AUSS
To recover from a catastrophic error, you can replace your AUSS data with a historic exported CSV 
profile file. See MarkView profile export and import on page 127. After that, select the Force full 
synchronization option when running the synchronization.

 This does not replace regularly backing up your system.

Export or import fails
If the import or export fails:
• Check the CSV file data for invalid values in source system type, application name, source group, 

MarkView group name or MarkView role name.
• Check the profile name. Since AUSS identifies imported profiles by name, if you change the profile 

name when you edit the CSV file, you risk unexpected results when you import the CSV file.
• Check the path and file name to ensure that you have read/write/modify access to the file.

Inconsistency between user rights and the Everyone profile groups and 
roles

If you have inconsistencies between user rights and the Everyone profile groups and roles, do the 
following:

1. After you upgrade MarkView, on the AUSS user interface, delete all groups and roles from the 
Everyone profile, save changes, and recreate roles and groups.

2. Resynchronize users.

Log file
In case of unexpected results, check the usermgmt.log file.

End-dated user authorization in MarkView
When integrated with Oracle Source System and if the WEBCLNT_SEC_AUTH_TYPE preference is 
set to MV, the end-dated user may still have access to MarkView before the synchronization. The 
end-dated user can be authorized in MarkView within 24 hours regardless of the synchronization 
schedule. If the synchronization occurs after 24 hours, the user access is disabled.

You can disable the end-dated user access immediately by setting the Disable Date value in
MarkView Admin > User Profiles.
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User not synchronized after scheduled synchronization
Two common causes:
• The user profile was created manually. Check the settings. Run the synchronisation using 

the Override manually created MarkView users option with the selected Force full 
synchronization option. See Synchronization.

• The user's source group is not in AUSS. For information about adding source system groups, see
Source System.

Indirect responsibilities deleted as a result of Role Hierarchy changes 
(Oracle EBS only)

If you use Oracle EBS as a Source System and Role Based Access Control (RBAC) is configured in 
Oracle EBS, incremental synchronization will not track Role Hierarchy changes correctly because 
Oracle EBS does not track such changes. For example, if a user has Role A and Responsibility B is 
connected to this role, the user will indirectly have Responsibility B and the respective record in 
the database. However, if Responsibility B is deleted from Role A in Role Hierarchy, the respective 
record for the user will not be end-dated but completely removed in Oracle EBS, so incremental 
synchronization will not be able to track such a change. In this case, use Force full synchronization
option, to synchronize all the differences including indirect responsibilities deleted as a result of 
Role Hierarchy changes.

Test MarkView for Accounts Payable
To test the MarkView for Accounts Payable installation, enable only the standard MarkView 
functionality. If you receive errors, they are probably generated by Oracle applications or non-
standard MarkView functionality.

Turn off custom packages
To ensure that Oracle Payables is running properly, disable custom MarkView packages and non-
standard functionality as follows:

1. Open Oracle Applications.
2. On the Help menu, select Diagnostics > Custom Code > Off.

You can now run tests against Oracle Applications. Custom packages remain disabled until you 
enable them.
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Migrate environments

Migrate your MarkView production environment to a non-production environment to test new 
functionality, train new users, or troubleshoot issues which you might encounter in your production 
environment. Use a third-party tool to clone the MarkView production database. Then, use the 
MarkView Migration utility to generate an SQL script to update the environment-specific MarkView 
URLs and design-time data on the non-production environment.

Also, you can use the MarkView Migration utility to move to a new application server without 
upgrading MarkView.

To migrate Kofax Analytics for MarkView from a production to non-production environment, 
additional setup is required. For more information, see the Kofax Analytics for MarkView 
Administrator's Guide.

• Migrating Data to Existing Non-Production Environments: If you already have a functioning 
non-production environment, refresh the database with a more recent copy of the production 
environment. See Migration Utility: Configure an existing non-production environment.

• Migrating Data to New Non-Production Environments: If you need a new non-production 
environment, see Configure a new non-production environment on page 206.

Migration Utility: Configure an existing non-production 
environment

Follow these steps before you use the Migration Utility:
1. Copy your production database schema to your non-production database.
2. Copy your production document server to your non-production document server.
3. Log in to a working MarkView environment (for example, your production environment) as an 

Administrator who is a member of the MODULE ADMINISTRATOR group.
4. Select Administration > Migration Utility.

Use the Migration Utility
1. Complete the values for your site using the following information.

Section Field Name Description

Application Server Post 
Migration

Application Server • WebLogic
• JBoss (use for WildFly and JBoss EAP)
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Section Field Name Description

Fully Qualified Hostname Enter the fully qualified hostname of the 
target application server.

HTTP Port Enter the HTTP port of the target 
application server.

Preferences Select to update the MarkView 
preference URLs to use the target 
application server.

Volume Paths Select to update the MarkView volume 
paths to use the new application server.

Volume Path To Leave Open If you select Volume Paths, select the
Volume Path To Leave Open in the list. 
Values include:
• Close All
• DEVELOPMENT
• PRODUCTION
• TEST

Menu Items Select to update the MarkView menu 
item URLs to use the new application 
server.

Configuration to be 
Updated to Reference 
Application Server Post 
Migration

Export Server Queue 
Assignments

Select to update the MarkView export 
queue assignments to use the new 
application server.

Enable SSL (HTTPs) on 
Application Server

Select to update the MarkView 
URLs to use HTTPs. This option also 
generates the SQL to update the 
WEBCLNT_HTTP_TYPE to the correct 
value (http or https) depending on 
whether SSL is enabled.

SSL Wallet Location If you select Enable SSL (HTTPs) on 
Application Server, enter the SSL Wallet 
Location. (Required for SSL wallets only.)

SSL Wallet Password If you select Enable SSL (HTTPs) on 
Application Server, enter the SSL Wallet 
Password. (Required for SSL wallets 
only.)

Clear Pending Export Requests Select to clear the pending export 
requests.

Route New Mail to Complete 
Mail Queue

Select to route the new mail items to the 
Complete Mail queue.

Data Cleanup Tasks

Override Outbound E-mail 
Destination

Select to update the MarkView 
Outbound Destination email 
address override preference, 
MVT_TEST_EMAIL_ADDRESS, to use a 
new email address.
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Section Field Name Description

E-mail Address If you select Override Outbound E-
mail Destination, enter the email 
address (required). The email address 
must meet the RFC2822 standards for 
valid syntax. See http://tools.ietf.org/
html/rfc2822#section-3.4.1 for more 
information about the RFC2822 
standards.

E-Mail Import 
Configuration

The fields in this section are no longer supported.

2. Select Generate SQL to generate the script and direct where to save the script.
3. Execute the script against the MarkView schema on the target database.

Configure a new non-production environment
If you are configuring a new non-production environment, or the current non-production database 
was overwritten with your production environment, follow these steps to configure your non-
production environment.

1. Follow the instructions in Plan your MarkView installation to prepare your new non-production 
environment.

2. Copy your production database schema to your non-production database.
3. Copy your production document server to your non-production document server.
4. Install the MarkView application server.

Install the same MarkView version as in your production environment.
• For point releases, such as MarkView 10.5.0, use the standard installer. Follow the 

instructions in this guide.
• For service packs, such as MarkView 10.x.x, only apply the service pack. Do not first install 

the MarkView point release. For example, if your production system is at MarkView 10.x, 
only apply service pack 10.x.x to the new non-production environment. This is because your 
database is already at version 10.x.

• If applicable, apply any fix pack to the new non-production application server to bring it to 
the same level as your production environment.

After the MarkView application server is installed, follow the instructions in Move to a new 
application server during MarkView upgrade.

5. Refresh the new non-production environment. See Refresh a new non-production 
environment.

Manually deploy TRS
Use the following procedure to deploy TRS manually. For example:
• You are installing a new Application Server but have an existing Application Server.
• You do not have an Application Server and must deploy TRS manually.
• Your Application Server has crashed.
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WebLogic
Create a new WebLogic domain and machine

1. Start the configuration wizard:
• Windows: %ORACLE_HOME%\oracle_common\common\bin\config.cmd
• UNIX: $ORACLE_HOME/oracle_common/common/bin/config.sh

2. Select Create a new domain and click Next.
3. Select Create Domain using Product Templates and Basic WebLogic Server Domain, and 

click Next.
4. In the Administrator Account window, specify the administrator's credentials and click Next.
5. In the Domain Mode field, select either the Production or Development environment.
6. Specify the appropriate JDK and click Next.
7. In the Advanced Configuration window, select the following check boxes:

• Administration Server
• Node Manager
• Managed Servers, Clusters, and Coherence (or Topology for WebLogic 12.2)

8. In the Administration Server window, specify Server name and Listen Address and Port.
Select Enable SSL, if required.

9. In the Node Manager window, specify Domain Location and Node Manager credentials.
10. In the Managed Servers window, leave the fields blank and click Next.
11. In the Clusters window, leave the fields blank unless you are deploying to a cluster and click

Next.
12. For WebLogic 12.2 only: In the Server Templates window, leave the fields blank and click Next.
13. In the Machines window, click Add, enter the following information for the machine, and click

Next:
• Name: markview_machine
• Node manager listen address: <HOSTNAME>
• Node manager listen port: <NODE_MANAGER_PORT>

14. For WebLogic 12.2 only: In Assign Servers To Machines:

a. In the column on the right, select Machine.

b. In the column on the left, select Server.

c. Use the arrow button to move the Server under the Machine and assign the server to the 
Machine.

d. Click Next.
15. For WebLogic 12.2 only:

a. In the Virtual Targets window, leave the fields blank and click Next.

b. In the Partitions window, leave the fields blank and click Next.
16. In the Configuration Summary window, verify that all information is correct and click Create.

When the creation of the domain is complete, click Next.
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17. In the End Of Configuration window, check Domain Location and Admin Server URL, and 
click Finish.
For WebLogic 12.2, verify that Start Admin Server is not selected.

18. Start Node Manager:
• Windows: <markview_domain>\bin\startNodeManager.cmd
• UNIX: <markview_domain>/bin/startNodeManager.sh

19. Start the domain:
• Windows: <markview_domain>\bin\startWebLogic.cmd
• UNIX: <markview_domain>/bin/startWebLogic.sh

Configure SSL for WebLogic 12c
Skip this section if you do not use Secure Sockets Layer (SSL) to provide secure web communications 
for the WebLogic application server.

To configure SSL for WebLogic, perform the instructions from the following section:

Configure SSL for WebLogic 12c (for SSL only) including the steps from Set up Node Manager (for 
SSL only).

Disable WebLogic basic authentication
1. Log in to the WebLogic host as the WebLogic owner.
2. Open the domain configuration file, which is located in the directory specified when you 

created the domain, for example:
/<WL_home>/../user_projects/domains/<markview domain>/config/config.xml

3. Add the following XML code immediately before the close tag for the security configuration:
<enforce-valid-basic-auth-credentials>false  
</enforce-valid-basic-auth-credentials>

4. Restart the server.

Create a new WebLogic server for the MarkView instance
The MarkView instance requires a unique WebLogic server.

1. Log in to the WebLogic Server Administration Console.
2. Go to Environment > Servers.
3. Click New.
4. Name the new server markview_server.
5. Enter the server Listen Port and click Finish.
6. Expand markview > Environment and click Machines.
7. Click the markview_server you just created.
8. Select the Servers tab.
9. Click Add.

10. Select Select an existing server and associate it with this machine.
11. Select markview_server and click Finish.
12. Expand Services > Data Source, and click JDBC.
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13. Click New.
14. Select Generic Data Source.
15. Enter the following information and click Next:

• Name: MarkViewDS
• JNDI Name: jdbc/MarkViewDS
• Database Type: Oracle
• Database Driver: Oracle's Driver (Thin) for Instance connections (Select the non-XA 

database-driver.)

16. Keep the default Transaction Options and click Next.
17. Supply the information for the MarkView database instance and click Next.
18. Click Test Configuration and click Next.
19. Select markview_server and click Finish.
20. Expand Environment and click Servers.
21. Click the Control tab.
22. Select markview_server and click Start.

Configure SSL for markview_server
Skip this section if you do not use Secure Sockets Layer (SSL) to provide secure web communications 
for the WebLogic application server.

To configure SSL for markview_server, perform the instructions from the following section:

Configure SSL for WebLogic 12c (for SSL only).

Exclude conflicting libraries (WebLogic 12.2 only)
1. Locate the file:

<WL_HOME>/modules/com.oracle.weblogic.security.opensaml2.jar

The WL_HOME environment variable points to the directory where you installed the WebLogic 
server.
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2. Change the file name, or back up and remove the file.
3. If you need to apply a patch on the WebLogic server after the preceding procedure, perform 

the following steps:

a. Restore the file <WL_HOME>/modules/
com.oracle.weblogic.security.opensaml2.jar.

b. Apply the WebLogic patch.

c. Change the file name, or back up and remove the file.

Manually deploy the mvastrs service
1. Copy the mvastrs-ear.ear file from the distribution directory:

<distribution_directory>/modules/installer-dist-(VER)/mvastrs-ear.ear

to the following location:
<installation_directory>/applications/mvastrs-ear.ear

Where <installation_directory> is the MarkView installation directory.
This is the same directory that contains the target_registry_service.properties file. See Create 
the target_registry_service.properties file for WebLogic.

2. Log in to the WebLogic Server Administration Console.
3. Go to Deployments.
4. Click Install.
5. Update the path to point at <home_directory>/markview/applications/mvastrs-

ear.ear where <home_directory> is the user home directory.
6. Click Next.
7. Select Install this deployment as an application and click Next.
8. Select markview_server and click Next.
9. Change the name of the application from mvastrs-ear to mvastrs.

10. Keep the remaining default options on the Optional Settings window and click Finish.
11. When the application finishes uploading, click Save.

Create the target_registry_service.properties file for WebLogic
1. Create a file called target_registry_service.properties in the MarkView installation directory.
2. Skip this step if you are not configuring SSL. In the target_registry_service.properties file, add 

the following line to the top of the file.
RESOURCE.mvtrs_url=http://<WL_Server>:<HTTP PORT>/mvastrs/markview

Where:
• <WL_Server> is the name of your WebLogic server.
• <HTTP PORT> is your HTTP port number.

3. For SSL configuration only: In the target_registry_service.properties file, add the following line 
to the top of the file.
RESOURCE.mvtrs_url=https://<WL_Server>:<HTTPS PORT>/mvastrs/markview

Where:
• <WL_Server> is the name of your WebLogic server.
• <HTTPS PORT> is your HTTPS port number.
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Run the MarkView installer
1. Ensure all active sessions on the WebLogic console are logged out.
2. Run the MarkView Partial Installation to install the remaining application server components.

WildFly or JBoss EAP in standalone mode
Before you proceed, do the following:

1. Open standalone.xml for editing and make sure the file contains the following string:
<subsystem xmlns="urn:jboss:domain:messaging:2.0">

2. If standalone.xml does not contain the <subsystem 
xmlns="urn:jboss:domain:messaging:2.0"> string, back up standalone.xml in
JBOSS_HOME/standalone/configuration.

3. Locate and rename standalone-full.xml to standalone.xml.

Install the Oracle JDBC driver (standalone mode)
1. In $JBOSS_HOME/modules, create the following folder:

oracle/jdbc/main

2. Copy the ojdbc6-11.2.0.3.jar oracle jdbc driver from installer/distr to $JBOSS_HOME/
modules/oracle/jdbc/main.

3. Rename ojdbc6-11.2.0.3.jar to ojdbc6.jar.
4. Copy module.xml from installer/distr to $JBOSS_HOME/modules/oracle/jdbc/main.

Alternatively, in $JBOSS_HOME/modules/oracle/jdbc/main, create the module.xml file with 
the following content:
<?xml version="1.0" encoding="UTF-8" standalone="no"?><module 
 xmlns="urn:jboss:module:1.1" name="oracle.jdbc">
<resources>  
<resource-root path="ojdbc6.jar"/>  
</resources>  
<dependencies>  
<module name="javax.api"/>  
<module name="javax.transaction.api"/>  
<system export="true">  
<paths>  
<path name="com/sun/rowset"/>  
<path name="com/sun/rowset/internal"/>  
<path name="com/sun/rowset/providers"/>  
</paths>  
</system>  
</dependencies>  
</module>

5. Open $JBOSS_HOME/standalone/configuration/standalone.xml and add the following 
strings:
<drivers>
...  
<driver name="OracleJDBCDriver" module="oracle.jdbc">  
<driver-class>oracle.jdbc.OracleDriver</driver-class>  
</driver>  
</drivers>
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Create a new WildFly or JBoss EAP server for the MarkView instance 
(standalone mode)
Configure the port

1. Log in to the WildFly or JBoss EAP Administration Console.
2. Select the Configuration tab.
3. On the General Configuration menu, select Socket Binding.
4. In the standard-sockets group, select View.
5. Select http.
6. In the Selection table, click Edit.
7. In the Port field, enter the appropriate value, such as ${jboss.http.port:26000} .
8. Click Save.

Create the datasource
1. Log in to the WildFly or JBoss EAP Administration Console.
2. On the Subsystems menu, navigate to Connector > Datasources.
3. On the JDBS Database pane, click Add.
4. In the Create Datasource window, enter the following values and click Next:

• Name: MarkViewDS
• JNDI Name: java:/jdbc/MarkViewDS

5. Select OracleJDBCDriver and click Next.
6. Specify your connection settings as follows:

a. In the Connection URL field, enter the connection string value, such as:
jdbc:oracle:thin:@r4ebsr12.kofax.com:1522:vis01

b. In the Username field, enter your MarkView user name.

c. In the Password field, enter your MarkView password.
7. Click Test Connection and check your connection settings.
8. Click Done.
9. On the JDBS Datasources panel, select MarkViewDS line and click Enable.

In the Enable datasource window, click Confirm.

Manually deploy the mvastrs service (standalone mode)
1. Copy mvastrs-ear.ear from the distribution directory:

<distribution_directory>/modules/installer-dist-(VER)/mvastrs-ear.ear

to the following location:
<installation_directory>/applications/mvastrs-ear.ear

Where <installation_directory> is the MarkView installation directory.
This is the same directory that contains the target_registry_service.properties file. See Create 
the target_registry_service.properties file for WildFly or JBoss EAP (standalone mode).

2. Log in to the WildFly or JBoss EAP Administration Console.
3. On the Deployments tab, click Add.
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4. In the Create Deployment window, click Browse and select the mvastrs-ear.ear file.
5. Change the name of the application from mvastrs-ear to mvastrs.
6. Select the Enable check box.
7. Click Save.

Configure SSL for WildFly or JBoss EAP (standalone mode)
Skip this section if you do not use Secure Sockets Layer (SSL) to provide secure web communications 
for the WildFly or JBoss EAP application server.

To configure SSL in standalone mode, follow the steps in Standalone mode.

Create the target_registry_service.properties file for WildFly or JBoss EAP 
(standalone mode)

1. Create a file called target_registry_service.properties in the MarkView installation directory.
2. Skip this step if you are not configuring SSL. In the target_registry_service.properties file, add 

the following line to the top of the file.
RESOURCE.mvtrs_url=http://<JBoss_Server>:<HTTP PORT>/mvastrs/markview

Where:
• <JBoss_Server> is the name of your WildFly or JBoss EAP server.
• <HTTP PORT> is your HTTP port number.

3. For SSL configuration only: In the target_registry_service.properties file, add the following line 
to the top of the file.
RESOURCE.mvtrs_url=https://<JBoss_Server>:<HTTPS PORT>/mvastrs/markview

Where:
• <JBoss_Server> is the name of your WildFly or JBoss EAP server.
• <HTTPS PORT> is your HTTPS port number.

Run the MarkView installer (standalone mode)
1. Ensure all active sessions on the WildFly or JBoss EAP console are logged out.
2. Run the MarkView Partial Installation to install the remaining application server components.

WildFly or JBoss EAP in domain mode
Install the Oracle JDBC driver (domain mode)

1. In $JBOSS_HOME/modules, create the following folder:
oracle/jdbc/main

2. Copy the ojdbc6-11.2.0.3.jar oracle jdbc driver from installer/distr to $JBOSS_HOME/
modules/oracle/jdbc/main.

3. Rename ojdbc6-11.2.0.3.jar to ojdbc6.jar.
4. Copy module.xml from installer/distr to $JBOSS_HOME/modules/oracle/jdbc/main.

Alternatively, in $JBOSS_HOME/modules/oracle/jdbc/main, create the module.xml file with 
the following content:
<?xml version="1.0" encoding="UTF-8" standalone="no"?><module 
 xmlns="urn:jboss:module:1.1" name="oracle.jdbc">
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<resources>  
<resource-root path="ojdbc6.jar"/>  
</resources>  
<dependencies>  
<module name="javax.api"/>  
<module name="javax.transaction.api"/>  
<system export="true">  
<paths>  
<path name="com/sun/rowset"/>  
<path name="com/sun/rowset/internal"/>  
<path name="com/sun/rowset/providers"/>  
</paths>  
</system>  
</dependencies>  
</module>

5. In $JBOSS_HOME/domain/configuration/domain.xml:

a. Locate <profile name="full-ha">.

b. Locate the next <subsystem xmlns="urn:jboss:domain:datasources:2.0">
line that follows <profile name="full-ha"> and add the following lines after the
<drivers> tag:
<driver name="OracleJDBCDriver"
module="oracle.jdbc">
<driver-class>oracle.jdbc.OracleDriver</driver-class>
</driver>

Create a new WildFly or JBoss EAP server for the MarkView instance (domain 
mode)
Create a new domain

1. Log in to the WildFly or JBoss EAP Administration Console.
2. Select the Runtime tab.
3. On the Browser By menu, select Server Groups and click Add Server Group.
4. In the Add Server Group window, enter the following information and click Add:

• Name: <domain_name>
• Profile: full-ha
• Socket Binding Group: full-ha-sockets

Create a new server
1. In the WildFly or JBoss EAP Administration Console, select the Runtime tab.
2. On the Browser By menu, select Server Groups.
3. On the Server Group menu, select the newly created server group and click Add Server.
4. In the Add Server window, enter the following information and click Add:

• Name: <domain_name>_server, where <domain_name> is the server group name.
Add the _server postfix to your server name.

• Host: master
• Auto Start: On
• Group: <domain_name>
• Socket Binding Port Offset: 0
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5. On the Runtime tab, select Topology and click Refresh.
Start the created server by clicking its name.

Configure the port
1. In the WildFly or JBoss EAP Administration Console, select the Configuration tab.
2. On the Profile menu, select full-ha and in the full-ha-sockets field, click View.
3. Change the http port value from 8080 to 26000 and click Save.

Create the datasource
1. In $JBOSS_HOME/bin, open the jboss-cli.sh command file.
2. Run the connect rhebsr12.kofax.com:9090 command, where rhebsr12.kofax.com is 

the host name and 9090 is the administration port.
3. To create the datasource, run the command such as:

data-source --profile=full-ha --name=MarkViewDS add 
      --jndi-name=java:/jdbc/MarkViewDS --driver-name=OracleJDBCDriver 
      --connection-url=jdbc:oracle:thin:@rhebsr12.kofax.com:1522:vis01 
      --user-name=markview --password=markview --enabled=true --use-ccm=true 
      --validate-on-match=false

Where rhebsr12.kofax.com is the host name of Oracle RDBMS, 1522 is the MarkView 
schema port, and vis01 is the MarkView instance schema.

Manually deploy the mvastrs service (domain mode)
1. Copy mvastrs-ear.ear from the distribution directory:

<distribution_directory>/modules/installer-dist-(VER)/mvastrs-ear.ear

to the following location:
<installation_directory>/applications/mvastrs-ear.ear

Where <installation_directory> is the MarkView installation directory.
This is the same directory that contains the target_registry_service.properties file. See Create 
the target_registry_service.properties file for WildFly or JBoss EAP (standalone mode).

2. Log in to the WildFly or JBoss EAP Administration Console.
3. On the Deployments tab, click Add.
4. In the Create Deployment window, click Browse and select the mvastrs-ear.ear file.
5. Change the name of the application from mvastrs-ear to mvastrs.
6. On the Name menu, select the mvastrs module and click Assign.
7. Select and enable mvgroup and click Save.

Configure SSL for WildFly or JBoss EAP (domain mode)
Skip this section if you do not use Secure Sockets Layer (SSL) to provide secure web communications 
for the WildFly or JBoss EAP application server.

To configure SSL in domain mode, follow the steps in Domain mode.

Create the target_registry_service.properties file for WildFly or JBoss EAP 
(domain mode)

1. Create a file called target_registry_service.properties in the MarkView installation directory.
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2. Skip this step if you are not configuring SSL. In the target_registry_service.properties file, add 
the following line to the top of the file.
RESOURCE.mvtrs_url=http://<JBoss_Server>:<HTTP PORT>/mvastrs/markview

Where:
• <JBoss_Server> is the name of your WildFly or JBoss EAP server.
• <HTTP PORT> is your HTTP port number.

3. For SSL configuration only: In the target_registry_service.properties file, add the following line 
to the top of the file.
RESOURCE.mvtrs_url=https://<JBoss_Server>:<HTTPS PORT>/mvastrs/markview

Where:
• <JBoss_Server> is the name of your WildFly or JBoss EAP server.
• <HTTPS PORT> is your HTTPS port number.

Run the MarkView installer (domain mode)
1. Ensure all active sessions on the WildFly or JBoss EAP console are logged out.
2. Run the MarkView Partial Installation to install the remaining application server components.

Refresh a new non-production environment
1. Log in to a working MarkView environment (for example, your production environment) as an 

Administrator who is a member of the MODULE ADMINISTRATOR group.
2. Select Administration > Migration Utility.
3. Complete the values for your site using the following information.

Section Field Name Description

Application Server • WebLogic
• JBoss (use for WildFly and JBoss EAP)

Fully Qualified Hostname Enter the fully qualified hostname of the 
target application server.

Application Server Post 
Migration

HTTP Port Enter the HTTP port of the target 
application server.

Preferences Select to update the MarkView 
preference URLs to use the target 
application server.

Volume Paths Select to update the MarkView volume 
paths to use the new application server.

Configuration to be 
Updated to Reference 
Application Server Post 
Migration

Volume Path To Leave Open If you select Volume Paths, select the
Volume Path To Leave Open in the list. 
Values include:
• Close All
• DEVELOPMENT
• PRODUCTION
• TEST
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Section Field Name Description

Menu Items Select to update the MarkView menu 
item URLs to use the new application 
server.

Export Server Queue 
Assignments

Select to update the MarkView export 
queue assignments to use the new 
application server.

Enable SSL (HTTPs) on 
Application Server

Select to update the MarkView 
URLs to use HTTPs. This option also 
generates the SQL to update the 
WEBCLNT_HTTP_TYPE to the correct 
value (http or https) depending on 
whether SSL is enabled.

SSL Wallet Location If you select Enable SSL (HTTPs) on 
Application Server, enter the SSL Wallet 
Location. (Required for SSL wallets only.)

SSL Wallet Password If you select Enable SSL (HTTPs) on 
Application Server, enter the SSL Wallet 
Password. (Required for SSL wallets 
only.)

Clear Pending Export Requests Select to clear the pending export 
requests.

Route New Mail to Complete 
Mail Queue

Select to route the new mail items to the 
Complete Mail queue.

Override Outbound E-mail 
Destination

Select to update the MarkView 
Outbound Destination email 
address override preference, 
MVT_TEST_EMAIL_ADDRESS, to use a 
new email address.

Data Cleanup Tasks

E-mail Address If you select Override Outbound E-
mail Destination, enter the email 
address (required). The email address 
must meet the RFC2822 standards for 
valid syntax. See http://tools.ietf.org/
html/rfc2822#section-3.4.1 for more 
information about the RFC2822 
standards.

E-Mail Import 
Configuration

The fields in this section are no longer supported.

4. Select Generate SQL to generate the script and direct where to save the script.
5. Execute the script against the MarkView schema on the target database.
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Appendix C

Customization migration tools

To migrate the MarkView customization data, use a third-party utility to create a production 
environment image in the non-production environment. After the third-party utility performs the 
migration, the MarkView configuration data export-import tools extract and merge all MarkView 
customization data into the database. They are located in the tools directory:

Tool Description

export-config Assigns the following to the CONFIG module:
• Volumes and volume paths
• URL preferences
• URL-type menu items
• Export queue assignments
• Connector configurations

import-config Closes all open volumes and merges the data extracted by the CONFIG module into 
the database.

export-module Extracts all the data assigned to the module to a file that the import-module can 
read

import-module Merges the data from the import-module into the database

The configuration data export-import tools preserve the unique non-production environment 
settings. The process includes:
• Running the export-config tool in the non-production environment.
• Running a third-party tool to create a production environment image in the non-production 

environment.
• Running the import-config tool in the non-production environment.

 Use Kofax Capture (KC) Database Utility Application (DBUtil) to migrate the Kofax Capture 
database and integrate with the Windows file system. Do not use third-party database tools to 
migrate the Kofax Capture database. See the DBUtil online help for additional information.

Migrate customizations
1. Log in to the application server host operating system as the application server owner 

and navigate to the tools directory <distribution_directory>\tools, where 
<distribution_directory> is the location where you downloaded and decompressed the 
installation files.
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2. UNIX:
config.sh <dbHost> <dbPort> <dbSID> <mvuser> <mvpasswd> <configFile>

Windows:
config.bat <dbHost> <dbPort> <dbSID> <mvuser> <mvpasswd> <configFile>

Where:
• <dbhost> is the database server host.
• <dbport> is the MarkView main application server port (default 7777).
• <dbSID> is the database SID name.
• <mvuser> is the MarkView schema user name.
• <mvpasswd> is the password for the MarkView schema user.
• <configFile> is the name of your configuration file.

The message "Configuration is successful" appears when the import is completed. The 
message also lists the location of a log file with more information about the export.

3. Run the import-config tool to import the data.
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Uninstall Capture and Output modules

Uninstall each Capture and Output module separately.
1. Log in as the local administrator for the operating system for the Windows Capture and Output 

server.
2. Navigate to the<distribution_directory> and run the installer of a module you want to 

uninstall.
3. Click Remove. Follow the instructions on the screen.
4. Click Finish. The module is now uninstalled. You do not have to restart the computer.
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Third-party license agreement

BEA Public License Version 2.1

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1. Definitions.
• "License" shall mean the terms and conditions of this agreement.
• "Licensor" shall mean BEA Systems, Inc.
• "Legal Entity" shall mean the union of the acting entity and all other entities that control, 

are controlled by, or are under common control with that entity. For the purposes of this 
definition, "control" means
(i) the power, direct or indirect, to cause the direction or management of such entity, 
whether by contract or otherwise, or
(ii) ownership of fifty percent (50%) or more of the outstanding shares, or
(iii) beneficial ownership of such entity.

• "You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted 
by this License, including but not limited to each Contributor other than Licensor in such 
Contributor’s role as a licensee for the Software.

• "Source Format" shall mean the preferred form for making modifications, including but not 
limited to software source code, documentation source, and configuration files.

• "Object Format" shall mean any form resulting from mechanical transformation or 
translation of a Source Format, including but not limited to compiled object code, generated 
documentation, and conversions to other media types.

• "Software" shall mean the original version of the software accompanying this agreement as 
released by BEA, including in Source or Object Format, and also any documentation provided 
therewith.

• "Derivative Works" shall mean any work, whether in Source or Object Format, that is 
based on (or derived from) the Software and for which the editorial revisions, annotations, 
elaborations, or other modifications represent, as a whole, an original work of authorship. 
For the purposes of this License, Derivative Works shall not include works that remain 
separable from, or merely link (or bind by name) to the interfaces of, the Software and 
derivative works thereof.

• "Contribution" shall mean any work of authorship, including the original version of the 
Software and any modifications or additions to that Software or Derivative Works thereof, 
that is intentionally submitted to Licensor for inclusion in the Software by the copyright 
owner or by an individual or Legal Entity authorized to submit on behalf of the copyright 
owner. For the purposes of this definition, "submitted" means any form of electronic, verbal, 
or written communication sent to the Licensor or its representatives, including but not 
limited to communication on electronic mailing lists, source code control systems, and issue 
tracking systems that are managed by, or on behalf of, the Licensor for the purpose of 
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discussing and improving the Software, but excluding communication that is conspicuously 
marked or otherwise designated in writing by the copyright owner as "Not a Contribution."

• "Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom 
a Contribution has been received by Licensor and subsequently incorporated within the 
Software.

2. Grant of Copyright License. Subject to the terms and conditions of this License, each 
Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-
free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, 
publicly perform, sublicense, and distribute the Software and such Derivative Works in Source 
or Object Format. Each Contributor represents that to its knowledge it has sufficient copyright 
rights in its Contribution, if any, to grant the foregoing copyright license.

3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor 
hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, 
irrevocable (except as stated in this section) patent license to make, have made, use, offer 
to sell, sell, import, and otherwise transfer the Software, where such license applies only 
to those patent claims licensable by such Contributor that are necessarily infringed by 
their Contribution(s) alone or by combination of their Contribution(s) with the Software 
to which such Contribution(s) was submitted. If You institute patent litigation against any 
entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Software or 
a Contribution incorporated within the Software constitutes direct or contributory patent 
infringement, then any patent licenses granted to You under this License for that Software 
shall terminate as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Software or Derivative Works 
thereof in any medium, with or without modifications, and in Source or Object Format, 
provided that You meet the following conditions:
• You must give any other recipients of the Software or Derivative Works a copy of this 

License; and
• You must cause any modified files to carry prominent notices stating that You changed the 

files; and
• You must retain, in the Source Format of any Derivative Works that You distribute, BEA’s 

copyright notice, "© [Date] BEA Systems, Inc. All rights Reserved.", and all other copyright, 
patent, trademark, and attribution notices from the Source Format of the Software, 
excluding those notices that do not pertain to any part of the Derivative Works; and

• You must affix to the Software or any Derivative Works in a prominent manner BEA’s 
copyright notice, "(© [Date] BEA Systems, Inc. All rights Reserved." whenever You distribute 
the Software or such Derivative Works in Object Format.

You may add Your own copyright statement to Your modifications and may provide additional 
or different license terms and conditions for use, reproduction, or distribution of Your 
modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, 
and distribution of the Software otherwise complies with the conditions stated in this License.

5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution 
intentionally submitted for inclusion in the Software by You to the Licensor shall be under 
the terms and conditions of this License, without any additional terms or conditions. 
Notwithstanding the above, nothing herein shall supersede or modify the terms of 
any separate license agreement you may have executed with Licensor regarding such 
Contributions.
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6. Trademarks. This License does not grant permission to use the trade names, trademarks, 
service marks, or product names of the Licensor, except as required for reasonable and 
customary use in describing the origin of the Software and reproducing the content of the 
NOTICE file.

7. Disclaimer of Warranty. EXCEPT AS EXPRESSLY SET FORTH IN THIS AGREEMENT, THE SOFTWARE 
IS PROVIDED ON AN "AS IS" BASIS, WITHOUT WARRANTIES OR REPRESENTATIONS OF ANY 
KIND, EITHER EXPRESS OR IMPLIED INCLUDING, WITHOUT LIMITATION, ANY WARRANTIES OF 
TITLE, NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
You are solely responsible for determining the appropriateness of using and distributing the 
Software and assume all risks associated with Your exercise of rights under this Agreement, 
including but not limited to the risks and costs of program errors, compliance with applicable 
laws, damage to or loss of data, programs or equipment, and unavailability or interruption 
of operations. Further, You understand that although each Contributor grants the licenses 
to its Contributions set forth herein, no assurances are provided by any Contributor that its 
Contribution does not infringe the patent or other intellectual property rights of any other 
entity. Each Contributor disclaims any liability to You for claims brought by any other entity 
based on infringement of intellectual property rights or otherwise. As a condition to exercising 
the rights and licenses granted hereunder, You hereby assume sole responsibility to secure any 
other intellectual property rights needed, if any.

8. Limitation of Liability. EXCEPT AS EXPRESSLY SET FORTH IN THIS AGREEMENT, NO 
CONTRIBUTOR SHALL HAVE ANY LIABILITY TO YOU FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING WITHOUT LIMITATION LOST 
PROFITS), HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY 
OUT OF THE USE OR DISTRIBUTION OF THE SOFTWARE OR THE EXERCISE OF ANY RIGHTS 
GRANTED HEREUNDER, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

9. Accepting Warranty or Additional Liability. Commercial distributors of software may accept 
certain responsibilities with respect to end users, business partners and the like. While this 
license is intended to facilitate the commercial use of the Software, if You include the Software 
in a commercial product offering, You may do so only in a manner which does not create 
potential liability for any Contributor. Therefore, if You include the Software in a commercial 
product offering, You shall and hereby do agree to defend and indemnify each and every 
Contributor against any losses, damages and costs (collectively "Losses") arising from claims, 
lawsuits and other legal actions brought by a third party against such Contributor(s) to the 
extent caused by Your acts or omissions in connection with Your distribution of the Software 
in a commercial product offering. The obligations in this section do not apply to any claims or 
Losses relating to any actual or alleged intellectual property infringement. In order to qualify to 
receive indemnification from You, a Contributor must:

a. promptly notify You in writing of such claim, and

b. allow the You to control, and cooperate with the You in, the defense and any related 
settlement negotiations.

The Contributor indemnified by You may participate in any such claim at its own expense.
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